- Update to 1.0.0.0

- Convert to USES qmake and dos2unix
- Convert to staging
- Use LOCALBASE instead of hardconding /usr/local.
- Fix build on 10 and head with new libc++

PR:		ports/183933
Submitted by:	Fernando <fernando.apesteguia@gmail.com> (maintainer)
This commit is contained in:
Guido Falsi 2013-11-19 22:39:50 +00:00
parent e843389660
commit f153879e96
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=334360
6 changed files with 31 additions and 37 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= basic256
PORTVERSION= 0.9.9.64
PORTVERSION= 1.0.0.0
CATEGORIES= lang
MASTER_SITES= SF
MASTER_SITE_SUBDIR= kidbasic/${PORTNAME}
@ -18,17 +18,16 @@ BUILD_DEPENDS= espeak:${PORTSDIR}/audio/espeak \
WRKSRC= ${WRKDIR}
USES= bison
USES= bison dos2unix qmake
USE_SDL= sdl mixer
USE_QT4= corelib gui network xml webkit moc_build qmake_build rcc_build uic_build
USE_DOS2UNIX= yes
HAS_CONFIGURE= yes
QMAKE_PRO= BASIC256.pro
MAKE_JOBS_UNSAFE=yes
NO_STAGE= yes
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} "PREFIX=${PREFIX}" BASIC256.pro
post-patch:
@${REINPLACE_CMD} -e 's/mutex/mymutex/' ${WRKSRC}/*.cpp
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/${QMAKE_PRO}
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (basic256_0.9.9.64.tgz) = 8a3a5f919502d98329e3922eb656d76bd69142e7bbb31c8cf5d78af1fbd3b991
SIZE (basic256_0.9.9.64.tgz) = 1919053
SHA256 (basic256_1.0.0.0.tgz) = 4eda84360eb576b38b7e514aeb8f2700681f81521932532d60693bc6c85a6652
SIZE (basic256_1.0.0.0.tgz) = 1848926

View file

@ -1,6 +1,15 @@
--- BASIC256.pro.orig 2013-02-11 23:43:57.000000000 +0100
+++ BASIC256.pro 2013-02-11 23:47:27.000000000 +0100
@@ -101,19 +101,19 @@
--- BASIC256.pro.orig 2013-11-13 18:26:47.000000000 +0100
+++ BASIC256.pro 2013-11-13 18:36:29.000000000 +0100
@@ -82,7 +82,7 @@
## TTS Option 2 - use the espeak library
DEFINES += ESPEAK
- INCLUDEPATH += /usr/include/espeak
+ INCLUDEPATH += %%LOCALBASE%%/include/espeak
LIBS += -lespeak
LIBS += -lm
@@ -113,19 +113,19 @@
# rules for make install
########
exampleFiles.files = ./Examples

View file

@ -0,0 +1,10 @@
--- BasicGraph.cpp.orig 2013-09-28 18:25:56.000000000 +0200
+++ BasicGraph.cpp 2013-09-28 18:26:06.000000000 +0200
@@ -37,7 +37,6 @@
#include <QPrinter>
#endif
-using namespace std;
#include "BasicGraph.h"

View file

@ -1,11 +0,0 @@
--- RunController.cpp.orig 2011-08-28 20:02:12.000000000 +0200
+++ RunController.cpp 2011-08-28 20:02:22.000000000 +0200
@@ -56,7 +56,7 @@
#ifdef LINUX_ESPEAK
- #include <speak_lib.h>
+ #include <espeak/speak_lib.h>
#endif
#ifdef LINUX_FLITE

View file

@ -106,6 +106,7 @@ bin/BASIC256
%%DATADIR%%/Examples/testing/testplusplus2.kbs
%%DATADIR%%/Examples/testing/testsubroutinebyref.kbs
%%DATADIR%%/Examples/testing/testsuite.kbs
%%DATADIR%%/Examples/testing/testsuite_functions.kbs
%%DATADIR%%/Examples/testing/testtextfont.kbs
%%DATADIR%%/Examples/testing/testtime.kbs
%%DATADIR%%/Examples/testing/uaarray.kbs
@ -803,16 +804,10 @@ bin/BASIC256
%%DATADIR%%/help/graphicsutilitiesstampmaker.html
%%DATADIR%%/help/graphicsutility.html
%%DATADIR%%/help/index.html
%%DATADIR%%/help/jp_start.html
%%DATADIR%%/help/lib/exe/alert.png
%%DATADIR%%/help/lib/exe/arc_example.png
%%DATADIR%%/help/lib/exe/basic256.png
%%DATADIR%%/help/lib/exe/chord_example.png
%%DATADIR%%/help/lib/exe/circle.png
%%DATADIR%%/help/lib/exe/color.png
%%DATADIR%%/help/lib/exe/confirm.png
%%DATADIR%%/help/lib/exe/css1353871590.css
%%DATADIR%%/help/lib/exe/css1364650667.css
%%DATADIR%%/help/lib/exe/de.png
%%DATADIR%%/help/lib/exe/en.png
%%DATADIR%%/help/lib/exe/en_cir.png
@ -841,13 +836,8 @@ bin/BASIC256
%%DATADIR%%/help/lib/exe/fr_cos.jpg
%%DATADIR%%/help/lib/exe/fr_sin.jpg
%%DATADIR%%/help/lib/exe/fr_tan.jpg
%%DATADIR%%/help/lib/exe/gamesballoons.png
%%DATADIR%%/help/lib/exe/gamescopycat.png
%%DATADIR%%/help/lib/exe/gamesspinner.png
%%DATADIR%%/help/lib/exe/graphicsutilitiesstamp2sprite.png
%%DATADIR%%/help/lib/exe/jmreneau_mobius.png
%%DATADIR%%/help/lib/exe/jmreneau_morie.png
%%DATADIR%%/help/lib/exe/line.png
%%DATADIR%%/help/lib/exe/nl.png
%%DATADIR%%/help/lib/exe/nl_array.png
%%DATADIR%%/help/lib/exe/nl_arrays_disp.png
@ -866,9 +856,7 @@ bin/BASIC256
%%DATADIR%%/help/lib/exe/nl_wrong_string.png
%%DATADIR%%/help/lib/exe/opensearch.php
%%DATADIR%%/help/lib/exe/pie_chart.png
%%DATADIR%%/help/lib/exe/prompt.png
%%DATADIR%%/help/lib/exe/pt.png
%%DATADIR%%/help/lib/exe/rect.png
%%DATADIR%%/help/lib/exe/ro.png
%%DATADIR%%/help/lib/exe/ru.png
%%DATADIR%%/help/lib/exe/ru_cir.png
@ -878,7 +866,6 @@ bin/BASIC256
%%DATADIR%%/help/lib/exe/ru_radians.png
%%DATADIR%%/help/lib/exe/ru_stamp.png
%%DATADIR%%/help/lib/exe/sp.png
%%DATADIR%%/help/lib/exe/stampmaker.png
%%DATADIR%%/help/lib/images/license/button/cc-by-nc-sa.png
%%DATADIR%%/help/lib/images/smileys/fixme.gif
%%DATADIR%%/help/lib/images/smileys/icon_exclaim.gif