new port graphics/linplasma, a bit of eyecandy for SVGAlib
This commit is contained in:
parent
c5d5a0fd6a
commit
f175fe0ecd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34099
6 changed files with 72 additions and 0 deletions
|
@ -99,6 +99,7 @@
|
|||
SUBDIR += libmorph
|
||||
SUBDIR += libungif
|
||||
SUBDIR += libwmf
|
||||
SUBDIR += linplasma
|
||||
SUBDIR += linux-bmrt
|
||||
SUBDIR += linux-jpeg
|
||||
SUBDIR += linux-png
|
||||
|
|
48
graphics/linplasma/Makefile
Normal file
48
graphics/linplasma/Makefile
Normal file
|
@ -0,0 +1,48 @@
|
|||
# New ports collection makefile for: linplasma
|
||||
# Date created: 2000-10-22
|
||||
# Whom: trevor
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= linplasma
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SUNSITE}
|
||||
MASTER_SITE_SUBDIR= apps/graphics/hacks/svgalib
|
||||
|
||||
MAINTAINER= trevor@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
|
||||
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
DOCFILES= README GPL
|
||||
DOCDIR= share/doc/${PORTNAME}/
|
||||
PLIST= ${WRKDIR}/pkg-plist
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/Makefile
|
||||
@${PERL} -pi -e "s:PI:M_PI:g" ${WRKSRC}/linplasma.c
|
||||
|
||||
pre-install:
|
||||
${ECHO} "bin/linplasma" > ${PLIST}
|
||||
.if !defined(NOPORTDOCS)
|
||||
.for i in ${DOCFILES}
|
||||
${ECHO} -n ${DOCDIR} >> ${PLIST}
|
||||
${ECHO} ${i} >> ${PLIST}
|
||||
.endfor
|
||||
${ECHO} -n "@dirrm " >> ${PLIST}
|
||||
${ECHO} ${DOCDIR} >> ${PLIST}
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL} -c -g wheel -o root -m 4755 ${WRKSRC}/linplasma ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/${DOCDIR}
|
||||
.for i in ${DOCFILES}
|
||||
${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${DOCDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/linplasma/distinfo
Normal file
1
graphics/linplasma/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (linplasma-1.0.tar.gz) = aa1f7c4c696da803edd8ae0936fd8817
|
15
graphics/linplasma/files/patch-Makefile
Normal file
15
graphics/linplasma/files/patch-Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- Makefile.orig Sun Oct 22 04:09:35 2000
|
||||
+++ Makefile Sun Oct 22 04:11:27 2000
|
||||
@@ -2,10 +2,9 @@
|
||||
# Makefile for LinPlasma
|
||||
#
|
||||
|
||||
-CC=gcc
|
||||
+CC?=gcc
|
||||
|
||||
-# optimize a lot
|
||||
-CFLAGS=-O3
|
||||
+CFLAGS += -L%%PREFIX%%/lib -I%%PREFIX%%/include
|
||||
|
||||
LIBS=-lvga -lvgagl -lm
|
||||
|
1
graphics/linplasma/pkg-comment
Normal file
1
graphics/linplasma/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Sinus plasma, an SVGAlib demo
|
6
graphics/linplasma/pkg-descr
Normal file
6
graphics/linplasma/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
This program is a display hack for SVGAlib.
|
||||
|
||||
To exit the program, press "any" key.
|
||||
|
||||
Trevor Johnson
|
||||
trevor@FreeBSD.org
|
Loading…
Reference in a new issue