Fix a few package list errors I introduced yesterday.

This commit is contained in:
Tom Hukins 2005-01-24 20:49:59 +00:00
parent 3d038784ad
commit f178ee0e58
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=127223
4 changed files with 46 additions and 4 deletions

View file

@ -28,7 +28,7 @@ RESTRICTED_FILES= ${ALCATELDRIVER}
WRKSRC= ${WRKDIR}/${SPEEDTOUCH}
MAN1= modem_run.1 pppoa2.1 pppoa3.1
MAN8= modem_run.8 pppoa2.8 pppoa3.8
USE_BZIP2= yes
.include <bsd.port.pre.mk>
@ -37,6 +37,10 @@ post-extract:
@${TAR} -zxf ${DISTDIR}/${ALCATELDRIVER} -C ${WRKSRC}
@${REINPLACE_CMD} s/-lkse/${PTHREAD_LIBS}/g ${WRKSRC}/configure
post-patch:
@${REINPLACE_CMD} 's/\@INSTALL_MAN\@/${INSTALL_MAN}/' \
${WRKSRC}/doc-bsd/Makefile.in
post-install:
${INSTALL} -m 0755 -o root -g wheel -d ${PREFIX}/libdata
${INSTALL_DATA} ${WRKSRC}/mgmt/mgmt.o ${PREFIX}/libdata

View file

@ -0,0 +1,27 @@
--- doc-bsd/Makefile.in.orig Wed Sep 29 21:56:31 2004
+++ doc-bsd/Makefile.in Mon Jan 24 20:10:17 2005
@@ -51,6 +51,7 @@
make_bindir=${rootdir}/bin
include= -I. -I${includedir} -I${oldincludedir}
INSTALL=@INSTALL@
+INSTALL_MAN=@INSTALL_MAN@
installuser=@installuser@
man1dir=${mandir}/man1
@@ -106,13 +107,10 @@
install-man:
@test -d "$(man1dir)" || $(INSTALL) -c -d "$(man1dir)"
- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/speedtouch-setup.1 "$(man1dir)"
- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/speedtouch-start.1 "$(man1dir)"
- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/speedtouch-stop.1 "$(man1dir)"
@test -d "$(man8dir)" || $(INSTALL) -c -d "$(man8dir)"
- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/modem_run.8 "$(man8dir)"
- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/pppoa2.8 "$(man8dir)"
- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/pppoa3.8 "$(man8dir)"
+ $(INSTALL_MAN) ../doc-linux/man/modem_run.8 "$(man8dir)"
+ $(INSTALL_MAN) ../doc-linux/man/pppoa2.8 "$(man8dir)"
+ $(INSTALL_MAN) ../doc-linux/man/pppoa3.8 "$(man8dir)"
uninstall :
rm -rf "$(docdir)"

View file

@ -0,0 +1,14 @@
--- src/Makefile.in.orig Wed Sep 29 21:56:31 2004
+++ src/Makefile.in Mon Jan 24 17:55:49 2005
@@ -184,11 +184,6 @@
rm -f Makefile
install:
- $(INSTALL) -d "$(bindir)"
- $(INSTALL) -m 0755 speedtouch-setup "$(bindir)"
- $(INSTALL) -m 0755 speedtouch-start "$(bindir)"
- $(INSTALL) -m 0755 speedtouch-stop "$(bindir)"
- $(INSTALL) -d "$(sysconfdir)/speedtouch"
uninstall:
$(RM) "$(bindir)/speedtouch-setup"

View file

@ -1,6 +1,3 @@
bin/speedtouch-setup
bin/speedtouch-start
bin/speedtouch-stop
sbin/modem_run
sbin/pppoa2
sbin/pppoa3