net/py-rainbowstream: Update to 1.4.0

This commit is contained in:
Kubilay Kocak 2019-05-18 10:10:50 +00:00
parent 8cee86f025
commit f1bb9d1401
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=501946
5 changed files with 21 additions and 13 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rainbowstream
PORTVERSION= 1.3.5
PORTREVISION= 1
PORTVERSION= 1.4.0
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -23,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pysocks>0:net/py-pysocks@${PY_FLAVOR}
# Actually 2.7,3.2-
USES= python:2.7
USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1471426336
SHA256 (rainbowstream-1.3.5.tar.gz) = 3c44fb37c766d146f4cda5d21d2db86cf19ff873b748b5493b44db805ed20b29
SIZE (rainbowstream-1.3.5.tar.gz) = 47971
TIMESTAMP = 1537720983
SHA256 (rainbowstream-1.4.0.tar.gz) = 16881d8bb15416389eeaf4ceee7a588069060c216b55e7602dbcff5134feb7cc
SIZE (rainbowstream-1.4.0.tar.gz) = 48113

View file

@ -1,9 +1,9 @@
# Make pocket actually optional
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=220312
--- rainbowstream/rainbow.py.orig 2017-07-03 10:00:26 UTC
--- rainbowstream/rainbow.py.orig 2018-08-28 02:35:54 UTC
+++ rainbowstream/rainbow.py
@@ -20,7 +20,10 @@ from twitter.oauth import OAuth, read_to
@@ -20,7 +20,10 @@ from twitter.oauth import OAuth, read_token_file
from twitter.oauth_dance import oauth_dance
from twitter.util import printNicely

View file

@ -1,9 +1,9 @@
# Make pocket actually optional
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=220312
--- setup.py.orig 2016-08-16 14:49:45 UTC
--- setup.py.orig 2018-08-30 11:36:46 UTC
+++ setup.py
@@ -15,14 +15,17 @@ version = '1.3.5'
@@ -15,14 +15,17 @@ version = '1.4.0'
install_requires = [
"python-dateutil",
"arrow",
@ -21,9 +21,18 @@
+}
+
# Default user (considers non virtualenv method)
user = os.environ.get('SUDO_USER', os.environ['USER'])
user = os.environ.get('SUDO_USER', os.environ.get('USER', None))
@@ -65,6 +68,7 @@ setup(name='rainbowstream',
@@ -41,7 +44,7 @@ if not os.path.isfile(default):
setup(name='rainbowstream',
version=version,
description="A smart and nice Twitter client on terminal.",
- long_description=open("./README.rst", "r").read(),
+ long_description=open("./README.rst", "rb").read().decode("utf-8"),
classifiers=[
"Development Status :: 5 - Production/Stable",
"Environment :: Console",
@@ -68,6 +71,7 @@ setup(name='rainbowstream',
include_package_data=True,
zip_safe=True,
install_requires=install_requires,

View file

@ -1,4 +1,4 @@
Terminal-based Twitter Client. Realtime tweetstream, compose, search,
favorite ... and much more fun directly from terminal
WWW: http://www.rainbowstream.org/
WWW: https://github.com/orakaro/rainbowstream