- Update qalculate to 0.8.0, which splits out libqalculate

PR:		ports/81832
Submitted by:	Sergey Akifyev <asa@agava.com> (maintainer)
This commit is contained in:
Pav Lucistnik 2005-06-07 09:01:36 +00:00
parent 283ce80207
commit f212fd9320
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=136977
13 changed files with 151 additions and 121 deletions

View file

@ -99,6 +99,7 @@
SUBDIR += libgmp4
SUBDIR += libmath++
SUBDIR += libneural
SUBDIR += libqalculate
SUBDIR += libranlib
SUBDIR += linalg
SUBDIR += linpack

View file

@ -0,0 +1,31 @@
# New ports collection makefile for: libqalculate
# Date created: 03 June 2004
# Whom: Sergey Akifyev <asa@agava.com>
#
# $FreeBSD$
#
PORTNAME= libqalculate
PORTVERSION= 0.8.0
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= qalculate
MAINTAINER= asa@agava.com
COMMENT= Very powerful GUI calculator for GNOME (backend library)
LIB_DEPENDS= cln.3:${PORTSDIR}/math/cln
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_INC_LIBTOOL_VER=15
USE_GNOME= intlhack lthack pkgconfig gnomehack glib20 libxml2
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= "does not configure"
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,2 @@
MD5 (libqalculate-0.8.0.tar.gz) = c3b63fa34093e519d9ff55a590713620
SIZE (libqalculate-0.8.0.tar.gz) = 665416

View file

@ -1,5 +1,5 @@
--- src/libqalculate/Calculator.cc.orig Fri Mar 11 14:36:10 2005
+++ src/libqalculate/Calculator.cc Fri Mar 11 14:36:17 2005
--- libqalculate/Calculator.cc.orig Fri Jun 3 12:25:49 2005
+++ libqalculate/Calculator.cc Fri Jun 3 12:25:59 2005
@@ -33,7 +33,7 @@
#include <sys/types.h>
#include <sys/stat.h>

View file

@ -0,0 +1,11 @@
--- src/Makefile.in.orig Tue Jun 7 10:42:56 2005
+++ src/Makefile.in Tue Jun 7 10:44:51 2005
@@ -530,7 +530,7 @@
install-exec-local:
- cd $(DESTDIR)$(bindir) && rm -f qalculate; $(LN_S) @LN_QALCULATE@ qalculate
+# cd $(DESTDIR)$(bindir) && rm -f qalculate; $(LN_S) @LN_QALCULATE@ qalculate
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:

View file

@ -1,5 +1,5 @@
--- src/qalc.cc.orig Fri Mar 11 14:50:18 2005
+++ src/qalc.cc Fri Mar 11 14:50:31 2005
--- src/qalc.cc.orig Fri Jun 3 12:51:31 2005
+++ src/qalc.cc Fri Jun 3 12:51:45 2005
@@ -16,7 +16,7 @@
#include <time.h>
#include <pthread.h>

View file

@ -0,0 +1,6 @@
Qalculate! is a multi-purpose desktop calculator. It is small and simple to
use but with much power and versatility underneath. Features include
customizable functions, units, arbitrary precision, plotting, and
a user-friendly interface.
WWW: http://qalculate.sourceforge.net

View file

@ -0,0 +1,29 @@
bin/qalc
include/libqalculate/Function.h
include/libqalculate/Calculator.h
include/libqalculate/DataSet.h
include/libqalculate/Variable.h
include/libqalculate/ExpressionItem.h
include/libqalculate/Number.h
include/libqalculate/MathStructure.h
include/libqalculate/Prefix.h
include/libqalculate/util.h
include/libqalculate/includes.h
include/libqalculate/Unit.h
include/libqalculate/BuiltinFunctions.h
include/libqalculate/qalculate.h
lib/libqalculate.a
lib/libqalculate.la
lib/libqalculate.so
lib/libqalculate.so.0
libdata/pkgconfig/libqalculate.pc
share/locale/sv/LC_MESSAGES/libqalculate.mo
share/qalculate/datasets.xml
share/qalculate/elements.xml
share/qalculate/functions.xml
share/qalculate/planets.xml
share/qalculate/prefixes.xml
share/qalculate/units.xml
share/qalculate/variables.xml
@dirrm include/libqalculate
@dirrm share/qalculate

View file

@ -6,17 +6,16 @@
#
PORTNAME= qalculate
PORTVERSION= 0.7.2
PORTREVISION= 1
PORTVERSION= 0.8.0
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
#DISTNAME= ${PORTNAME}-gtk-${PORTVERSION}
DISTNAME= ${PORTNAME}-gtk-${PORTVERSION}
MAINTAINER= asa@agava.com
COMMENT= Very powerful GUI calculator for GNOME
LIB_DEPENDS= cln.3:${PORTSDIR}/math/cln
LIB_DEPENDS= qalculate.0:${PORTSDIR}/math/libqalculate
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
wget:${PORTSDIR}/ftp/wget
@ -25,15 +24,5 @@ USE_GMAKE= yes
USE_INC_LIBTOOL_VER=15
USE_GNOME= gnomeprefix gnomehack intlhack libglade2 libgnome
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
# cln is built with gcc 3.4 on FreeBSD 4.x
USE_GCC= 3.4
# in FreeBSD 4.x struct liconv does not contain int_p_cs_precedes
EXTRA_PATCHES= ${FILESDIR}/extra-patch-FreeBSD4
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (qalculate-0.7.2.tar.gz) = 75af1f213829fb0905ce6784ee0e1017
SIZE (qalculate-0.7.2.tar.gz) = 1504796
MD5 (qalculate-gtk-0.8.0.tar.gz) = baf8571de19dbcc41ef22cd8b4bab24b
SIZE (qalculate-gtk-0.8.0.tar.gz) = 1194828

View file

@ -1,11 +0,0 @@
--- src/libqalculate/Calculator.cc.orig Sun Aug 29 17:22:28 2004
+++ src/libqalculate/Calculator.cc Sun Aug 29 17:27:37 2004
@@ -225,7 +225,7 @@
saved_locale = strdup(setlocale(LC_NUMERIC, NULL));
struct lconv *lc = localeconv();
- place_currency_code_before = lc->int_p_cs_precedes;
+ place_currency_code_before = lc->p_cs_precedes;
place_currency_sign_before = lc->p_cs_precedes;
setlocale(LC_NUMERIC, "C");
ILLEGAL_IN_NAMES = DOT_S + RESERVED OPERATORS SPACES PARENTHESISS VECTOR_WRAPS;

View file

@ -3,4 +3,6 @@ use but with much power and versatility underneath. Features include
customizable functions, units, arbitrary precision, plotting, and
a user-friendly interface.
This package includes libqalculate - Qalculate! backend library
WWW: http://qalculate.sourceforge.net

View file

@ -1,91 +1,61 @@
bin/qalc
bin/qalculate
bin/qalculate-gtk
include/libqalculate/Function.h
include/libqalculate/Calculator.h
include/libqalculate/DataSet.h
include/libqalculate/Variable.h
include/libqalculate/ExpressionItem.h
include/libqalculate/Number.h
include/libqalculate/MathStructure.h
include/libqalculate/Prefix.h
include/libqalculate/util.h
include/libqalculate/includes.h
include/libqalculate/Unit.h
include/libqalculate/BuiltinFunctions.h
include/libqalculate/qalculate.h
lib/libqalculate.so.0
lib/libqalculate.so
lib/libqalculate.la
lib/libqalculate.a
libdata/pkgconfig/libqalculate.pc
share/gnome/applnk/Utilities/qalculate.desktop
share/gnome/applications/qalculate.desktop
share/gnome/help/qalculate/C/appendixa.xml
share/gnome/help/qalculate/C/appendixb.xml
share/gnome/help/qalculate/C/appendixc.xml
share/gnome/help/qalculate/C/legal.xml
share/gnome/help/qalculate/C/qalculate.xml
share/gnome/help/qalculate/C/figures/calculation-history.png
share/gnome/help/qalculate/C/figures/calculator-buttons-screen.png
share/gnome/help/qalculate/C/figures/calculator-buttons.png
share/gnome/help/qalculate/C/figures/completion.png
share/gnome/help/qalculate/C/figures/convert-number-bases.png
share/gnome/help/qalculate/C/figures/convert-unit.png
share/gnome/help/qalculate/C/figures/edit-function.png
share/gnome/help/qalculate/C/figures/edit-matrix.png
share/gnome/help/qalculate/C/figures/edit-unit.png
share/gnome/help/qalculate/C/figures/function-manager.png
share/gnome/help/qalculate/C/figures/gnuplot.png
share/gnome/help/qalculate/C/figures/import-csv.png
share/gnome/help/qalculate/C/figures/insert-function-screen.png
share/gnome/help/qalculate/C/figures/insert-function.png
share/gnome/help/qalculate/C/figures/mainwindow-screen.png
share/gnome/help/qalculate/C/figures/mainwindow.png
share/gnome/help/qalculate/C/figures/plot-data.png
share/gnome/help/qalculate/C/figures/plot-settings.png
share/gnome/help/qalculate/C/figures/store-variable.png
share/gnome/help/qalculate/C/figures/unit-manager.png
share/gnome/help/qalculate/C/figures/variable-manager.png
share/gnome/omf/qalculate/qalculate-C.omf
share/gnome/qalculate/glade/about.glade
share/gnome/qalculate/glade/argumentrules.glade
share/gnome/qalculate/glade/csvexport.glade
share/gnome/qalculate/glade/csvimport.glade
share/gnome/qalculate/glade/datasetedit.glade
share/gnome/qalculate/glade/datasets.glade
share/gnome/qalculate/glade/decimals.glade
share/gnome/qalculate/glade/functionedit.glade
share/gnome/qalculate/glade/functions.glade
share/gnome/qalculate/glade/main.glade
share/gnome/qalculate/glade/matrixedit.glade
share/gnome/qalculate/glade/namesedit.glade
share/gnome/qalculate/glade/nbases.glade
share/gnome/qalculate/glade/nbexpression.glade
share/gnome/qalculate/glade/periodictable.glade
share/gnome/qalculate/glade/plot.glade
share/gnome/qalculate/glade/precision.glade
share/gnome/qalculate/glade/preferences.glade
share/gnome/qalculate/glade/unit.glade
share/gnome/qalculate/glade/unitedit.glade
share/gnome/qalculate/glade/units.glade
share/gnome/qalculate/glade/unknownedit.glade
share/gnome/qalculate/glade/variableedit.glade
share/gnome/qalculate/glade/variables.glade
share/gnome/qalculate/datasets.xml
share/gnome/qalculate/elements.xml
share/gnome/qalculate/functions.xml
share/gnome/qalculate/planets.xml
share/gnome/qalculate/prefixes.xml
share/gnome/qalculate/units.xml
share/gnome/qalculate/variables.xml
share/locale/sv/LC_MESSAGES/qalculate.mo
@dirrm include/libqalculate
@dirrm share/gnome/applnk/Utilities
@dirrm share/gnome/applnk
@dirrm share/gnome/help/qalculate/C/figures
@dirrm share/gnome/help/qalculate/C
@dirrm share/gnome/help/qalculate
@dirrm share/gnome/omf/qalculate
@dirrm share/gnome/qalculate/glade
@dirrm share/gnome/qalculate
share/locale/sv/LC_MESSAGES/qalculate-gtk.mo
share/gnome/applications/qalculate-gtk.desktop
share/gnome/help/qalculate-gtk/C/legal.xml
share/gnome/help/qalculate-gtk/C/appendixa.xml
share/gnome/help/qalculate-gtk/C/appendixb.xml
share/gnome/help/qalculate-gtk/C/appendixc.xml
share/gnome/help/qalculate-gtk/C/qalculate-gtk.xml
share/gnome/help/qalculate-gtk/C/figures/calculation-history.png
share/gnome/help/qalculate-gtk/C/figures/calculator-buttons-screen.png
share/gnome/help/qalculate-gtk/C/figures/calculator-buttons.png
share/gnome/help/qalculate-gtk/C/figures/completion.png
share/gnome/help/qalculate-gtk/C/figures/convert-number-bases.png
share/gnome/help/qalculate-gtk/C/figures/convert-unit.png
share/gnome/help/qalculate-gtk/C/figures/edit-function.png
share/gnome/help/qalculate-gtk/C/figures/edit-matrix.png
share/gnome/help/qalculate-gtk/C/figures/edit-unit.png
share/gnome/help/qalculate-gtk/C/figures/function-manager.png
share/gnome/help/qalculate-gtk/C/figures/gnuplot.png
share/gnome/help/qalculate-gtk/C/figures/import-csv.png
share/gnome/help/qalculate-gtk/C/figures/insert-function-screen.png
share/gnome/help/qalculate-gtk/C/figures/insert-function.png
share/gnome/help/qalculate-gtk/C/figures/mainwindow-screen.png
share/gnome/help/qalculate-gtk/C/figures/mainwindow.png
share/gnome/help/qalculate-gtk/C/figures/plot-data.png
share/gnome/help/qalculate-gtk/C/figures/plot-settings.png
share/gnome/help/qalculate-gtk/C/figures/store-variable.png
share/gnome/help/qalculate-gtk/C/figures/unit-manager.png
share/gnome/help/qalculate-gtk/C/figures/variable-manager.png
share/gnome/omf/qalculate-gtk/qalculate-gtk-C.omf
share/gnome/qalculate-gtk/glade/about.glade
share/gnome/qalculate-gtk/glade/argumentrules.glade
share/gnome/qalculate-gtk/glade/csvexport.glade
share/gnome/qalculate-gtk/glade/csvimport.glade
share/gnome/qalculate-gtk/glade/datasetedit.glade
share/gnome/qalculate-gtk/glade/datasets.glade
share/gnome/qalculate-gtk/glade/decimals.glade
share/gnome/qalculate-gtk/glade/functionedit.glade
share/gnome/qalculate-gtk/glade/functions.glade
share/gnome/qalculate-gtk/glade/main.glade
share/gnome/qalculate-gtk/glade/matrixedit.glade
share/gnome/qalculate-gtk/glade/namesedit.glade
share/gnome/qalculate-gtk/glade/nbases.glade
share/gnome/qalculate-gtk/glade/nbexpression.glade
share/gnome/qalculate-gtk/glade/periodictable.glade
share/gnome/qalculate-gtk/glade/plot.glade
share/gnome/qalculate-gtk/glade/precision.glade
share/gnome/qalculate-gtk/glade/preferences.glade
share/gnome/qalculate-gtk/glade/unit.glade
share/gnome/qalculate-gtk/glade/units.glade
share/gnome/qalculate-gtk/glade/unitedit.glade
share/gnome/qalculate-gtk/glade/unknownedit.glade
share/gnome/qalculate-gtk/glade/variableedit.glade
share/gnome/qalculate-gtk/glade/variables.glade
@dirrm share/gnome/help/qalculate-gtk/C/figures
@dirrm share/gnome/help/qalculate-gtk/C
@dirrm share/gnome/help/qalculate-gtk
@dirrm share/gnome/omf/qalculate-gtk
@dirrm share/gnome/qalculate-gtk/glade
@dirrm share/gnome/qalculate-gtk