- update 2.1.1

- fix build with custom LOCALBASE [1]

Submitted by:	maintainer
Reported by:	QATty [1]
This commit is contained in:
Ion-Mihai Tetcu 2009-06-18 15:51:47 +00:00
parent fd55934d74
commit f226588423
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=236228
3 changed files with 24 additions and 11 deletions

View file

@ -7,7 +7,7 @@
#
PORTNAME= tables
PORTVERSION= 2.1
PORTVERSION= 2.1.1
CATEGORIES= devel python
MASTER_SITES= http://www.pytables.org/download/stable/ \
http://www.pytables.org/download/py${PORTNAME}-${PORTVERSION}/

View file

@ -1,6 +1,6 @@
MD5 (tables-2.1.tar.gz) = 68393f93b7307f7ee3dedad74fb53584
SHA256 (tables-2.1.tar.gz) = 59f8bc7d1f08262c6db5cd13831fa14d4bc9f87def2b629c8330899dd668dd77
SIZE (tables-2.1.tar.gz) = 4701236
MD5 (pytablesmanual-2.1.pdf) = 7ade045d4de763e58782482320beb721
SHA256 (pytablesmanual-2.1.pdf) = 26c578fa7cf82fe89937757a613409ebc4029496fe23211d2055b659a88ed6cf
SIZE (pytablesmanual-2.1.pdf) = 1732222
MD5 (tables-2.1.1.tar.gz) = fce2100e655e91849b3d73f22274b0c4
SHA256 (tables-2.1.1.tar.gz) = b53b119eb893377da174fc62d7249dc2f47420e2905d1eb5c97dd2f494be7e68
SIZE (tables-2.1.1.tar.gz) = 4689343
MD5 (pytablesmanual-2.1.1.pdf) = 82db5b774ec9a5df4873e578b757a5b2
SHA256 (pytablesmanual-2.1.1.pdf) = f5b30b50e0836e89cf8377246874277ce4b72de98bea7abfaf807f1fc5fa33aa
SIZE (pytablesmanual-2.1.1.pdf) = 1738363

View file

@ -1,6 +1,6 @@
--- setup.py.orig Wed Jul 26 23:43:50 2006
+++ setup.py Wed Jul 26 23:44:46 2006
@@ -72,8 +72,8 @@
--- setup.py.orig 2009-06-18 17:57:21.000000000 +0800
+++ setup.py 2009-06-18 18:02:43.000000000 +0800
@@ -81,8 +81,8 @@
debug = '--debug' in sys.argv
# Global variables
@ -9,5 +9,18 @@
+lib_dirs = ['%%LOCALBASE%%/lib']
+inc_dirs = ['%%LOCALBASE%%/include']
optional_libs = []
data_files = [] # list of data files to add to packages (mainly for DLL's)
@@ -91,10 +91,10 @@
default_runtime_dirs = None
if os.name == 'posix':
- default_header_dirs = ['/usr/include', '/usr/local/include']
+ default_header_dirs = ['/usr/include', '/usr/local/include','%%LOCALBASE%%/include']
default_library_dirs = [
os.path.join(_tree, _arch)
- for _tree in ('/', '/usr', '/usr/local')
+ for _tree in ('/', '/usr', '/usr/local','%%LOCALBASE%%')
for _arch in ('lib64', 'lib') ]
default_runtime_dirs = default_library_dirs
default_header_dirs = None