SeqAn is an open source C++ library of efficient algorithms

and data structures for the analysis of sequences with the
focus on biological data. The library is licensed under the
3-clause BSD license except the applications which are GPL.

WWW: http://www.seqan.de/

PR:		167571
Submitted by:	Hannes <h2+fbsdports@fsfe.org>
This commit is contained in:
Dmitry Marakasov 2012-06-06 17:51:33 +00:00
parent 6d5f661a66
commit f234335598
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298619
8 changed files with 2230 additions and 0 deletions

View file

@ -85,6 +85,7 @@
SUBDIR += recombine
SUBDIR += ruby-bio
SUBDIR += seaview
SUBDIR += seqan
SUBDIR += seqio
SUBDIR += sim4
SUBDIR += ssaha

49
biology/seqan/Makefile Normal file
View file

@ -0,0 +1,49 @@
# New ports collection makefile for: seqan
# Date created: 3 May 2012
# Whom: h2
#
# $FreeBSD$
#
PORTNAME= seqan
PORTVERSION= 1.3.1
CATEGORIES= biology
MASTER_SITES= http://ftp.seqan.de/releases/
MAINTAINER= h2+fsbdports@fsfe.org
COMMENT= C++ Sequence Analysis Library
LICENSE= BSD GPLv3
LICENSE_COMB= multi
LICENSE_FILE_BSD=${WRKSRC}/seqan/LICENSE
LICENSE_FILE_GPLv3=${WRKSRC}/apps/LICENSE
USE_ZIP= yes
USE_CMAKE= yes
CMAKE_SOURCE_PATH=${WRKSRC}/cmake
CMAKE_OUTSOURCE=yes
USE_PYTHON_BUILD=yes
MAKE_JOB_SAFE= yes
SUB_FILES= pkg-message
PKG_MESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
.if ${ARCH} == i386
# triggers internal error in system gcc
USE_GCC= 4.4+
.endif
# unsafe workaround because FreeBSD lacks logl and expl
# see "BUGS" in `man 3 math`
post-patch:
@${REINPLACE_CMD} -e 's|expl|exp|g' ${WRKSRC}/apps/snp_store/snp_store.h
@${REINPLACE_CMD} -e 's|logl|log|g' ${WRKSRC}/apps/snp_store/snp_store.h
post-install:
@${CAT} ${PKG_MESSAGE}
.include <bsd.port.post.mk>

2
biology/seqan/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (seqan-1.3.1.zip) = 87eebe73ace9ada2f4664a768ae212d4acc5fb3ce87702709c3d15bf2d153aeb
SIZE (seqan-1.3.1.zip) = 8787521

View file

@ -0,0 +1,13 @@
--- cmake/CMakeLists.txt.orig 2012-05-04 12:56:23.000000000 +0800
+++ cmake/CMakeLists.txt 2012-05-04 13:00:03.000000000 +0800
@@ -146,6 +146,10 @@
COMPONENT headers)
#message("install(FILES ${HEADER} RENAME seqan${NEW_PATH} DESTINATION include COMPONENT headers)")
endforeach()
+#seqan.h
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/../seqan.h
+ DESTINATION include
+ COMPONENT headers)
################################################################################
# Set Compiler Flags

View file

@ -0,0 +1,8 @@
--- cmake/apps/CMakeLists.txt.orig 2012-05-04 11:12:35.000000000 +0800
+++ cmake/apps/CMakeLists.txt 2012-05-04 11:23:26.000000000 +0800
@@ -108,4 +108,4 @@
# Install RazerS gapped parameters.
install(DIRECTORY ${SEQAN_LIBRARY}/apps/razers2/gapped_params
- DESTINATION bin)
+ DESTINATION share/seqan)

View file

@ -0,0 +1,6 @@
gapped_params for Razers2 have been installed to
%%PREFIX%%/share/seqan/gapped_params
If you require these, make sure to set the correct
path with --param-dir as Razers2 will not pick them
up automatically.

6
biology/seqan/pkg-descr Normal file
View file

@ -0,0 +1,6 @@
SeqAn is an open source C++ library of efficient algorithms
and data structures for the analysis of sequences with the
focus on biological data. The library is licensed under the
3-clause BSD license except the applications which are GPL.
WWW: http://www.seqan.de/

2145
biology/seqan/pkg-plist Normal file

File diff suppressed because it is too large Load diff