Update to 1.5.4.

This commit is contained in:
Mike Heffner 2003-02-08 17:59:46 +00:00
parent 082afda448
commit f2424c9975
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=75134
5 changed files with 2 additions and 34 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= xfmail
PORTVERSION= 1.5.3
PORTVERSION= 1.5.4
CATEGORIES= mail
MASTER_SITES= ftp://xfmail.cfreeze.com/pub/xfmail/release/%SUBDIR%/ \
ftp://cupido.geophys.nat.tu-bs.de/pub/xfmail/release/%SUBDIR%/ \

View file

@ -1 +1 @@
MD5 (xfmail-1.5.3.tar.bz2) = ce7fb31306642ba336f41ac2e0e9738f
MD5 (xfmail-1.5.4.tar.bz2) = 2921b249238a4223259b1037dd12082e

View file

@ -1,10 +0,0 @@
--- contrib/Makefile.am.orig Wed Nov 6 10:04:08 2002
+++ contrib/Makefile.am Wed Nov 6 10:04:18 2002
@@ -4,6 +4,6 @@
xfmail-full.spec \
xfmail.spec
-SUBDIRS = misc specfiles
+SUBDIRS = misc
DIST_SUBDIRS = $(SUBDIRS)

View file

@ -1,11 +0,0 @@
--- src/mail/nntp.cpp.orig Thu Jan 16 12:37:07 2003
+++ src/mail/nntp.cpp Thu Jan 16 12:37:32 2003
@@ -59,7 +59,7 @@
#endif
if(fmt) {
- snprintf(response, sizeof(response), fmt, ap);
+ vsnprintf(response, sizeof(response), fmt, ap);
if(logging & LOG_NNTP) {
if(!strncasecmp(response, "AUTHINFO PASS ", 14))

View file

@ -1,11 +0,0 @@
--- src/ui/rules.cpp.orig Fri Jan 25 22:14:55 2002
+++ src/ui/rules.cpp Wed Nov 6 00:32:49 2002
@@ -362,7 +362,7 @@
r_modified = 0;
fl_delete_browser_line(rule_obj->Rule_List, k);
add_dead_rule(rules[i]);
- rules.erase((vector<struct _xf_rule *>::iterator) &rules[i]);
+ rules.erase(rules.begin() + i);
changed = 1;