Add gdesklets-sensor-psi_popmail, a mail check backend Sensor for gDesklets

from the PSI project.

PR:		59821
Submitted by:	Franz Klammer <klammer@webonaut.com>
This commit is contained in:
Joe Marcus Clarke 2003-12-17 20:45:54 +00:00
parent e69d130c58
commit f25d399415
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=96098
7 changed files with 80 additions and 0 deletions

View file

@ -83,6 +83,7 @@
SUBDIR += ftrack
SUBDIR += gbuffy
SUBDIR += gdesklets-imapmail
SUBDIR += gdesklets-sensor-psi_popmail
SUBDIR += gensig
SUBDIR += getmail
SUBDIR += gkrellmmailwatch

View file

@ -0,0 +1,43 @@
# New ports collection makefile for: gdesklets-sensor-psi_popmail
# Date created: 21 September 2003
# Whom: Franz Klammer <klammer@webonaut.com>
#
# $FreeBSD$
#
PORTNAME= popmail
PORTVERSION= 0.1.4
CATEGORIES= mail gnome
MASTER_SITES= http://gdesklets.gnomedesktop.org/files/
PKGNAMEPREFIX= gdesklets-sensor-psi_
DISTNAME= PsiSensorPackage-${DISTVERSION}
MAINTAINER= klammer@webonaut.com
COMMENT= Popmail Sensor from the Psi Sensor Package
RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gdesklets-core.pc:${PORTSDIR}/deskutils/gdesklets
USE_BZIP2= yes
USE_PYTHON= yes
USE_X_PREFIX= yes
DISTVERSION= 20031028
NAME= popmail
DATADIR= ${PREFIX}/share/gnome
WRKSRC= ${WRKDIR}/${NAME}-${PORTVERSION}
do-build:
@${WRKSRC}/Install_${NAME}_Sensor.bin --nomsg ${WRKSRC}
@${FIND} ${WRKSRC} -name '*.orig' -delete
do-install:
@${MKDIR} ${DATADIR}/gdesklets/Sensors/${NAME}
@${INSTALL_DATA} ${WRKSRC}/${NAME}/*.py ${DATADIR}/gdesklets/Sensors/${NAME}/
@${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/gdesklets/Sensors/${NAME}/
post-install:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (PsiSensorPackage-20031028.tar.bz2) = 24c891e1d0f66426040b4e4fb618f9f5

View file

@ -0,0 +1,19 @@
--- Install_popmail_Sensor.bin.orig Wed Nov 19 18:34:09 2003
+++ Install_popmail_Sensor.bin Wed Nov 19 18:34:26 2003
@@ -75,15 +75,9 @@
else:
cmd = "mkdir -p %(destination)s; cd %(destination)s; " \
"LANG=C tar -xzvf %(tmp)s 2>&1"
- fail, out = commands.getstatusoutput(cmd % vars())
+ commands.getstatusoutput(cmd % vars())
os.unlink(tmp)
- if (fail):
- if (no_message): print ERROR_TAR + out
- else: message(ERROR_TAR + out, "error")
- sys.exit(1)
-
- print out
if (not list_only):
if (no_message): print SUCCESS
else: message(SUCCESS, "info")

View file

@ -0,0 +1,3 @@
popmail Sensor from the Psi Sensor Package.
WWW: http://gdesklets.gnomedesktop.org/

View file

@ -0,0 +1,8 @@
##
To view the README, do the command following:
cat ${PREFIX}/share/gnome/gdesklets/Sensors/popmail/README
This is just a sensor, to actually see the data it collects, you have to install
an appropriate display plugin.
##

View file

@ -0,0 +1,5 @@
share/gnome/gdesklets/Sensors/popmail/__init__.py
share/gnome/gdesklets/Sensors/popmail/__init__.pyc
share/gnome/gdesklets/Sensors/popmail/__init__.pyo
share/gnome/gdesklets/Sensors/popmail/README
@dirrm share/gnome/gdesklets/Sensors/popmail