Make clang-format.py look for clang-format37 rather than clang-format in

$PATH.
This commit is contained in:
Brooks Davis 2015-09-08 22:24:46 +00:00
parent 3e21abd63b
commit f266bbb878
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=396445
2 changed files with 14 additions and 2 deletions

View file

@ -2,7 +2,7 @@
PORTNAME= llvm
DISTVERSION= 3.7.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/${PRE_}releases/${LLVM_RELEASE}/${RCDIR}
DISTNAME= ${PORTNAME}-${DISTVERSION}.src
@ -40,7 +40,8 @@ OPTIONS_SUB= yes
CLANG_DESC= Build clang
CLANG_EXTRA_PATCHES= \
${PATCHDIR}/clang-patch-fformat_extensions.diff \
${PATCHDIR}/clang-patch-tools_clang_lib_Headers_CMakeLists.txt
${PATCHDIR}/clang-patch-tools_clang_lib_Headers_CMakeLists.txt \
${PATCHDIR}/clang-patch-tools_clang_tools_clang-format_clang-format.py
CLANG_CONFLICTS_INSTALL= clang-devel-3.[1234567]*
CLANG_DISTFILES= cfe-${DISTVERSION}.src${EXTRACT_SUFX}
CLANG_CMAKE_ON= -DCLANG_DEFAULT_OPENMP_RUNTIME=libomp

View file

@ -0,0 +1,11 @@
--- tools/clang/tools/clang-format/clang-format.py.orig 2015-09-08 20:44:00 UTC
+++ tools/clang/tools/clang-format/clang-format.py
@@ -34,7 +34,7 @@ import vim
# set g:clang_format_path to the path to clang-format if it is not on the path
# Change this to the full path if clang-format is not on the path.
-binary = 'clang-format'
+binary = 'clang-format37'
if vim.eval('exists("g:clang_format_path")') == "1":
binary = vim.eval('g:clang_format_path')