Add progsreiserfs, a library for reiserfs filesystem access and manipulation.
For now progsreiserfs consists of: 1. libreiserfs, which have a number of high level APIs for access reiserfs filesystem. There are: main filesystem code (reiserfs_fs_open, reiserfs_fs_close, resierfs_fs_create, reiserfs_fs_resize, reiserfs_fs_journal_tune, etc), journal code, bitmap code, directories and files access code and device abstraction layer. 2. fouth progs which are simple frontends to libreiserfs. There are: mkfs.reiserfs, resizefs.reiserfs, cpfs.reiserfs, tunefs.reiserfs. PR: ports/66590 Submitted by: Florent Thoumie <flz@xbsd.org>
This commit is contained in:
parent
a08800154b
commit
f26daa7f4e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=109140
6 changed files with 93 additions and 0 deletions
|
@ -295,6 +295,7 @@
|
|||
SUBDIR += portupgrade
|
||||
SUBDIR += prips
|
||||
SUBDIR += procmap
|
||||
SUBDIR += progsreiserfs
|
||||
SUBDIR += prune
|
||||
SUBDIR += pslist
|
||||
SUBDIR += psmisc
|
||||
|
|
29
sysutils/progsreiserfs/Makefile
Normal file
29
sysutils/progsreiserfs/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: progsreiserfs
|
||||
# Date created: May 13 2004
|
||||
# Whom: Florent Thoumie <flz@xbsd.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= progsreiserfs
|
||||
PORTVERSION= 0.3.1.r8
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.cgsecurity.org/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
|
||||
|
||||
MAINTAINER= flz@xbsd.org
|
||||
COMMENT= Utilities and library to manipulate ReiserFS partitions
|
||||
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GETTEXT= 1
|
||||
USE_LIBTOOL_VER= 15
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib -lgnugetopt"
|
||||
|
||||
MAN8= cpfs.reiserfs.8 mkfs.reiserfs.8 reiserfs.8 \
|
||||
resizefs.reiserfs.8 tunefs.reiserfs.8
|
||||
|
||||
.include <bsd.port.mk>
|
2
sysutils/progsreiserfs/distinfo
Normal file
2
sysutils/progsreiserfs/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (progsreiserfs-0.3.1-rc8.tar.gz) = e545a171a207ec5b9045ceb1a982c1bd
|
||||
SIZE (progsreiserfs-0.3.1-rc8.tar.gz) = 399279
|
11
sysutils/progsreiserfs/files/patch-libreiserfs::journal.c
Normal file
11
sysutils/progsreiserfs/files/patch-libreiserfs::journal.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- libreiserfs/journal.c Thu Dec 12 13:32:35 2002
|
||||
+++ libreiserfs/journal.c.new Thu May 13 00:01:43 2004
|
||||
@@ -482,7 +482,7 @@
|
||||
blk_t reiserfs_journal_boundary_transactions(reiserfs_journal_t *journal,
|
||||
reiserfs_journal_trans_t *oldest, reiserfs_journal_trans_t *newest)
|
||||
{
|
||||
- reiserfs_gauge_t *gauge;
|
||||
+ reiserfs_gauge_t *gauge = NULL;
|
||||
struct reiserfs_replay_desc desc;
|
||||
|
||||
desc.oldest_id = 0xffffffff; desc.newest_id = 0x0;
|
11
sysutils/progsreiserfs/pkg-descr
Normal file
11
sysutils/progsreiserfs/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
This is a library for reiserfs filesystem access and manipulation.
|
||||
The primary goal is to develop the nice, full functionality library
|
||||
wich might be linked against any projects which needed reiserfs filesystem
|
||||
access. There are GNU Parted, GNU GRUB, Yaboot, Partimage, EVMS, etc.
|
||||
|
||||
progsreiserfs supports versions 3.5, 3.6 with standard and relocated journal.
|
||||
|
||||
WWW: http://reiserfs.osdn.org.ua
|
||||
|
||||
- Florent Thoumie
|
||||
flz@xbsd.org
|
39
sysutils/progsreiserfs/pkg-plist
Normal file
39
sysutils/progsreiserfs/pkg-plist
Normal file
|
@ -0,0 +1,39 @@
|
|||
include/dal/dal.h
|
||||
include/dal/file.h
|
||||
include/reiserfs/bitmap.h
|
||||
include/reiserfs/block.h
|
||||
include/reiserfs/core.h
|
||||
include/reiserfs/dir.h
|
||||
include/reiserfs/endian.h
|
||||
include/reiserfs/exception.h
|
||||
include/reiserfs/file.h
|
||||
include/reiserfs/filesystem.h
|
||||
include/reiserfs/gauge.h
|
||||
include/reiserfs/hashes.h
|
||||
include/reiserfs/journal.h
|
||||
include/reiserfs/key.h
|
||||
include/reiserfs/node.h
|
||||
include/reiserfs/object.h
|
||||
include/reiserfs/path.h
|
||||
include/reiserfs/reiserfs.h
|
||||
include/reiserfs/segment.h
|
||||
include/reiserfs/tools.h
|
||||
include/reiserfs/tree.h
|
||||
lib/libdal-0.3.so
|
||||
lib/libdal-0.3.so.0
|
||||
lib/libdal.a
|
||||
lib/libdal.la
|
||||
lib/libdal.so
|
||||
lib/libreiserfs-0.3.so
|
||||
lib/libreiserfs-0.3.so.0
|
||||
lib/libreiserfs.a
|
||||
lib/libreiserfs.la
|
||||
lib/libreiserfs.so
|
||||
sbin/cpfs.reiserfs
|
||||
sbin/fsck.reiserfs
|
||||
sbin/mkfs.reiserfs
|
||||
sbin/resizefs.reiserfs
|
||||
sbin/tunefs.reiserfs
|
||||
share/aclocal/progsreiserfs.m4
|
||||
@dirrm include/reiserfs
|
||||
@dirrm include/dal
|
Loading…
Reference in a new issue