Send ports/misc/metatheme to Valhalla - it have been dead for too long now.

This commit is contained in:
Maxim Sobolev 2002-08-30 15:56:50 +00:00
parent 8d97fb36a7
commit f2921c2f2a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=65319
15 changed files with 0 additions and 255 deletions

View file

@ -194,7 +194,6 @@
SUBDIR += matrix-kmod
SUBDIR += mc
SUBDIR += menushki
SUBDIR += metatheme
SUBDIR += metatheme2
SUBDIR += mgp-mode.el
SUBDIR += misterproper

View file

@ -1,40 +0,0 @@
# New ports collection makefile for: metatheme
# Date created: 25 November 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= metatheme
PORTVERSION= 0.6.0
CATEGORIES= misc gnome
MASTER_SITES= ftp://ftp.ximian.com/pub/metatheme/
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= gnet.0:${PORTSDIR}/net/gnet
BROKEN= "Out of sync with latest Gal"
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-configure:
.for file in gtk/gtk-plugin.c background/background-plugin.c sawfish/sawfish-plugin.c
@${PERL} -pi -e 's|%%GTK_CONFIG%%|${GTK_CONFIG}|g ; \
s|%%X11BASE%%|${X11BASE}|g ; s|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/plugins/${file}
.endfor
.include <bsd.port.mk>

View file

@ -1 +0,0 @@
MD5 (metatheme-0.6.0.tar.gz) = ab076f973ee0de37a5b69371e8ac52a8

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- Makefile.in 2001/07/10 06:14:43 1.1
+++ Makefile.in 2001/07/10 06:14:59
@@ -141,7 +141,7 @@
appicondir = $(datadir)/pixmaps
appicon_DATA = gnome-application-x-metatheme.png
-mtmdir = $(prefix)/share/metathemes
+mtmdir = $(prefix)/share/gnome/metathemes
mtm_DATA = default.mtm
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs

View file

@ -1,23 +0,0 @@
$FreeBSD$
--- plugins/gtk/Makefile.in.orig Tue Jul 10 09:01:49 2001
+++ plugins/gtk/Makefile.in Tue Jul 10 09:04:51 2001
@@ -143,7 +143,7 @@
themehelper_SOURCES = themehelper.c
-EXTRA_STUFF = `gtk-config --libs`
+EXTRA_STUFF = @GTK_LIBS@
themehelper_LDFLAGS = $(EXTRA_STUFF)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
@@ -156,7 +156,7 @@
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
-libgtk_la_LDFLAGS =
+libgtk_la_LDFLAGS = -module -avoid-version
libgtk_la_LIBADD =
libgtk_la_OBJECTS = gtk-plugin.lo gtk-config-gui.lo
PROGRAMS = $(bin_PROGRAMS)

View file

@ -1,23 +0,0 @@
$FreeBSD$
--- plugins/background/Makefile.in.orig Wed Dec 19 13:42:05 2001
+++ plugins/background/Makefile.in Wed Dec 19 13:44:54 2001
@@ -137,7 +137,7 @@
libbackground_la_LIBADD = $(GDK_PIXBUF_LIBS) $(LIBGLADE_LIBS)
-INCLUDES = -I$(top_srcdir) -I$(METATHEME_SRC_DIR) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(includedir) $(GNOME_INCLUDEDIR) -DSHAREDIR=\"$(SHAREDIR)\" $(LIBGLADE_CFLAGS)
+INCLUDES = $(GDK_PIXBUF_CFLAGS) -I$(top_srcdir) -I$(METATHEME_SRC_DIR) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(includedir) $(GNOME_INCLUDEDIR) -DSHAREDIR=\"$(SHAREDIR)\" $(LIBGLADE_CFLAGS)
EXTRA_DIST = bg-config-gui.glade translatable.c
@@ -155,7 +155,7 @@
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
-libbackground_la_LDFLAGS =
+libbackground_la_LDFLAGS = -module -avoid-version
libbackground_la_DEPENDENCIES =
libbackground_la_OBJECTS = background-plugin.lo config-io.lo \
bg-ext-handler.lo bg-config-gui.lo

View file

@ -1,11 +0,0 @@
--- plugins/sawfish/Makefile.in 2000/11/26 21:12:29 1.1
+++ plugins/sawfish/Makefile.in 2000/11/26 21:13:06
@@ -148,7 +148,7 @@
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
-libsawfish_la_LDFLAGS =
+libsawfish_la_LDFLAGS = -module -avoid-version
libsawfish_la_LIBADD =
libsawfish_la_OBJECTS = sawfish-plugin.lo
CFLAGS = @CFLAGS@

View file

@ -1,21 +0,0 @@
--- plugins/gtk/gtk-plugin.c 2000/11/26 21:25:12 1.1
+++ plugins/gtk/gtk-plugin.c 2000/11/26 21:27:39
@@ -375,15 +375,15 @@
/* This should be more robust.
* Perhaps we could make this user-configurable somehow. */
- pipe = popen ("gtk-config --prefix", "r");
+ pipe = popen ("%%GTK_CONFIG%% --prefix", "r");
if (pipe == NULL)
- return g_strdup ("/usr");
+ return g_strdup ("%%X11BASE%%");
fgets (prefix, 1000, pipe);
pclose (pipe);
if (prefix == NULL)
- return g_strdup ("/usr");
+ return g_strdup ("%%X11BASE%%");
return g_strchomp (g_strdup (prefix));
}

View file

@ -1,15 +0,0 @@
--- plugins/background/background-plugin.c 2000/11/26 21:31:41 1.1
+++ plugins/background/background-plugin.c 2000/11/26 21:33:54
@@ -227,9 +227,9 @@
bg_plugin_find_theme (MtmExtHandler *handler, gchar *name,
gboolean is_root)
{
- gchar *root_prefixes[] = {"/usr/share/pixmaps/backgrounds",
- "/usr/share/pixmaps/backgrounds/tiles",
- "/usr/share/wallpapers",
+ gchar *root_prefixes[] = {"%%X11BASE%%/share/gnome/pixmaps/backgrounds",
+ "%%X11BASE%%/share/gnome/pixmaps/backgrounds/tiles",
+ "%%X11BASE%%/share/gnome/wallpapers",
NULL};
gchar *user_prefixes[] = {".metatheme-backgrounds",
".backgrounds",

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- plugins/sawfish/sawfish-plugin.c.orig Sat Jun 23 00:02:09 2001
+++ plugins/sawfish/sawfish-plugin.c Tue Jul 10 08:59:34 2001
@@ -224,7 +224,7 @@
sawfish_plugin_theme_find (MtmExtHandler *handler, const gchar *name,gboolean is_root)
{
gchar *root_prefixes[] = {"share/sawfish/themes", NULL, NULL};
- gchar *pre_prefixes[] = {"/usr/", "/usr/local/", NULL};
+ gchar *pre_prefixes[] = {"%%X11BASE%%", "%%LOCALBASE%%", NULL};
gchar *user_prefixes[] = {".sawfish/themes", NULL};
gchar **arr;
gchar *ret;

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- capplet/mtm-selector.c 2001/07/10 06:15:32 1.1
+++ capplet/mtm-selector.c 2001/07/10 06:16:15
@@ -203,7 +203,7 @@
g_return_if_fail (MTM_IS_SELECTOR (selector));
- sysdir = g_strdup_printf ("%s/share/metathemes", mtm_get_prefix ());
+ sysdir = g_strdup_printf ("%s/share/gnome/metathemes", mtm_get_prefix ());
userdir = g_strdup_printf ("%s/.metathemes", g_get_home_dir ());
/* Create it if it doesn't exist */
mtm_check_dir (userdir);

View file

@ -1,23 +0,0 @@
$FreeBSD$
--- metatheme-edit/Makefile.in.orig Tue Jul 10 09:01:49 2001
+++ metatheme-edit/Makefile.in Tue Jul 10 09:10:07 2001
@@ -133,7 +133,7 @@
metatheme_edit_SOURCES = main.c editor-shell.c editor-shell.h editor-page.c editor-page.h editor-main-page.c editor-main-page.h save.c save.h
-EXTRA_STUFF = `gnome-config --libs libglade xml`
+EXTRA_STUFF = @GNOME_LIBS@ @GTK_LIBS@ @EXTRA_LIBS@
metatheme_edit_LDFLAGS = $(EXTRA_STUFF) ../mtm/libmtm.la
@@ -152,7 +152,7 @@
gladedir = $(SHAREDIR)
glade_DATA = metatheme-edit.glade
-pixmapsdir = $(prefix)/share/pixmaps
+pixmapsdir = $(prefix)/share/gnome/pixmaps
pixmaps_DATA = 32_butteflylogo.png settings.png
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../config.h

View file

@ -1 +0,0 @@
An utility for managing "theme sets" that accomodate gtk, window manager, etc

View file

@ -1,2 +0,0 @@
This is metatheme, an application for managing "theme sets" that accomodate
gtk+, your window manager, etc etc.

View file

@ -1,52 +0,0 @@
bin/metatheme-edit
bin/metatheme_selector_capplet
include/mtm/mtm-config-gui.h
include/mtm/mtm-env.h
include/mtm/mtm-ext-handler.h
include/mtm/mtm-ext.h
include/mtm/mtm-gui-handler.h
include/mtm/mtm-handler.h
include/mtm/mtm-init.h
include/mtm/mtm-plugin.h
include/mtm/mtm-stateful.h
include/mtm/mtm-theme.h
include/mtm/mtm-util.h
include/mtm/mtm.h
lib/libmtm.a
lib/libmtm.so
lib/libmtm.so.0
lib/metatheme/plugins/gtk/themehelper
lib/metatheme/plugins/libbackground.so
lib/metatheme/plugins/libgtk.so
lib/metatheme/plugins/libsawfish.so
share/gnome/apps/Applications/metatheme-edit.desktop
share/gnome/apps/Settings/Desktop/metatheme_selector.desktop
share/gnome/control-center/Desktop/metatheme_selector.desktop
share/gnome/metatheme-glade/bg-config-gui.glade
share/gnome/metatheme-glade/metatheme-edit.glade
share/gnome/metatheme-glade/mtm-sel.glade
share/gnome/metatheme-glade/mtm-selector.glade
share/gnome/metathemes/default.mtm
share/gnome/mime-info/metatheme-edit.keys
share/gnome/mime-info/metatheme.keys
share/gnome/mime-info/metatheme.mime
share/gnome/pixmaps/32_butteflylogo.png
share/gnome/pixmaps/gnome-application-x-metatheme.png
share/gnome/pixmaps/settings.png
share/locale/da/LC_MESSAGES/metatheme.mo
share/locale/de/LC_MESSAGES/metatheme.mo
share/locale/fr/LC_MESSAGES/metatheme.mo
share/locale/hu/LC_MESSAGES/metatheme.mo
share/locale/it/LC_MESSAGES/metatheme.mo
share/locale/ko/LC_MESSAGES/metatheme.mo
share/locale/no/LC_MESSAGES/metatheme.mo
share/locale/pt_BR/LC_MESSAGES/metatheme.mo
share/locale/ru/LC_MESSAGES/metatheme.mo
share/locale/sv/LC_MESSAGES/metatheme.mo
share/locale/tr/LC_MESSAGES/metatheme.mo
@dirrm share/gnome/metathemes
@dirrm share/gnome/metatheme-glade
@dirrm lib/metatheme/plugins/gtk
@dirrm lib/metatheme/plugins
@dirrm lib/metatheme
@dirrm include/mtm