- Update to version 1.4.2

- Install config file by default - this allows to view compressed files,
  add usual remove if not edited statements in pkg-plist
- Remove leading article from COMMENT
- Simplify REINPLACE_CMD
- Convert to OptionsNG
- Take maintainership
This commit is contained in:
Pawel Pekala 2013-01-04 16:29:34 +00:00
parent 5f54ed8b68
commit f29e67e8c3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=309933
5 changed files with 43 additions and 66 deletions

View file

@ -1,41 +1,38 @@
# New ports collection makefile for: lookat
# Date created: Tue Apr 22 15:56:54 CEST 2003
# Whom: Kirill Ponomarew <ponomarew@oberon.net>
#
# Created by: Kirill Ponomarew <ponomarew@oberon.net>
# $FreeBSD$
#
PORTNAME= lookat
PORTVERSION= 1.4.1
PORTVERSION= 1.4.2
CATEGORIES= sysutils
MASTER_SITES= http://www.wagemakers.be/uploads/fc/38/fc38e0abaf31f0f343d99479b08875dd/
MASTER_SITES= http://www.wagemakers.be/uploads/d9/2a/d92a52ea9fdfb96d1196005e0fa60fca/
DISTNAME= ${PORTNAME}_bekijk-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A program to view Un*x text files and manual pages
MAINTAINER= pawel@FreeBSD.org
COMMENT= Program to view Un*x text files and manual pages
GNU_CONFIGURE= yes
USE_GMAKE= yes
MAN1= lookat.1
.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e \
's|/etc/lookat.conf|${PREFIX}/etc/lookat.conf|g' ${WRKSRC}/${PORTNAME}.1
@${REINPLACE_CMD} 's|/etc/lookat.conf|${PREFIX}&|g' \
${WRKSRC}/${PORTNAME}.1
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/lookat ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/lookat.1 ${PREFIX}/man/man1
@${INSTALL_DATA} ${WRKSRC}/lookat.conf.default ${PREFIX}/etc
@${ECHO} "------------------------------------------------------------"
@${ECHO} "Sample of configuration file placed at"
@${ECHO} "${PREFIX}/etc/lookat.conf.default"
@${ECHO} "------------------------------------------------------------"
.if !defined(NOPORTDOCS)
@${INSTALL_DATA} ${WRKSRC}/lookat.conf.default \
${PREFIX}/etc/lookat.conf.sample
@if [ ! -f ${PREFIX}/etc/lookat.conf ]; then \
${CP} -p ${PREFIX}/etc/lookat.conf.sample ${PREFIX}/etc/lookat.conf ; \
fi
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (lookat_bekijk-1.4.1.tar.gz) = 66b20518a791a2ce52229654bb5d2f19ed68593fc7dfd66893ff9bcd48a7814e
SIZE (lookat_bekijk-1.4.1.tar.gz) = 153146
SHA256 (lookat_bekijk-1.4.2.tar.gz) = fa7b006173c5cc8901b0a3b2599d6f695a8035b506aacb05e7c097b01a968971
SIZE (lookat_bekijk-1.4.2.tar.gz) = 264735

View file

@ -1,33 +1,27 @@
--- ./getline.c.orig 2009-03-23 18:42:33.000000000 +0000
+++ ./getline.c 2009-03-23 19:03:49.000000000 +0000
@@ -45,7 +45,15 @@
}
--- getline.c.orig 2013-01-04 16:25:54.000000000 +0100
+++ getline.c 2013-01-04 16:37:47.000000000 +0100
@@ -33,7 +33,7 @@
#include <stdio.h>
#include <sys/types.h>
-#if defined __GNU_LIBRARY__ && HAVE_GETDELIM
+#if HAVE_GETDELIM
#ifndef HAVE_GETLINE
@@ -50,15 +50,6 @@
#else /* ! have getdelim */
+
+#if defined(__FreeBSD__)
+#include <osreldate.h>
+#if __FreeBSD_version <= 800066
int
+#else
+ssize_t
+#endif
+#endif
getdelim (lineptr, n, delimiter, stream);
-#if defined(__FreeBSD__)
-#include <osreldate.h>
-#if __FreeBSD_version <= 800066
-int getdelim (lineptr, n, delimiter, stream);
-#else
-ssize_t getdelim (lineptr, n, delimiter, stream);
-#endif
-#endif
-
# include <assert.h>
@@ -150,7 +158,14 @@
return getstr (lineptr, n, stream, '\n', 0);
}
+#if defined(__FreeBSD__)
+#include <osreldate.h>
+#if __FreeBSD_version <= 800066
int
+#else
+ssize_t
+#endif
+#endif
getdelim (lineptr, n, delimiter, stream)
char **lineptr;
size_t *n;
# if HAVE_STDLIB_H

View file

@ -1,16 +0,0 @@
--- ./getline.h.orig 2009-03-23 18:40:41.000000000 +0000
+++ ./getline.h 2009-03-23 18:40:20.000000000 +0000
@@ -36,8 +36,13 @@
int
getline PARAMS ((char **_lineptr, size_t *_n, FILE *_stream));
+#if defined(__FreeBSD__)
+#include <osreldate.h>
+#if __FreeBSD_version <= 800066
int
getdelim PARAMS ((char **_lineptr, size_t *_n, int _delimiter, FILE *_stream));
+#endif
+#endif
# endif

View file

@ -1,4 +1,6 @@
bin/lookat
etc/lookat.conf.default
@unexec if cmp -s %D/etc/lookat.conf.sample %D/etc/lookat.conf; then rm -f %D/etc/lookat.conf; fi
etc/lookat.conf.sample
@exec if [ ! -f %D/etc/lookat.conf ] ; then cp -p %D/%F %B/lookat.conf; fi
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%