Update to 4.4.1
This commit is contained in:
parent
b738a2237c
commit
f2a21d42f2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=418976
3 changed files with 6 additions and 19 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= tornado
|
||||
PORTVERSION= 4.3
|
||||
PORTVERSION= 4.4.1
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -12,19 +12,14 @@ COMMENT= Python Web Server from FriendFeed
|
|||
|
||||
LICENSE= APACHE20
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PYTHON_REL} < 3000
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>0:devel/py-futures
|
||||
.endif
|
||||
|
||||
.if ${PYTHON_REL} < 3400
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}singledispatch>0:devel/py-singledispatch
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}singledispatch>0:devel/py-singledispatch \
|
||||
${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi
|
||||
.endif
|
||||
|
||||
.if ${PYTHON_REL} < 3500
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (tornado-4.3.tar.gz) = c9c2d32593d16eedf2cec1b6a41893626a2649b40b21ca9c4cac4243bde2efbf
|
||||
SIZE (tornado-4.3.tar.gz) = 450916
|
||||
TIMESTAMP = 1469297044
|
||||
SHA256 (tornado-4.4.1.tar.gz) = 371d0cf3d56c47accc66116a77ad558d76eebaa8458a6b677af71ca606522146
|
||||
SIZE (tornado-4.4.1.tar.gz) = 456992
|
||||
|
|
|
@ -1,14 +1,5 @@
|
|||
--- setup.py.orig 2015-11-06 20:08:26 UTC
|
||||
+++ setup.py
|
||||
@@ -125,7 +125,7 @@ if setuptools is not None:
|
||||
if sys.version_info < (2, 7):
|
||||
# Only needed indirectly, for singledispatch.
|
||||
install_requires.append('ordereddict')
|
||||
- if sys.version_info < (3, 2):
|
||||
+ if sys.version_info < (2, 7, 9):
|
||||
install_requires.append('backports.ssl_match_hostname')
|
||||
if sys.version_info < (3, 4):
|
||||
install_requires.append('singledispatch')
|
||||
@@ -147,9 +147,6 @@ setup(
|
||||
# in the sdist tarball)
|
||||
"tornado.test": [
|
||||
|
|
Loading…
Reference in a new issue