New port: dynamips

dynamips is Cisco 7200 simulator.
This commit is contained in:
Max Khon 2006-02-02 13:22:47 +00:00
parent 4222e06413
commit f2a391d1fb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=155068
9 changed files with 241 additions and 0 deletions

View file

@ -19,6 +19,7 @@
SUBDIR += dlx
SUBDIR += dosbox
SUBDIR += doscmd
SUBDIR += dynamips
SUBDIR += e-uae
SUBDIR += extract-xiso
SUBDIR += fceu

View file

@ -0,0 +1,46 @@
# New ports collection makefile for: dynamips
# Date created: 31 Jan 2006
# Whom: Max Khon <fjoe@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= dynamips
PORTVERSION= 0.2.3b
CATEGORIES= sysutils
MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Cisco 7200 Simulator
LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
USE_GMAKE= yes
ALL_TARGET= ${PORTNAME}
MAKE_ENV= DYNAMIPS_ARCH=${DYNAMIPS_ARCH}\
PTHREAD_CFLAGS=${PTHREAD_CFLAGS}\
PTHREAD_LIBS=${PTHREAD_LIBS}
PLIST_FILES= bin/${PORTNAME}
.if !defined(NOPORTDOCS)
PORTDOCS= README
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
DYNAMIPS_ARCH= "x86"
.elif ${ARCH} == "amd64"
DYNAMIPS_ARCH= "amd64"
.else
DYNAMIPS_ARCH= "nojit"
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,3 @@
MD5 (dynamips-0.2.3b.tar.gz) = 5ec12dedc04391aed8c8f4c7b22c5c75
SHA256 (dynamips-0.2.3b.tar.gz) = 3764e2cd967674097118637484bc0855ffeac515190a8f13991b0189fbf2b5b6
SIZE (dynamips-0.2.3b.tar.gz) = 182549

View file

@ -0,0 +1,68 @@
--- Makefile.orig Mon Jan 30 19:09:47 2006
+++ Makefile Tue Jan 31 01:38:09 2006
@@ -3,7 +3,7 @@
# Replace x86 by amd64 for a build on x86_64.
# Use "nojit" for architectures that are not x86 or x86_64.
-ARCH=x86
+DYNAMIPS_ARCH=x86
# Change this to 0 if your system doesn't support RFC 2553 extensions
HAS_RFC2553=1
@@ -11,21 +11,21 @@
# Current dynamips release
VERSION=0.2.3b
-CC=gcc
+CC?=gcc
LD=ld
RM=rm
TAR=tar
CP=cp
LEX=flex
-ARCH_INC_FILE=\"$(ARCH)_trans.h\"
-CFLAGS=-g -Wall -O3 -fomit-frame-pointer -DJIT_ARCH=\"$(ARCH)\" \
+ARCH_INC_FILE=\"$(DYNAMIPS_ARCH)_trans.h\"
+CFLAGS+=-g -Wall -O3 -fomit-frame-pointer -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" \
-DARCH_INC_FILE=$(ARCH_INC_FILE) \
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \
-DHAS_RFC2553=$(HAS_RFC2553)
ifeq ($(shell uname), FreeBSD)
- CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
- LIBS=-L/usr/local/lib -L. -lelf -pthread
+ CFLAGS+=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/libelf $(PTHREAD_CFLAGS)
+ LIBS=-L$(LOCALBASE)/lib -lelf $(PTHREAD_LIBS)
else
ifeq ($(shell uname -o), Cygwin)
CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
@@ -61,17 +61,17 @@
#SOURCES += profiler.c
#CFLAGS += -p -DPROFILE -DPROFILE_FILE=\"$(PROG).profile\"
-ifeq ($(ARCH),x86)
+ifeq ($(DYNAMIPS_ARCH),x86)
HDR += x86-codegen.h x86_trans.h
SOURCES += x86_trans.c
endif
-ifeq ($(ARCH),amd64)
+ifeq ($(DYNAMIPS_ARCH),amd64)
HDR += x86-codegen.h amd64-codegen.h amd64_trans.h
SOURCES += amd64_trans.c
endif
-ifeq ($(ARCH),nojit)
+ifeq ($(DYNAMIPS_ARCH),nojit)
HDR += nojit_trans.h
SOURCES += nojit_trans.c
endif
@@ -101,7 +101,7 @@
.PHONY: microcode
microcode:
- @$(CC) -Wall -o rom2c rom2c.c $(LIBS)
+ @$(CC) -Wall $(CFLAGS) -o rom2c rom2c.c $(LIBS)
@./rom2c microcode microcode_dump.inc
.PHONY: clean

View file

@ -0,0 +1,3 @@
Cisco 7200 simulator.
WWW: http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator

View file

@ -0,0 +1,46 @@
# New ports collection makefile for: dynamips
# Date created: 31 Jan 2006
# Whom: Max Khon <fjoe@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= dynamips
PORTVERSION= 0.2.3b
CATEGORIES= sysutils
MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Cisco 7200 Simulator
LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
USE_GMAKE= yes
ALL_TARGET= ${PORTNAME}
MAKE_ENV= DYNAMIPS_ARCH=${DYNAMIPS_ARCH}\
PTHREAD_CFLAGS=${PTHREAD_CFLAGS}\
PTHREAD_LIBS=${PTHREAD_LIBS}
PLIST_FILES= bin/${PORTNAME}
.if !defined(NOPORTDOCS)
PORTDOCS= README
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
DYNAMIPS_ARCH= "x86"
.elif ${ARCH} == "amd64"
DYNAMIPS_ARCH= "amd64"
.else
DYNAMIPS_ARCH= "nojit"
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,3 @@
MD5 (dynamips-0.2.3b.tar.gz) = 5ec12dedc04391aed8c8f4c7b22c5c75
SHA256 (dynamips-0.2.3b.tar.gz) = 3764e2cd967674097118637484bc0855ffeac515190a8f13991b0189fbf2b5b6
SIZE (dynamips-0.2.3b.tar.gz) = 182549

View file

@ -0,0 +1,68 @@
--- Makefile.orig Mon Jan 30 19:09:47 2006
+++ Makefile Tue Jan 31 01:38:09 2006
@@ -3,7 +3,7 @@
# Replace x86 by amd64 for a build on x86_64.
# Use "nojit" for architectures that are not x86 or x86_64.
-ARCH=x86
+DYNAMIPS_ARCH=x86
# Change this to 0 if your system doesn't support RFC 2553 extensions
HAS_RFC2553=1
@@ -11,21 +11,21 @@
# Current dynamips release
VERSION=0.2.3b
-CC=gcc
+CC?=gcc
LD=ld
RM=rm
TAR=tar
CP=cp
LEX=flex
-ARCH_INC_FILE=\"$(ARCH)_trans.h\"
-CFLAGS=-g -Wall -O3 -fomit-frame-pointer -DJIT_ARCH=\"$(ARCH)\" \
+ARCH_INC_FILE=\"$(DYNAMIPS_ARCH)_trans.h\"
+CFLAGS+=-g -Wall -O3 -fomit-frame-pointer -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" \
-DARCH_INC_FILE=$(ARCH_INC_FILE) \
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \
-DHAS_RFC2553=$(HAS_RFC2553)
ifeq ($(shell uname), FreeBSD)
- CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
- LIBS=-L/usr/local/lib -L. -lelf -pthread
+ CFLAGS+=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/libelf $(PTHREAD_CFLAGS)
+ LIBS=-L$(LOCALBASE)/lib -lelf $(PTHREAD_LIBS)
else
ifeq ($(shell uname -o), Cygwin)
CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
@@ -61,17 +61,17 @@
#SOURCES += profiler.c
#CFLAGS += -p -DPROFILE -DPROFILE_FILE=\"$(PROG).profile\"
-ifeq ($(ARCH),x86)
+ifeq ($(DYNAMIPS_ARCH),x86)
HDR += x86-codegen.h x86_trans.h
SOURCES += x86_trans.c
endif
-ifeq ($(ARCH),amd64)
+ifeq ($(DYNAMIPS_ARCH),amd64)
HDR += x86-codegen.h amd64-codegen.h amd64_trans.h
SOURCES += amd64_trans.c
endif
-ifeq ($(ARCH),nojit)
+ifeq ($(DYNAMIPS_ARCH),nojit)
HDR += nojit_trans.h
SOURCES += nojit_trans.c
endif
@@ -101,7 +101,7 @@
.PHONY: microcode
microcode:
- @$(CC) -Wall -o rom2c rom2c.c $(LIBS)
+ @$(CC) -Wall $(CFLAGS) -o rom2c rom2c.c $(LIBS)
@./rom2c microcode microcode_dump.inc
.PHONY: clean

View file

@ -0,0 +1,3 @@
Cisco 7200 simulator.
WWW: http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator