- Update to 2.11

Changes: http://www.japheth.de/JWasm/History.txt
This commit is contained in:
Alex Kozlov 2013-10-21 15:05:55 +00:00
parent 124e223954
commit f2a3992c7a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=331148
6 changed files with 3 additions and 63 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= jwasm
PORTVERSION= 210
PORTVERSION= 211
CATEGORIES= devel
MASTER_SITES= http://www.japheth.de/Download/JWasm/
DISTNAME= JWasm${PORTVERSION}s
@ -24,8 +24,6 @@ MAKEFILE= GccUnix.mak
PORTDOCS= *
PLIST_FILES= bin/jwasm
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e \
'/^extra_c_flags/s|-O2|$$(CFLAGS)| ; \

View file

@ -1,2 +1,2 @@
SHA256 (JWasm210s.zip) = 8d9a5ac95fa07a8e935423f3d1e44127c79d873e380f04d1ce8e1a65ca7daafd
SIZE (JWasm210s.zip) = 939008
SHA256 (JWasm211s.zip) = 6d5ab10908fbedddf652b2c683e9fdf450caae9741082c1077100308d0879146
SIZE (JWasm211s.zip) = 1006791

View file

@ -1,10 +0,0 @@
--- H/expreval.h.orig
+++ H/expreval.h
@@ -130,6 +130,7 @@
EXPF_IN_SQBR = 8 /* private flag, used inside expreval.c only */
};
+extern void EmitConstError( const struct expr * );
extern ret_code EvalOperand( int *, struct asm_tok[], int, struct expr *, uint_8 );
extern void ExprEvalInit( void );

View file

@ -1,10 +0,0 @@
--- H/parser.h.orig
+++ H/parser.h
@@ -302,7 +302,6 @@
extern ret_code MemtypeFromSize( int, enum memtype * );
extern int SizeFromRegister( int );
extern ret_code GetLangType( int *, struct asm_tok[], enum lang_type * );
-extern void EmitConstError( const struct expr * );
extern void sym_add_table( struct symbol_queue *, struct dsym * );
extern void sym_remove_table( struct symbol_queue *, struct dsym * );

View file

@ -1,19 +0,0 @@
--- expreval.c.orig
+++ expreval.c
@@ -79,6 +79,16 @@
LS_FAR32 = 0xFF06,
};
+void EmitConstError( const struct expr *opnd )
+/********************************************/
+{
+ if ( opnd->hlvalue != 0 )
+ EmitErr( CONSTANT_VALUE_TOO_LARGE_EX, opnd->hlvalue, opnd->value64 );
+ else
+ EmitErr( CONSTANT_VALUE_TOO_LARGE, opnd->value64 );
+ return;
+}
+
static const uint_16 tbaseptr[] = { T_BP, T_EBP
#if AMD64_SUPPORT
, T_RBP

View file

@ -1,19 +0,0 @@
--- parser.c.orig
+++ parser.c
@@ -787,16 +787,6 @@
return( NOT_ERROR );
}
-void EmitConstError( const struct expr *opnd )
-/********************************************/
-{
- if ( opnd->hlvalue != 0 )
- EmitErr( CONSTANT_VALUE_TOO_LARGE_EX, opnd->hlvalue, opnd->value64 );
- else
- EmitErr( CONSTANT_VALUE_TOO_LARGE, opnd->value64 );
- return;
-}
-
/* get an immediate operand without a fixup.
* output:
* - ERROR: error