- Update to 1.3.1 Final
- Bugfixes: - Fixed compilation error in mod_sql_mysql. - Fixed handling of the --ipv4 and --ipv6 command-line options. - Fixed "directory not accessible" errors when using the mod_facl module. - Patches integrated upstream. Approved by: sat (mentor), portmgr (linimon)
This commit is contained in:
parent
689f9b8b18
commit
f2aa6a83a2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=201012
16 changed files with 16 additions and 238 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= proftpd
|
||||
DISTVERSION= 1.3.1rc3
|
||||
PORTREVISION= 6
|
||||
DISTVERSION= 1.3.1
|
||||
CATEGORIES= ftp
|
||||
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
|
||||
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
|
||||
|
@ -163,7 +162,6 @@ USE_OPENLDAP= yes
|
|||
MODULES:=${MODULES}:mod_ldap
|
||||
INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
|
||||
LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
|
||||
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-contrib-mod_ldap.c
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MYSQL)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
MD5 (proftpd-1.3.1rc3.tar.bz2) = 485af3aee9ecebfeae1ae2003250a3a9
|
||||
SHA256 (proftpd-1.3.1rc3.tar.bz2) = 9bad65ea4ddca40547ca6bb1aa337c7d4ae54752bb9f5fc76124a8c4535daefd
|
||||
SIZE (proftpd-1.3.1rc3.tar.bz2) = 1538700
|
||||
MD5 (proftpd-1.3.1.tar.bz2) = 175958df8de92d5209b7b1e2e23a5a28
|
||||
SHA256 (proftpd-1.3.1.tar.bz2) = 03bc023e5b7b1c04d8eb2d5dca53b931b3e02cc7aba7dd8f629b0878535dc91b
|
||||
SIZE (proftpd-1.3.1.tar.bz2) = 2243888
|
||||
MD5 (mod_clamav-0.5.tar.bz2) = a098b630db1aa4ce02d77be84c21e59d
|
||||
SHA256 (mod_clamav-0.5.tar.bz2) = badab5d0577439e4de4a4d8fa6d1035da4884cc5b8e5569057816da4ced9667f
|
||||
SIZE (mod_clamav-0.5.tar.bz2) = 3027
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
---contrib/mod_ldap.c.orig 2007-07-02 15:20:31.000000000 -0800
|
||||
+++ contrib/mod_ldap.c 2007-08-27 13:48:11.000000000 -0800
|
||||
@@ -22,7 +22,7 @@
|
||||
*/
|
||||
|
||||
/*
|
||||
- * mod_ldap v2.8.17-20070701
|
||||
+ * mod_ldap v2.8.17
|
||||
*
|
||||
* Thanks for patches go to (in alphabetical order):
|
||||
*
|
||||
@@ -48,7 +48,7 @@
|
||||
* LDAPDefaultAuthScheme
|
||||
*
|
||||
*
|
||||
- * $Id: mod_ldap.c,v 1.54 2007/07/02 23:20:31 jwm Exp $
|
||||
+ * $Id: mod_ldap.c,v 1.57 2007/08/22 02:00:06 jwm Exp $
|
||||
* $Libraries: -lldap -llber$
|
||||
*/
|
||||
|
||||
@@ -70,7 +70,7 @@
|
||||
#include "conf.h"
|
||||
#include "privs.h"
|
||||
|
||||
-#define MOD_LDAP_VERSION "mod_ldap/2.8.17-20070701"
|
||||
+#define MOD_LDAP_VERSION "mod_ldap/2.8.17"
|
||||
|
||||
#if PROFTPD_VERSION_NUMBER < 0x0001021002
|
||||
# error MOD_LDAP_VERSION " requires ProFTPD 1.2.10rc2 or later"
|
||||
@@ -2245,8 +2245,8 @@
|
||||
* ldap_init() will connect to the LDAP SDK's default.
|
||||
*/
|
||||
if ((c = find_config(main_server->conf, CONF_PARAM, "LDAPServer", FALSE)) != NULL) {
|
||||
- if (strcmp(c->argv[1], "url") == 0) {
|
||||
- url = c->argv[2];
|
||||
+ if (strcmp(c->argv[0], "url") == 0) {
|
||||
+ url = c->argv[1];
|
||||
if (url) {
|
||||
#ifdef LDAP_OPT_X_TLS_HARD
|
||||
if (strcmp(url->lud_scheme, "ldaps") == 0) {
|
||||
@@ -2269,8 +2269,8 @@
|
||||
* by other/future callers.
|
||||
*/
|
||||
}
|
||||
- } else if (strcmp(c->argv[1], "host") == 0) {
|
||||
- ldap_server = c->argv[2];
|
||||
+ } else if (strcmp(c->argv[0], "host") == 0) {
|
||||
+ ldap_server = c->argv[1];
|
||||
} else {
|
||||
/* This should never happen, since the configuration handler for
|
||||
* LDAPServer only passes url or host, but we'll be defensive.
|
|
@ -1,5 +1,5 @@
|
|||
--- modules/mod_auth_unix.c.orig Thu May 13 23:40:18 2004
|
||||
+++ modules/mod_auth_unix.c Thu May 13 23:40:27 2004
|
||||
--- modules/mod_auth_unix.c.orig 2006-06-29 09:16:23.000000000 -0800
|
||||
+++ modules/mod_auth_unix.c 2007-10-05 16:23:46.000000000 -0800
|
||||
@@ -57,6 +57,7 @@
|
||||
#endif /* HAVE_HPSECURITY_H or HPUX10 or HPUX11 */
|
||||
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- contrib/mod_sql_mysql.c.orig 2007-07-05 10:34:43.000000000 -0800
|
||||
+++ contrib/mod_sql_mysql.c 2007-07-05 10:42:05.000000000 -0800
|
||||
@@ -595,7 +595,7 @@
|
||||
}
|
||||
|
||||
if (!conn_pool) {
|
||||
- pr_log_pri(PR_LOG_WARNING, "warning: the mod_sql_mysql module has not been
|
||||
+ pr_log_pri(PR_LOG_WARNING, "warning: the mod_sql_mysql module has not been"
|
||||
"properly intialized. Please make sure your --with-modules configure "
|
||||
"option lists mod_sql *before* mod_sql_mysql, and recompile.");
|
||||
|
|
@ -1,5 +1,5 @@
|
|||
--- contrib/mod_wrap2/Makefile.in.orig Wed Sep 6 15:11:47 2006
|
||||
+++ contrib/mod_wrap2/Makefile.in Thu Dec 28 11:41:24 2006
|
||||
--- contrib/mod_wrap2/Makefile.in.orig 2007-01-08 19:16:11.000000000 -0900
|
||||
+++ contrib/mod_wrap2/Makefile.in 2007-10-05 14:02:38.000000000 -0800
|
||||
@@ -13,7 +13,7 @@
|
||||
MODULE_NAME=mod_wrap2
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
Index: modules/Makefile.in
|
||||
===================================================================
|
||||
RCS file: /cvsroot/proftp/proftpd/modules/Makefile.in,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 Makefile.in
|
||||
--- modules/Makefile.in 8 Jan 2007 19:58:22 -0000 1.24
|
||||
+++ modules/Makefile.in 17 Sep 2007 17:27:11 -0000
|
||||
@@ -50,7 +50,7 @@
|
||||
test -z "$(SHARED_MODULE_OBJS)" || $(LIBTOOL) --mode=install $(INSTALL_BIN) $(SHARED_MODULE_OBJS) $(DESTDIR)$(LIBEXECDIR)
|
||||
@dirs="$(SHARED_MODULE_DIRS)"; \
|
||||
for dir in $$dirs; do\
|
||||
- cd $(top_srcdir)/$$dir/ && $(MAKE) install; \
|
||||
+ (cd $(top_srcdir)/$$dir/ && $(MAKE) install); \
|
||||
done
|
||||
|
||||
clean:
|
||||
@@ -59,7 +59,7 @@
|
||||
$(LIBTOOL) --mode=clean $(RM) `echo $(SHARED_MODULE_OBJS) | sed 's/\.la$\/.lo/g'`
|
||||
@dirs="$(SHARED_MODULE_DIRS) $(STATIC_MODULE_DIRS)"; \
|
||||
for dir in $$dirs; do\
|
||||
- cd $(top_srcdir)/$$dir/ && $(MAKE) clean; \
|
||||
+ (cd $(top_srcdir)/$$dir/ && $(MAKE) clean); \
|
||||
done
|
||||
|
||||
depend:
|
|
@ -1,22 +0,0 @@
|
|||
Index: src/dirtree.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/proftp/proftpd/src/dirtree.c,v
|
||||
retrieving revision 1.184
|
||||
diff -u -r1.184 dirtree.c
|
||||
--- src/dirtree.c 22 Mar 2007 03:54:20 -0000 1.184
|
||||
+++ src/dirtree.c 24 Jul 2007 17:13:05 -0000
|
||||
@@ -2911,12 +2911,13 @@
|
||||
* this address.
|
||||
*/
|
||||
snprintf(ipbuf, sizeof(ipbuf), "::ffff:%s", ipstr);
|
||||
- ipstr = ipbuf;
|
||||
+ ipstr = pstrdup(s->pool, ipbuf);
|
||||
}
|
||||
}
|
||||
#endif /* PR_USE_IPV6 */
|
||||
|
||||
- pr_conf_add_server_config_param_str(s, "_bind", 1, ipstr);
|
||||
+ if (ipstr)
|
||||
+ pr_conf_add_server_config_param_str(s, "_bind", 1, ipstr);
|
||||
}
|
||||
}
|
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= proftpd
|
||||
DISTVERSION= 1.3.1rc3
|
||||
PORTREVISION= 6
|
||||
DISTVERSION= 1.3.1
|
||||
CATEGORIES= ftp
|
||||
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
|
||||
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
|
||||
|
@ -163,7 +162,6 @@ USE_OPENLDAP= yes
|
|||
MODULES:=${MODULES}:mod_ldap
|
||||
INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
|
||||
LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
|
||||
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-contrib-mod_ldap.c
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MYSQL)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
MD5 (proftpd-1.3.1rc3.tar.bz2) = 485af3aee9ecebfeae1ae2003250a3a9
|
||||
SHA256 (proftpd-1.3.1rc3.tar.bz2) = 9bad65ea4ddca40547ca6bb1aa337c7d4ae54752bb9f5fc76124a8c4535daefd
|
||||
SIZE (proftpd-1.3.1rc3.tar.bz2) = 1538700
|
||||
MD5 (proftpd-1.3.1.tar.bz2) = 175958df8de92d5209b7b1e2e23a5a28
|
||||
SHA256 (proftpd-1.3.1.tar.bz2) = 03bc023e5b7b1c04d8eb2d5dca53b931b3e02cc7aba7dd8f629b0878535dc91b
|
||||
SIZE (proftpd-1.3.1.tar.bz2) = 2243888
|
||||
MD5 (mod_clamav-0.5.tar.bz2) = a098b630db1aa4ce02d77be84c21e59d
|
||||
SHA256 (mod_clamav-0.5.tar.bz2) = badab5d0577439e4de4a4d8fa6d1035da4884cc5b8e5569057816da4ced9667f
|
||||
SIZE (mod_clamav-0.5.tar.bz2) = 3027
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
---contrib/mod_ldap.c.orig 2007-07-02 15:20:31.000000000 -0800
|
||||
+++ contrib/mod_ldap.c 2007-08-27 13:48:11.000000000 -0800
|
||||
@@ -22,7 +22,7 @@
|
||||
*/
|
||||
|
||||
/*
|
||||
- * mod_ldap v2.8.17-20070701
|
||||
+ * mod_ldap v2.8.17
|
||||
*
|
||||
* Thanks for patches go to (in alphabetical order):
|
||||
*
|
||||
@@ -48,7 +48,7 @@
|
||||
* LDAPDefaultAuthScheme
|
||||
*
|
||||
*
|
||||
- * $Id: mod_ldap.c,v 1.54 2007/07/02 23:20:31 jwm Exp $
|
||||
+ * $Id: mod_ldap.c,v 1.57 2007/08/22 02:00:06 jwm Exp $
|
||||
* $Libraries: -lldap -llber$
|
||||
*/
|
||||
|
||||
@@ -70,7 +70,7 @@
|
||||
#include "conf.h"
|
||||
#include "privs.h"
|
||||
|
||||
-#define MOD_LDAP_VERSION "mod_ldap/2.8.17-20070701"
|
||||
+#define MOD_LDAP_VERSION "mod_ldap/2.8.17"
|
||||
|
||||
#if PROFTPD_VERSION_NUMBER < 0x0001021002
|
||||
# error MOD_LDAP_VERSION " requires ProFTPD 1.2.10rc2 or later"
|
||||
@@ -2245,8 +2245,8 @@
|
||||
* ldap_init() will connect to the LDAP SDK's default.
|
||||
*/
|
||||
if ((c = find_config(main_server->conf, CONF_PARAM, "LDAPServer", FALSE)) != NULL) {
|
||||
- if (strcmp(c->argv[1], "url") == 0) {
|
||||
- url = c->argv[2];
|
||||
+ if (strcmp(c->argv[0], "url") == 0) {
|
||||
+ url = c->argv[1];
|
||||
if (url) {
|
||||
#ifdef LDAP_OPT_X_TLS_HARD
|
||||
if (strcmp(url->lud_scheme, "ldaps") == 0) {
|
||||
@@ -2269,8 +2269,8 @@
|
||||
* by other/future callers.
|
||||
*/
|
||||
}
|
||||
- } else if (strcmp(c->argv[1], "host") == 0) {
|
||||
- ldap_server = c->argv[2];
|
||||
+ } else if (strcmp(c->argv[0], "host") == 0) {
|
||||
+ ldap_server = c->argv[1];
|
||||
} else {
|
||||
/* This should never happen, since the configuration handler for
|
||||
* LDAPServer only passes url or host, but we'll be defensive.
|
|
@ -1,5 +1,5 @@
|
|||
--- modules/mod_auth_unix.c.orig Thu May 13 23:40:18 2004
|
||||
+++ modules/mod_auth_unix.c Thu May 13 23:40:27 2004
|
||||
--- modules/mod_auth_unix.c.orig 2006-06-29 09:16:23.000000000 -0800
|
||||
+++ modules/mod_auth_unix.c 2007-10-05 16:23:46.000000000 -0800
|
||||
@@ -57,6 +57,7 @@
|
||||
#endif /* HAVE_HPSECURITY_H or HPUX10 or HPUX11 */
|
||||
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- contrib/mod_sql_mysql.c.orig 2007-07-05 10:34:43.000000000 -0800
|
||||
+++ contrib/mod_sql_mysql.c 2007-07-05 10:42:05.000000000 -0800
|
||||
@@ -595,7 +595,7 @@
|
||||
}
|
||||
|
||||
if (!conn_pool) {
|
||||
- pr_log_pri(PR_LOG_WARNING, "warning: the mod_sql_mysql module has not been
|
||||
+ pr_log_pri(PR_LOG_WARNING, "warning: the mod_sql_mysql module has not been"
|
||||
"properly intialized. Please make sure your --with-modules configure "
|
||||
"option lists mod_sql *before* mod_sql_mysql, and recompile.");
|
||||
|
|
@ -1,5 +1,5 @@
|
|||
--- contrib/mod_wrap2/Makefile.in.orig Wed Sep 6 15:11:47 2006
|
||||
+++ contrib/mod_wrap2/Makefile.in Thu Dec 28 11:41:24 2006
|
||||
--- contrib/mod_wrap2/Makefile.in.orig 2007-01-08 19:16:11.000000000 -0900
|
||||
+++ contrib/mod_wrap2/Makefile.in 2007-10-05 14:02:38.000000000 -0800
|
||||
@@ -13,7 +13,7 @@
|
||||
MODULE_NAME=mod_wrap2
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
Index: modules/Makefile.in
|
||||
===================================================================
|
||||
RCS file: /cvsroot/proftp/proftpd/modules/Makefile.in,v
|
||||
retrieving revision 1.24
|
||||
diff -u -r1.24 Makefile.in
|
||||
--- modules/Makefile.in 8 Jan 2007 19:58:22 -0000 1.24
|
||||
+++ modules/Makefile.in 17 Sep 2007 17:27:11 -0000
|
||||
@@ -50,7 +50,7 @@
|
||||
test -z "$(SHARED_MODULE_OBJS)" || $(LIBTOOL) --mode=install $(INSTALL_BIN) $(SHARED_MODULE_OBJS) $(DESTDIR)$(LIBEXECDIR)
|
||||
@dirs="$(SHARED_MODULE_DIRS)"; \
|
||||
for dir in $$dirs; do\
|
||||
- cd $(top_srcdir)/$$dir/ && $(MAKE) install; \
|
||||
+ (cd $(top_srcdir)/$$dir/ && $(MAKE) install); \
|
||||
done
|
||||
|
||||
clean:
|
||||
@@ -59,7 +59,7 @@
|
||||
$(LIBTOOL) --mode=clean $(RM) `echo $(SHARED_MODULE_OBJS) | sed 's/\.la$\/.lo/g'`
|
||||
@dirs="$(SHARED_MODULE_DIRS) $(STATIC_MODULE_DIRS)"; \
|
||||
for dir in $$dirs; do\
|
||||
- cd $(top_srcdir)/$$dir/ && $(MAKE) clean; \
|
||||
+ (cd $(top_srcdir)/$$dir/ && $(MAKE) clean); \
|
||||
done
|
||||
|
||||
depend:
|
|
@ -1,22 +0,0 @@
|
|||
Index: src/dirtree.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/proftp/proftpd/src/dirtree.c,v
|
||||
retrieving revision 1.184
|
||||
diff -u -r1.184 dirtree.c
|
||||
--- src/dirtree.c 22 Mar 2007 03:54:20 -0000 1.184
|
||||
+++ src/dirtree.c 24 Jul 2007 17:13:05 -0000
|
||||
@@ -2911,12 +2911,13 @@
|
||||
* this address.
|
||||
*/
|
||||
snprintf(ipbuf, sizeof(ipbuf), "::ffff:%s", ipstr);
|
||||
- ipstr = ipbuf;
|
||||
+ ipstr = pstrdup(s->pool, ipbuf);
|
||||
}
|
||||
}
|
||||
#endif /* PR_USE_IPV6 */
|
||||
|
||||
- pr_conf_add_server_config_param_str(s, "_bind", 1, ipstr);
|
||||
+ if (ipstr)
|
||||
+ pr_conf_add_server_config_param_str(s, "_bind", 1, ipstr);
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue