multimedia/openshot: Update to 2.4.4
- give maintainership to tatsuki_makino@hotmail.com PR: 234803 Submitted by: Tatsuki Makino <tatsuki_makino@hotmail.com>, Reported by: kunda <chitty_cloud@me.com>
This commit is contained in:
parent
e7bf608b71
commit
f2d3bfa7ac
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=519293
10 changed files with 2183 additions and 2187 deletions
|
@ -2,41 +2,31 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= openshot
|
||||
PORTVERSION= 1.4.3
|
||||
PORTREVISION= 12
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.4.4-443
|
||||
DISTVERSIONSUFFIX= -g7351f506
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://launchpad.net/openshot/${PORTVERSION:C/\.[0-9]+$//}/${PORTVERSION}/+download/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Non-linear video editor
|
||||
MAINTAINER= tatsuki_makino@hotmail.com
|
||||
COMMENT= OpenShot Video Editor
|
||||
|
||||
LICENSE= GPLv3+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
RUN_DEPENDS= ffmpeg:multimedia/ffmpeg \
|
||||
frei0r-plugins>=0:graphics/frei0r-plugins \
|
||||
${PYTHON_PKGNAMEPREFIX}goocanvas>=0:graphics/py-goocanvas@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}httplib2>=0:www/py-httplib2@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}mlt>=0:multimedia/py-mlt@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}xdg>=0:devel/py-xdg@${PY_FLAVOR} \
|
||||
scrollkeeper-install:textproc/rarian \
|
||||
sox:audio/sox
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/openshot.py:multimedia/libopenshot \
|
||||
${PYTHON_PKGNAMEPREFIX}pyzmq>=0:net/py-pyzmq@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
|
||||
|
||||
USES= desktop-file-utils gettext gnome python:2.7 shared-mime-info
|
||||
USE_GNOME= pygtk2
|
||||
USE_PYTHON= distutils
|
||||
INSTALLS_OMF= yes
|
||||
NO_ARCH= yes
|
||||
USES= desktop-file-utils pyqt:5 python:3.5+ shared-mime-info shebangfix
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= OpenShot
|
||||
GH_PROJECT= ${PORTNAME}-qt
|
||||
USE_PYQT= core gui svg webkitwidgets widgets
|
||||
USE_PYTHON= distutils noflavors
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC}/docs/omf -name '*.omf' | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|/usr/share|${PREFIX}/share|g'
|
||||
|
||||
pre-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/share/omf/${PORTNAME}
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/omf/*.omf ${STAGEDIR}${PREFIX}/share/omf/${PORTNAME}
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/share/gnome/help/${PORTNAME}
|
||||
@cd ${WRKSRC}/docs/gnome && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/gnome/help/${PORTNAME}
|
||||
SHEBANG_FILES= src/language/generate_translations.py\
|
||||
src/language/show_translations.py\
|
||||
src/language/test_translations.py
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (openshot-1.4.3.tar.gz) = 5bebf1c59a8667b0263599544f2d23ce6be3ab79ce24a85b766e1e39cab859d0
|
||||
SIZE (openshot-1.4.3.tar.gz) = 31990991
|
||||
TIMESTAMP = 1573527600
|
||||
SHA256 (OpenShot-openshot-qt-v2.4.4-443-g7351f506_GH0.tar.gz) = 8c1545c3eeadc16e2099d0aadde7049e648cc38402aea19f602d42f036728ea2
|
||||
SIZE (OpenShot-openshot-qt-v2.4.4-443-g7351f506_GH0.tar.gz) = 59428059
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- openshot/language/Language_Init.py.orig 2012-01-02 03:39:04.000000000 +0400
|
||||
+++ openshot/language/Language_Init.py 2012-03-24 21:08:33.000000000 +0400
|
||||
@@ -82,8 +82,8 @@
|
||||
|
||||
# Set locale specific settings
|
||||
locale.setlocale(locale.LC_ALL)
|
||||
- locale.bindtextdomain("OpenShot", self.project.LOCALE_DIR)
|
||||
- locale.bind_textdomain_codeset("OpenShot", "UTF-8")
|
||||
+# locale.bindtextdomain("OpenShot", self.project.LOCALE_DIR)
|
||||
+# locale.bind_textdomain_codeset("OpenShot", "UTF-8")
|
||||
|
||||
# Set gettext settings
|
||||
gettext.bindtextdomain("OpenShot", self.project.LOCALE_DIR)
|
|
@ -1,42 +1,47 @@
|
|||
--- ./setup.py.orig 2011-02-04 12:07:09.000000000 -0800
|
||||
+++ ./setup.py 2011-03-04 04:57:02.000000000 -0800
|
||||
@@ -40,10 +40,10 @@
|
||||
# XDG desktop mime types cache
|
||||
('share/mime/packages',['xdg/openshot.xml']),
|
||||
# launcher (mime.types)
|
||||
- ('lib/mime/packages',['xdg/openshot']),
|
||||
+ #('lib/mime/packages',['xdg/openshot']),
|
||||
# man-page ("man 1 openshot")
|
||||
- ('share/man/man1',['docs/openshot.1']),
|
||||
- ('share/man/man1',['docs/openshot-render.1']),
|
||||
+ ('man/man1',['docs/openshot.1']),
|
||||
+ ('man/man1',['docs/openshot-render.1']),
|
||||
--- setup.py.orig 2019-11-11 07:57:57 UTC
|
||||
+++ setup.py
|
||||
@@ -68,7 +68,7 @@ os_files = [
|
||||
# AppStream metadata
|
||||
('share/metainfo', ['xdg/org.openshot.OpenShot.appdata.xml']),
|
||||
# Debian menu system application icon
|
||||
- ('share/pixmaps', ['xdg/openshot-qt.svg']),
|
||||
+ ('share/pixmaps', ['xdg/icon/64/openshot-qt.png']),
|
||||
# XDG Freedesktop icon paths
|
||||
('share/icons/hicolor/scalable/apps', ['xdg/openshot-qt.svg']),
|
||||
('share/icons/hicolor/64x64/apps', ['xdg/icon/64/openshot-qt.png']),
|
||||
@@ -77,7 +77,7 @@ os_files = [
|
||||
# XDG desktop mime types cache
|
||||
('share/mime/packages', ['xdg/org.openshot.OpenShot.xml']),
|
||||
# launcher (mime.types)
|
||||
- ('lib/mime/packages', ['xdg/openshot-qt']),
|
||||
+ #('lib/mime/packages', ['xdg/openshot-qt']),
|
||||
]
|
||||
|
||||
# Add all the translations
|
||||
@@ -70,7 +70,7 @@
|
||||
|
||||
# Find files matching patterns
|
||||
@@ -118,26 +118,6 @@ if os.path.exists(os.path.join(PATH, "src")):
|
||||
FAILED = 'Failed to update.\n'
|
||||
|
||||
-if ROOT and dist != None:
|
||||
+if ROOT and sys.argv[1] == "install" and dist != None:
|
||||
#update the XDG Shared MIME-Info database cache
|
||||
try:
|
||||
sys.stdout.write('Updating the Shared MIME-Info database cache.\n')
|
||||
@@ -79,11 +79,11 @@
|
||||
sys.stderr.write(FAILED)
|
||||
|
||||
#update the mime.types database
|
||||
- try:
|
||||
- sys.stdout.write('Updating the mime.types database\n')
|
||||
- subprocess.call("update-mime")
|
||||
- except:
|
||||
- sys.stderr.write(FAILED)
|
||||
+ #try:
|
||||
+ # sys.stdout.write('Updating the mime.types database\n')
|
||||
+ # subprocess.call("update-mime")
|
||||
+ #except:
|
||||
+ # sys.stderr.write(FAILED)
|
||||
|
||||
# update the XDG .desktop file database
|
||||
try:
|
||||
if ROOT and dist != None:
|
||||
- # update the XDG Shared MIME-Info database cache
|
||||
- try:
|
||||
- sys.stdout.write('Updating the Shared MIME-Info database cache.\n')
|
||||
- subprocess.call(["update-mime-database", os.path.join(sys.prefix, "share/mime/")])
|
||||
- except:
|
||||
- sys.stderr.write(FAILED)
|
||||
-
|
||||
- # update the mime.types database
|
||||
- try:
|
||||
- sys.stdout.write('Updating the mime.types database\n')
|
||||
- subprocess.call("update-mime")
|
||||
- except:
|
||||
- sys.stderr.write(FAILED)
|
||||
-
|
||||
- # update the XDG .desktop file database
|
||||
- try:
|
||||
- sys.stdout.write('Updating the .desktop file database.\n')
|
||||
- subprocess.call(["update-desktop-database"])
|
||||
- except:
|
||||
- sys.stderr.write(FAILED)
|
||||
sys.stdout.write("\n-----------------------------------------------")
|
||||
sys.stdout.write("\nInstallation Finished!")
|
||||
sys.stdout.write("\nRun OpenShot by typing 'openshot-qt' or through the Applications menu.")
|
||||
|
|
10
multimedia/openshot/files/patch-src_classes_info.py
Normal file
10
multimedia/openshot/files/patch-src_classes_info.py
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/classes/info.py.orig 2019-11-11 07:57:57 UTC
|
||||
+++ src/classes/info.py
|
||||
@@ -125,6 +125,7 @@ SETUP = {
|
||||
"License :: OSI Approved :: GNU General Public License (GPL)",
|
||||
"Operating System :: OS Independent",
|
||||
"Operating System :: POSIX :: Linux",
|
||||
+ "Operating System :: POSIX :: BSD :: FreeBSD",
|
||||
"Programming Language :: Python",
|
||||
"Topic :: Artistic Software",
|
||||
"Topic :: Multimedia :: Video :: Non-Linear Editor", ] +
|
14
multimedia/openshot/files/patch-src_classes_metrics.py
Normal file
14
multimedia/openshot/files/patch-src_classes_metrics.py
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- src/classes/metrics.py.orig 2019-11-11 07:57:57 UTC
|
||||
+++ src/classes/metrics.py
|
||||
@@ -53,6 +53,11 @@ try:
|
||||
os_version = "Macintosh; Intel Mac OS X %s" % v[0].replace(".", "_")
|
||||
linux_distro = "OS X %s" % v[0]
|
||||
|
||||
+ elif 0 and platform.system() == "FreeBSD":
|
||||
+ v = platform.version().split(" ")
|
||||
+ os_version = "X11; %s %s" % (v[0], platform.machine())
|
||||
+ linux_distro = " ".join([v[0], v[1]])
|
||||
+
|
||||
elif platform.system() == "Windows":
|
||||
v = platform.win32_ver()
|
||||
# TODO: Upgrade windows python (on build server) version to 3.5, so it correctly identifies Windows 10
|
11
multimedia/openshot/files/patch-src_windows_main__window.py
Normal file
11
multimedia/openshot/files/patch-src_windows_main__window.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/windows/main_window.py.orig 2019-11-11 07:57:57 UTC
|
||||
+++ src/windows/main_window.py
|
||||
@@ -247,6 +247,8 @@ class MainWindow(QMainWindow, updates.UpdateWatcher):
|
||||
# Format last log line based on OS (since each OS can be formatted differently)
|
||||
if platform.system() == "Darwin":
|
||||
last_log_line = "mac-%s" % last_log_line[58:].strip()
|
||||
+ elif platform.system() == "FreeBSD":
|
||||
+ last_log_line = "freebsd-%s" % last_log_line.replace("/usr/local/lib/", "")
|
||||
elif platform.system() == "Windows":
|
||||
last_log_line = "windows-%s" % last_log_line
|
||||
elif platform.system() == "Linux":
|
11
multimedia/openshot/files/patch-src_windows_preferences.py
Normal file
11
multimedia/openshot/files/patch-src_windows_preferences.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/windows/preferences.py.orig 2019-11-11 07:57:57 UTC
|
||||
+++ src/windows/preferences.py
|
||||
@@ -293,7 +293,7 @@ class Preferences(QDialog):
|
||||
value_list.remove(value_item)
|
||||
elif os_platform == "Windows" and v not in ("0", "3", "4", "7"):
|
||||
value_list.remove(value_item)
|
||||
- elif os_platform == "Linux" and v not in ("0", "1", "2", "6", "7"):
|
||||
+ elif (os_platform == "FreeBSD" or os_platform == "Linux") and v not in ("0", "1", "2", "6", "7"):
|
||||
value_list.remove(value_item)
|
||||
|
||||
# Remove hardware mode items which cannot decode the example video
|
|
@ -1,12 +1,5 @@
|
|||
OpenShot Video Editor is a program designed to create videos on
|
||||
Linux. It can easily combine multiple video clips, audio clips,
|
||||
and images into a single project, and then export the video into
|
||||
many common video formats.
|
||||
|
||||
OpenShot is a non-linear video editor, which means any frame of
|
||||
video can be accessed at any time, and thus the video clips can
|
||||
be layered, mixed, and arranged in very creative ways. All
|
||||
video clip edits (trimming, cutting, etc...) are non-destructive,
|
||||
meaning that the original video clips are never modified.
|
||||
OpenShot Video Editor is an award-winning free and open-source video editor for
|
||||
Linux, Mac, and Windows, and is dedicated to delivering high quality video
|
||||
editing and animation solutions to the world.
|
||||
|
||||
WWW: https://www.openshot.org/
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue