- Update to 1.2

PR:		202087
Submitted by:	mp39590@gmail.com (maintainer)
This commit is contained in:
Dmitry Marakasov 2015-08-17 09:17:23 +00:00
parent c335b7a5c2
commit f30f1509ca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=394443
3 changed files with 3 additions and 57 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= orthanc-portgresql
PORTVERSION= 1.1
PORTVERSION= 1.2
CATEGORIES= science graphics
MASTER_SITES= http://orthanc-server.com/downloads/get.php?path=/plugin-postgresql/
DISTNAME= OrthancPostgreSQL-${PORTVERSION}

View file

@ -1,2 +1,2 @@
SHA256 (orthanc/OrthancPostgreSQL-1.1.tar.gz) = f68d98a1f282ad31ac3fde2ff11449db840a5daf8a9605f3a9d5678691bd9b84
SIZE (orthanc/OrthancPostgreSQL-1.1.tar.gz) = 56750
SHA256 (orthanc/OrthancPostgreSQL-1.2.tar.gz) = 629bf07a7365d9570b340f336cc2367b30fe6244d32ca881d7a3a0ea9802e8a9
SIZE (orthanc/OrthancPostgreSQL-1.2.tar.gz) = 81424

View file

@ -1,54 +0,0 @@
--- CMakeLists.txt.orig 2015-07-03 09:22:49 UTC
+++ CMakeLists.txt
@@ -32,6 +32,7 @@ set(USE_SYSTEM_JSONCPP ON CACHE BOOL "Us
set(USE_SYSTEM_BOOST ON CACHE BOOL "Use the system version of Boost")
set(USE_SYSTEM_GOOGLE_TEST ON CACHE BOOL "Use the system version of Google Test")
set(USE_SYSTEM_LIBPQ ON CACHE BOOL "Use the system version of the PostgreSQL client library")
+set(BUILD_UNIT_TESTS ON CACHE BOOL "Build UnitTests")
# Distribution-specific settings
set(USE_GTEST_DEBIAN_SOURCE_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
@@ -47,7 +48,10 @@ include(${CMAKE_SOURCE_DIR}/Resources/CM
include(${CMAKE_SOURCE_DIR}/Resources/CMake/BoostConfiguration.cmake)
include(${CMAKE_SOURCE_DIR}/Resources/CMake/PostgreSQLConfiguration.cmake)
include(${CMAKE_SOURCE_DIR}/Resources/CMake/JsonCppConfiguration.cmake)
-include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleTestConfiguration.cmake)
+
+if (BUILD_UNIT_TESTS)
+ include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleTestConfiguration.cmake)
+endif()
# Check that the Orthanc SDK headers are available or download them
@@ -123,14 +127,21 @@ set_target_properties(OrthancPostgreSQLI
SOVERSION ${ORTHANC_POSTGRESQL_VERSION}
)
+install(
+ TARGETS OrthancPostgreSQLStorage OrthancPostgreSQLIndex
+ RUNTIME DESTINATION lib # Destination for Windows
+ LIBRARY DESTINATION share/orthanc/plugins # Destination for Linux
+)
-add_executable(UnitTests
- ${CORE_SOURCES}
- ${GTEST_SOURCES}
- ${AUTOGENERATED_SOURCES}
- ${CMAKE_SOURCE_DIR}/IndexPlugin/PostgreSQLWrapper.cpp
- ${CMAKE_SOURCE_DIR}/StoragePlugin/PostgreSQLStorageArea.cpp
- ${CMAKE_SOURCE_DIR}/UnitTestsSources/UnitTestsMain.cpp
- ${CMAKE_SOURCE_DIR}/UnitTestsSources/PostgreSQLTests.cpp
- ${CMAKE_SOURCE_DIR}/UnitTestsSources/PostgreSQLWrapperTests.cpp
- )
+if (BUILD_UNIT_TESTS)
+ add_executable(UnitTests
+ ${CORE_SOURCES}
+ ${GTEST_SOURCES}
+ ${AUTOGENERATED_SOURCES}
+ ${CMAKE_SOURCE_DIR}/IndexPlugin/PostgreSQLWrapper.cpp
+ ${CMAKE_SOURCE_DIR}/StoragePlugin/PostgreSQLStorageArea.cpp
+ ${CMAKE_SOURCE_DIR}/UnitTestsSources/UnitTestsMain.cpp
+ ${CMAKE_SOURCE_DIR}/UnitTestsSources/PostgreSQLTests.cpp
+ ${CMAKE_SOURCE_DIR}/UnitTestsSources/PostgreSQLWrapperTests.cpp
+ )
+endif()