Update to 1.21.1
PR: 202843 Submitted by: Ports Fury
This commit is contained in:
parent
1ddaaea2e3
commit
f310175ba4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=397972
7 changed files with 8 additions and 53 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= recoll
|
||||
PORTVERSION= 1.21.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.21.1
|
||||
CATEGORIES= deskutils
|
||||
MASTER_SITES= http://www.lesbonscomptes.com/${PORTNAME}/
|
||||
|
||||
|
@ -23,6 +22,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
|
|||
|
||||
USES= bison gmake iconv shebangfix
|
||||
SHEBANG_FILES= filters/rclimg filters/rclpdf desktop/hotrecoll.py
|
||||
USE_GNOME= libxslt:run
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-pic
|
||||
|
||||
|
@ -42,11 +42,11 @@ CHM_DESC= CHM via CHMLIB
|
|||
CHM_RUN_DEPENDS= pychm:${PORTSDIR}/textproc/pychm
|
||||
DJVU_RUN_DEPENDS= djvutxt:${PORTSDIR}/graphics/djvulibre
|
||||
IMAGE_DESC= Store personal tags or textual descriptions in images
|
||||
IMAGE_RUN_DEPENDS= exiftool:${PORTSDIR}/graphics/p5-Image-ExifTool-devel
|
||||
IMAGE_RUN_DEPENDS= exiftool:${PORTSDIR}/graphics/p5-Image-ExifTool
|
||||
KONQUEROR_DESC= Konqueror webarchive format with Python
|
||||
KONQUEROR_RUN_DEPENDS= kwebkitpart:${PORTSDIR}/www/kwebkitpart
|
||||
LATEX_RUN_DEPENDS= detex:${PORTSDIR}/print/detex \
|
||||
dvips:${PORTSDIR}/print/tex-dvipsk
|
||||
LATEX_USE= tex=dvipsk:run
|
||||
#LATEX_RUN_DEPENDS= detex:${PORTSDIR}/print/detex
|
||||
PDF_RUN_DEPENDS= xpdf:${PORTSDIR}/graphics/xpdf
|
||||
PS_RUN_DEPENDS= pstotext:${PORTSDIR}/print/pstotext
|
||||
PYTHON_USES= python
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (recoll-1.21.0.tar.gz) = 0450d85d5065d22e87ae600571e3be23a5ff2000f533c15f819a5bd77164a1be
|
||||
SIZE (recoll-1.21.0.tar.gz) = 2234834
|
||||
SHA256 (recoll-1.21.1.tar.gz) = 74d09fabe7b53a7b6bc8bb3b5d8428d64e092c0cc2a7ea0559be681c9a26f1a9
|
||||
SIZE (recoll-1.21.1.tar.gz) = 2236877
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- mk/commondefs.orig 2015-07-16 19:52:37 UTC
|
||||
+++ mk/commondefs
|
||||
@@ -15,7 +15,7 @@ COMMONCXXFLAGS = -I. \
|
||||
# the sys file or localdefs
|
||||
SYSPICFLAGS = -fPIC -DPIC
|
||||
|
||||
-LIBRECOLL = -L$(depth)/lib -lrecoll -Wl,-rpath=$(libdir)/recoll
|
||||
+LIBRECOLL = -L$(depth)/lib -lrecoll -liconv -Wl,-rpath=$(libdir)/recoll
|
||||
|
||||
RANLIB = test -f
|
||||
AR=ar
|
|
@ -1,11 +0,0 @@
|
|||
--- query/Makefile.orig 2015-07-16 19:59:24 UTC
|
||||
+++ query/Makefile
|
||||
@@ -13,7 +13,7 @@ wasaparse.tab.cpp : wasaparse.y
|
||||
XADUMP_OBJS= xadump.o
|
||||
xadump : $(XADUMP_OBJS)
|
||||
$(CXX) $(ALL_CXXFLAGS) -o xadump $(XADUMP_OBJS) \
|
||||
- $(depth)/lib/librecoll.a $(LIBICONV) $(LIBXAPIAN) $(LIBSYS)
|
||||
+ $(depth)/lib/librecoll.a -liconv $(LIBICONV) $(LIBXAPIAN) $(LIBSYS)
|
||||
xadump.o : xadump.cpp
|
||||
$(CXX) $(ALL_CXXFLAGS) -c xadump.cpp
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- utils/Makefile.orig 2015-07-16 19:56:54 UTC
|
||||
+++ utils/Makefile
|
||||
@@ -4,7 +4,7 @@ include $(depth)/mk/sysconf
|
||||
# Use a static link for some of the utility programs so that they can be
|
||||
# executed independantly of the installed version of recoll. None of them
|
||||
# are part of the official distrib anyway
|
||||
-LIBRECOLL = ../lib/librecoll.a
|
||||
+LIBRECOLL = ../lib/librecoll.a -liconv
|
||||
|
||||
PROGS = pxattr trclosefrom trecrontab \
|
||||
trnetcon trcopyfile trcircache trmd5 trreadfile trfileudi \
|
|
@ -1,13 +0,0 @@
|
|||
--- utils/md5.h.orig 2015-07-16 19:46:26 UTC
|
||||
+++ utils/md5.h
|
||||
@@ -19,6 +19,10 @@
|
||||
#define MD5_DIGEST_LENGTH 16
|
||||
#define MD5_DIGEST_STRING_LENGTH (MD5_DIGEST_LENGTH * 2 + 1)
|
||||
|
||||
+typedef uint32_t u_int32_t;
|
||||
+typedef uint64_t u_int64_t;
|
||||
+typedef uint8_t u_int8_t;
|
||||
+
|
||||
typedef struct MD5Context {
|
||||
u_int32_t state[4]; /* state */
|
||||
u_int64_t count; /* number of bits, mod 2^64 */
|
|
@ -125,3 +125,4 @@ man/man5/recoll.conf.5.gz
|
|||
%%DATADIR%%/translations/recoll_xx.qm
|
||||
%%DATADIR%%/translations/recoll_zh.qm
|
||||
%%DATADIR%%/translations/recoll_zh_CN.qm
|
||||
%%NO_QT4%%@dir share/icons/hicolor/48x48/apps
|
||||
|
|
Loading…
Reference in a new issue