Add www/cowboy, a complete Erlang HTTP stack in a small code base.

This commit is contained in:
Jimmy Olgeni 2013-05-23 20:53:11 +00:00
parent 8c86052e02
commit f316cdac28
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=318909
7 changed files with 342 additions and 0 deletions

View file

@ -113,6 +113,7 @@
SUBDIR += codeigniter17
SUBDIR += comclear
SUBDIR += coppermine
SUBDIR += cowboy
SUBDIR += cplanet
SUBDIR += crawl
SUBDIR += crp

43
www/cowboy/Makefile Normal file
View file

@ -0,0 +1,43 @@
# $FreeBSD$
PORTNAME= cowboy
PORTVERSION= 0.8.4
CATEGORIES= www
MASTER_SITES= GH
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Small, fast and modular HTTP server written in Erlang
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
ranch>=0:${PORTSDIR}/net/ranch
PLIST_SUB= VERSION="${PORTVERSION}"
USE_GMAKE= yes
USE_GITHUB= yes
GH_ACCOUNT= extend
GH_PROJECT= cowboy
GH_COMMIT= 46b2ea0
GH_TAGNAME= ${PORTVERSION}
PORTDOCS= *
.include <bsd.port.options.mk>
do-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/guide/* ${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
.endif
@${MKDIR} ${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}
@${MKDIR} ${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}/ebin
@${MKDIR} ${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}/src
${INSTALL_DATA} ${WRKSRC}/ebin/* ${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}/ebin
${INSTALL_DATA} ${WRKSRC}/src/* ${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}/src
.include <bsd.port.mk>

2
www/cowboy/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (cowboy-0.8.4.tar.gz) = 536c81783b1cf73cf62b1ea594f1f7c2a3041055e475b312275750673449c8f7
SIZE (cowboy-0.8.4.tar.gz) = 3908260

View file

@ -0,0 +1,15 @@
$FreeBSD$
--- Makefile.orig
+++ Makefile
@@ -55,8 +55,7 @@
git clone -n -- https://github.com/extend/ranch.git $(DEPS_DIR)/ranch
cd $(DEPS_DIR)/ranch ; git checkout -q $(RANCH_VSN)
-deps: $(DEPS_DIR)/ranch
- @$(MAKE) -C $(DEPS_DIR)/ranch
+deps:
clean-deps:
-@$(MAKE) -C $(DEPS_DIR)/ranch clean

View file

@ -0,0 +1,10 @@
$FreeBSD$
--- rebar.config.orig
+++ rebar.config
@@ -1,3 +1,3 @@
{deps, [
- {ranch, ".*", {git, "git://github.com/extend/ranch.git", "0.8.1"}}
+ {ranch, ".*"}
]}.

11
www/cowboy/pkg-descr Normal file
View file

@ -0,0 +1,11 @@
Cowboy aims to provide a complete HTTP stack in a small code base. It
is optimized for low latency and low memory usage, in parts because it
uses binary strings.
Cowboy provides routing capabilities, selectively dispatching requests
to handlers written in Erlang.
Because it uses Ranch for managing connections, Cowboy can easily be
embedded in any other application.
WWW: https://github.com/extend/cowboy

260
www/cowboy/pkg-plist Normal file
View file

@ -0,0 +1,260 @@
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy.app
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_app.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_bstr.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_client.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_clock.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_handler.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_http.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_http_handler.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_loop_handler.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_middleware.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_multipart.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_protocol.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_req.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_rest.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_router.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_static.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_sub_protocol.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_sup.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_websocket.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_websocket_handler.beam
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy.app.src
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_app.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_bstr.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_client.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_clock.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_handler.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_http.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_http_handler.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_loop_handler.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_middleware.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_multipart.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_protocol.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_req.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_rest.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_router.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_static.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_sup.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_sub_protocol.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_websocket.erl
%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_websocket_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/basic_auth.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/basic_auth.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/basic_auth_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/basic_auth_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/templates/toppage.dtl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/curl_post.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/lib/elixir_hello_world.ex
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/lib/elixir_hello_world/supervisor.ex
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/lib/elixir_hello_world/top_page_handler.ex
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/mix.exs
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/test/elixir_hello_world_test.exs
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/test/test_helper.exs
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook_responder.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/priv/index.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/priv/small.mp4
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/priv/small.ogv
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/priv/video.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_converter.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/priv/index.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/priv/index.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/priv/ssl/cowboy-ca.crt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/priv/ssl/server.crt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/priv/ssl/server.key
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/small.mp4
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/small.ogv
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/test.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/video.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/small.mp4
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/small.ogv
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/test.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/video.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/directory_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/directory_lister.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/priv/html_ws_client.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/priv/static/jquery.min.js
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/rebar.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/toppage_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket.app.src
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/ws_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/start.sh
@dirrm %%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src
@dirrm %%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin
@dirrm %%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/websocket/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/websocket/priv/static
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/websocket/priv
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/websocket
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/web_server/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/web_server/priv
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/web_server
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/static_world/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/static_world/priv
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/static_world
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ssl_hello_world/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ssl_hello_world/priv/ssl
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ssl_hello_world/priv
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ssl_hello_world
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_stream_response/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_stream_response
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_pastebin/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_pastebin/priv
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_pastebin
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_hello_world/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_hello_world
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/markdown_middleware/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/markdown_middleware/priv
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/markdown_middleware
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/hello_world/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/hello_world
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/eventsource/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/eventsource/priv
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/eventsource
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/error_hook/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/error_hook
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/elixir_hello_world/test
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/elixir_hello_world/lib/elixir_hello_world
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/elixir_hello_world/lib
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/elixir_hello_world
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo_post/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo_post
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo_get/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo_get
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/cookie/templates
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/cookie/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/cookie
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/compress_response/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/compress_response
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/chunked_hello_world/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/chunked_hello_world
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/basic_auth/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/basic_auth
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%