- Remove bad MASTER_SITES
- Pass maintainership to submitter PR: ports/106218 Submitted by: chinsan
This commit is contained in:
parent
06ee8d0762
commit
f38d3f1112
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=178656
4 changed files with 9 additions and 22 deletions
|
@ -9,10 +9,10 @@ PORTNAME= bg5pdf
|
|||
PORTVERSION= 1.0.0
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= chinese print
|
||||
MASTER_SITES= http://cschin.yydolphin.net/bg5pdf/ \
|
||||
ftp://freebsd.sinica.edu.tw/pub/statue/bg5pdf/
|
||||
MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/statue/bg5pdf/ \
|
||||
LOCAL/chinsan
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= chinsan@FreeBSD.org
|
||||
COMMENT= Convert Chinese-Big5 encoded files to PDF, using PDFlib
|
||||
|
||||
LIB_DEPENDS= pdf.8:${PORTSDIR}/print/pdflib
|
||||
|
@ -22,8 +22,11 @@ USE_PYTHON= yes
|
|||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's,%%PYTHON_INCLUDEDIR%%,${PYTHON_INCLUDEDIR},g' \
|
||||
${WRKSRC}/Makefile
|
||||
${REINPLACE_CMD} -e 's,/usr/bin/python,python,g' ${WRKSRC}/bg5pdf
|
||||
|
||||
do-build:
|
||||
${CC} ${CFLAGS} -shared ${WRKSRC}/bg5pdflib.c -I${PREFIX}/include \
|
||||
-I${PYTHON_INCLUDEDIR} -L${PREFIX}/lib -lpdf -o ${WRKSRC}/bg5pdflib.so
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
|
|
|
@ -1,8 +0,0 @@
|
|||
--- bg5pdf.orig Mon Dec 3 06:53:10 2001
|
||||
+++ bg5pdf Mon Dec 3 06:53:19 2001
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env /usr/bin/python
|
||||
+#!/usr/bin/env python
|
||||
|
||||
"""
|
||||
Bg5pdf is a simple wrapper for wrapping big5 encoding text file into
|
|
@ -1,6 +0,0 @@
|
|||
--- Makefile.orig Sat Mar 30 23:01:25 2002
|
||||
+++ Makefile Sat Mar 30 23:01:40 2002
|
||||
@@ -0,0 +1,3 @@
|
||||
+all:
|
||||
+ ${CC} ${CFLAGS} -shared bg5pdflib.c -I/usr/local/include -I%%PYTHON_INCLUDEDIR%% -L/usr/local/lib -lpdf -o bg5pdflib.so
|
||||
+
|
|
@ -1,9 +1,7 @@
|
|||
Bg5pdf is a simple wrapper for wrapping big5 encoding text file into
|
||||
bg5pdf is a simple wrapper for wrapping Big5 encoding text file into
|
||||
PDF file by using PDFlib. The output of this program does not contain
|
||||
embedding fonts. You have to download Acrobat Acroread Asianfont pack
|
||||
to view and print the output file. This wrapper does not provide any
|
||||
formatting function except simple line wrapping. If you need
|
||||
sophisticated formatting, you should try CJK-LaTex or other equivalent
|
||||
tools.
|
||||
|
||||
WWW: http://cschin.yydolphin.net/bg5pdf/
|
||||
|
|
Loading…
Reference in a new issue