Upgrade to 0.8.1.
Changelog at <https://github.com/JFreegman/toxic/releases/tag/v0.8.1>.
This commit is contained in:
parent
bb620445e2
commit
f3db21204e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=454418
4 changed files with 21 additions and 15 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= toxic
|
||||
PORTVERSION= 0.8.0
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.8.1
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= net-im
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1496951410
|
||||
SHA256 (JFreegman-toxic-v0.8.0_GH0.tar.gz) = 4078167ff09a94a78cd46d55163524b0a6692b56a74458c99093b84316a6c604
|
||||
SIZE (JFreegman-toxic-v0.8.0_GH0.tar.gz) = 1145799
|
||||
TIMESTAMP = 1510996634
|
||||
SHA256 (JFreegman-toxic-v0.8.1_GH0.tar.gz) = 4bea591a08b3628e06940f0f7b9be320391013564cc8c9e88642af2f2debafd2
|
||||
SIZE (JFreegman-toxic-v0.8.1_GH0.tar.gz) = 1146245
|
||||
|
|
|
@ -1,20 +1,16 @@
|
|||
--- cfg/global_vars.mk.orig 2017-05-24 18:57:32 UTC
|
||||
--- cfg/global_vars.mk.orig 2017-11-17 22:44:56 UTC
|
||||
+++ cfg/global_vars.mk
|
||||
@@ -1,11 +1,11 @@
|
||||
@@ -1,11 +1,7 @@
|
||||
# Version
|
||||
-TOXIC_VERSION = 0.7.2
|
||||
TOXIC_VERSION = 0.8.1
|
||||
-REV = $(shell git rev-list HEAD --count 2>/dev/null || echo -n "error")
|
||||
-ifneq (, $(findstring error, $(REV)))
|
||||
+TOXIC_VERSION = 0.8.0
|
||||
+#REV = $(shell git rev-list HEAD --count 2>/dev/null || echo -n "error")
|
||||
+#ifneq (, $(findstring error, $(REV)))
|
||||
VERSION = $(TOXIC_VERSION)
|
||||
- VERSION = $(TOXIC_VERSION)
|
||||
-else
|
||||
- VERSION = $(TOXIC_VERSION)_r$(REV)
|
||||
-endif
|
||||
+#else
|
||||
+# VERSION = $(TOXIC_VERSION)_r$(REV)
|
||||
+#endif
|
||||
+#REV = $(shell git rev-list HEAD --count 2>/dev/null || echo -n "error")
|
||||
+VERSION = $(TOXIC_VERSION)
|
||||
|
||||
# Project directories
|
||||
BUILD_DIR = $(BASE_DIR)/build
|
||||
|
|
11
net-im/toxic/files/patch-src_video__device.c
Normal file
11
net-im/toxic/files/patch-src_video__device.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/video_device.c.orig 2017-11-17 22:44:56 UTC
|
||||
+++ src/video_device.c
|
||||
@@ -37,7 +37,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/mman.h>
|
||||
#include <fcntl.h>
|
||||
-#if defined(__linux__)
|
||||
+#if defined(__linux__) || defined(__FreeBSD__)
|
||||
#include <linux/videodev2.h>
|
||||
#else
|
||||
#include <sys/videoio.h>
|
Loading…
Reference in a new issue