Qpopper's configure script tries to detect sendmail in a number of common
paths, but the first guess will always fail, because sbindir contains an embedded shell variable. As a result, systems without base sendmail (more specifically, without /usr/sbin/sendmail) will fail configure step. Additional info: http://lists.freebsd.org/pipermail/freebsd-ports/2012-March/073828.html PR: ports/166108 Submitted by: Mel Flynn <rflynn@acsalaska.net> Approved by: maintainer timeout (14+ days)
This commit is contained in:
parent
66ce140747
commit
f411d52623
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=295003
2 changed files with 27 additions and 4 deletions
|
@ -133,6 +133,9 @@ CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
|
|||
post-patch:
|
||||
@${RM} -f ${WRKSRC}/popper/md5.h
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/man/*
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|\$${sbindir}/sendmail|${LOCALBASE}/sbin/sendmail|g' \
|
||||
${WRKSRC}/configure.in
|
||||
.if defined(WITH_POPPASSD)
|
||||
@${REINPLACE_CMD} -e 's|/usr/bin/smbpasswd|${LOCALBASE}/bin/smbpasswd|' \
|
||||
${WRKSRC}/password/poppassd.c
|
||||
|
|
|
@ -1,10 +1,30 @@
|
|||
--- configure.in.orig Sat May 5 14:32:51 2001
|
||||
+++ configure.in Sat May 5 14:33:32 2001
|
||||
@@ -1257,7 +1257,6 @@
|
||||
--- configure.in.orig 2011-05-30 11:13:39.000000000 -0800
|
||||
+++ configure.in 2012-03-14 10:38:44.000000000 -0800
|
||||
@@ -1409,14 +1409,14 @@
|
||||
dnl
|
||||
|
||||
AC_MSG_CHECKING([for sendmail program])
|
||||
-if test -f ${sbindir}/sendmail
|
||||
-then
|
||||
- AC_DEFINE(MAIL_COMMAND, "${sbindir}/sendmail")
|
||||
- AC_MSG_RESULT([found at ${sbindir}/sendmail])
|
||||
-elif test -f /usr/sbin/sendmail
|
||||
+if test -f /usr/sbin/sendmail
|
||||
then
|
||||
AC_DEFINE(MAIL_COMMAND, "/usr/sbin/sendmail")
|
||||
AC_MSG_RESULT([found at /usr/sbin/sendmail])
|
||||
+elif test -f ${sbindir}/sendmail
|
||||
+then
|
||||
+ AC_DEFINE(MAIL_COMMAND, "${sbindir}/sendmail")
|
||||
+ AC_MSG_RESULT([found at ${sbindir}/sendmail])
|
||||
elif test -f /usr/lib/sendmail
|
||||
then
|
||||
AC_DEFINE(MAIL_COMMAND, "/usr/lib/sendmail")
|
||||
@@ -1508,7 +1508,6 @@
|
||||
)
|
||||
|
||||
AC_CHECK_HEADER( ndbm.h, NDBM_H="yes"; AC_DEFINE(HAVE_NDBM_H), NDBM_H="no" )
|
||||
-AC_CHECK_HEADER( gdbm.h, GDBM_H="yes"; AC_DEFINE(HAVE_GDBM_H), GDBM_H="no" )
|
||||
AC_CHECK_HEADER( dbm.h, DBM_H="yes"; AC_DEFINE(HAVE_DBM_H), DBM_H="no" )
|
||||
|
||||
|
||||
AC_CHECK_TYPES( socklen_t, , , [#include <sys/socket.h>] )
|
Loading…
Reference in a new issue