Update to 0.2.9
PR: 82945 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
5bce097063
commit
f479bd44c4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138462
4 changed files with 10 additions and 27 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= 3ddesktop
|
||||
PORTVERSION= 0.2.8
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.2.9
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= desk3d
|
||||
|
@ -18,7 +17,6 @@ COMMENT= 3D Virtual Desktop Switcher
|
|||
LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut \
|
||||
Imlib2.3:${PORTSDIR}/graphics/imlib2
|
||||
|
||||
USE_AUTOCONF_VER= 259
|
||||
USE_GL= yes
|
||||
USE_GETOPT_LONG= yes
|
||||
USE_REINPLACE= yes
|
||||
|
@ -26,6 +24,7 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
||||
MAN1= 3ddesk.1 3ddeskd.1
|
||||
PORTDOCS= README README.windowmanagers
|
||||
PLIST_FILES= bin/3ddesk bin/3ddeskd etc/3ddesktop.conf \
|
||||
%%DATADIR%%/digits.bmp
|
||||
|
@ -35,7 +34,12 @@ CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT ${PTHREAD_CFLAGS}
|
|||
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/Makefile.in
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|-O3||g ; \
|
||||
s|@ACLOCAL@|${TRUE}|g ; \
|
||||
s|@AUTOCONF@|${TRUE}|g ; \
|
||||
s|@AUTOHEADER@|${TRUE}|g ; \
|
||||
s|@AUTOMAKE@|${TRUE}|g'
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (3ddesktop-0.2.8.tar.gz) = 2691741a984c441e0a84aa6b4fac8513
|
||||
SIZE (3ddesktop-0.2.8.tar.gz) = 175233
|
||||
MD5 (3ddesktop-0.2.9.tar.gz) = da1e8b0d2c210a441676bbf663e694ee
|
||||
SIZE (3ddesktop-0.2.9.tar.gz) = 182278
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- 3ddesk.cpp.orig Mon May 10 01:44:54 2004
|
||||
+++ 3ddesk.cpp Thu Aug 26 22:59:52 2004
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <errno.h>
|
||||
#include <sys/types.h>
|
||||
+#include <sys/time.h>
|
||||
#include <sys/ipc.h>
|
||||
#include <sys/msg.h>
|
||||
#include <string.h>
|
|
@ -1,11 +0,0 @@
|
|||
--- util.h.orig Mon May 10 00:57:26 2004
|
||||
+++ util.h Thu Aug 26 23:00:45 2004
|
||||
@@ -21,7 +21,7 @@
|
||||
#ifndef _UTIL_H
|
||||
#define _UTIL_H
|
||||
#include <math.h> // for cos
|
||||
-#include <endian.h>
|
||||
+#include <sys/endian.h>
|
||||
#include "3ddesk.h"
|
||||
|
||||
#define MAX_FACES 30 // this is a lot
|
Loading…
Reference in a new issue