Second try to fix compatibility with new boost
PR: 224094 Reported by: jbeich@FreeBSD.org
This commit is contained in:
parent
9c66986f13
commit
f4814bf4de
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=455587
13 changed files with 324 additions and 46 deletions
|
@ -2,7 +2,7 @@
|
|||
|
||||
PORTNAME= msp430-debug-stack
|
||||
PORTVERSION= 3.10.001.000
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.ti.com/lit/sw/slac460v/ \
|
||||
http://www.ti.com/lit/ug/slau320z/:doc1 \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- DLL430_v3/src/TI/DLL430/FetControl.cpp.orig 2016-03-12 13:23:34 UTC
|
||||
+++ DLL430_v3/src/TI/DLL430/FetControl.cpp
|
||||
@@ -214,7 +214,7 @@ bool FetControl::resetCommunication()
|
||||
--- DLL430_v3/src/TI/DLL430/FetControl.cpp.orig 2017-12-05 18:47:14.471975000 +0300
|
||||
+++ DLL430_v3/src/TI/DLL430/FetControl.cpp 2017-12-05 18:47:14.610359000 +0300
|
||||
@@ -222,7 +222,7 @@ bool FetControl::resetCommunication()
|
||||
data.push_back(0x00);
|
||||
this->sendData(data); // reset connection
|
||||
|
||||
|
|
|
@ -1,33 +1,20 @@
|
|||
--- DLL430_v3/src/TI/DLL430/UsbCdcIoChannel.cpp.orig 2016-05-02 09:51:53.763023000 +0200
|
||||
+++ DLL430_v3/src/TI/DLL430/UsbCdcIoChannel.cpp 2016-05-02 09:53:56.332580000 +0200
|
||||
@@ -303,6 +303,22 @@
|
||||
--- DLL430_v3/src/TI/DLL430/UsbCdcIoChannel.cpp.orig 2017-12-05 18:49:13.159254000 +0300
|
||||
+++ DLL430_v3/src/TI/DLL430/UsbCdcIoChannel.cpp 2017-12-05 18:49:23.590490000 +0300
|
||||
@@ -401,7 +401,7 @@ bool UsbCdcIoChannel::openPort()
|
||||
int retry = 5;
|
||||
while (ec && --retry )
|
||||
{
|
||||
- this_thread::sleep_for(chrono::milliseconds(5));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(5));
|
||||
ec = port->open(portInfo.path, ec);
|
||||
}
|
||||
|
||||
@@ -426,7 +426,7 @@ void UsbCdcIoChannel::retrieveStatus()
|
||||
{
|
||||
openPort();
|
||||
//Seeing issues on some platforms (eg. Ubuntu) when port is immediately closed again
|
||||
- this_thread::sleep_for(chrono::milliseconds(100));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(100));
|
||||
close();
|
||||
}
|
||||
#else
|
||||
stringstream cdcIdStream;
|
||||
+
|
||||
+#ifdef __FreeBSD__
|
||||
+
|
||||
+ path p( "/dev" );
|
||||
+ if( exists(p) && is_directory(p) ) {
|
||||
+
|
||||
+ cdcIdStream << hex << setfill('0') << "mspfet" << setw(4) << productId;
|
||||
+
|
||||
+ const directory_iterator end;
|
||||
+ for( directory_iterator it(p); it != end; ++it ) {
|
||||
+
|
||||
+ string dir = it->path().string();
|
||||
+ if( dir.find( cdcIdStream.str() ) != string::npos ) {
|
||||
+ {
|
||||
+
|
||||
+#else
|
||||
cdcIdStream << hex << setfill('0') << "usb:v" << setw(4) << vendorId << "p" << setw(4) << productId;
|
||||
|
||||
path p("/sys/class/tty/");
|
||||
@@ -324,6 +340,7 @@
|
||||
ifNumStream >> interfaceNumber;
|
||||
if (modalias.find(cdcIdStream.str()) == 0 && interfaceNumber == 0)
|
||||
{
|
||||
+#endif
|
||||
const string filename = it->path().filename().string();
|
||||
const string portPath = string("/dev/") + filename;
|
||||
|
||||
}
|
||||
|
|
|
@ -0,0 +1,56 @@
|
|||
--- DLL430_v3/src/DLL430_OldApiV3.cpp.orig 2017-12-05 18:38:46.037302000 +0300
|
||||
+++ DLL430_v3/src/DLL430_OldApiV3.cpp 2017-12-05 18:40:21.357777000 +0300
|
||||
@@ -191,7 +191,7 @@ void DLL430_OldApiV3::event(DebugEventTa
|
||||
//With trace/variable watch enabled, give storage events on same trigger time to be reported
|
||||
if (trace_storage.trControl == TR_ENABLE)
|
||||
{
|
||||
- this_thread::sleep_for(chrono::milliseconds(100));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(100));
|
||||
}
|
||||
db_man->pausePolling();
|
||||
}
|
||||
@@ -1524,7 +1524,7 @@ bool DLL430_OldApiV3::Erase(int32_t type
|
||||
log(LogTarget::ERR, ERASE_ERR, "");
|
||||
return false;
|
||||
}
|
||||
- this_thread::sleep_for(chrono::seconds(1));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(1));
|
||||
return true;
|
||||
|
||||
}
|
||||
@@ -1538,7 +1538,7 @@ bool DLL430_OldApiV3::Erase(int32_t type
|
||||
}
|
||||
if (singleDevice)
|
||||
{
|
||||
- this_thread::sleep_for(chrono::seconds(1));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(1));
|
||||
return true;
|
||||
}
|
||||
}
|
||||
@@ -1923,7 +1923,7 @@ bool DLL430_OldApiV3::Reset(int32_t meth
|
||||
if (devArchitecture != MSP432_M4)
|
||||
{
|
||||
db_man->resumePolling();
|
||||
- this_thread::sleep_for(chrono::milliseconds(500));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(500));
|
||||
db_man->pausePolling();
|
||||
}
|
||||
if (!State(&state, true, &pCPUCycles))
|
||||
@@ -3781,7 +3781,7 @@ bool DLL430_OldApiV3::FET_FwUpdate(
|
||||
|
||||
if (!handle)
|
||||
{
|
||||
- this_thread::sleep_for(chrono::seconds(3));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(3));
|
||||
this->Initialize(&port[0], &version);
|
||||
}
|
||||
|
||||
@@ -4179,7 +4179,7 @@ bool DLL430_OldApiV3::writeToExternalMem
|
||||
|
||||
Run(FREE_RUN, true); // start execution of loader code
|
||||
|
||||
- this_thread::sleep_for(chrono::seconds(15));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(15));
|
||||
|
||||
int32_t state;
|
||||
int32_t pCPUCycles;
|
|
@ -0,0 +1,91 @@
|
|||
--- DLL430_v3/src/TI/DLL430/ConfigManager.cpp.orig 2017-12-05 18:47:14.461686000 +0300
|
||||
+++ DLL430_v3/src/TI/DLL430/ConfigManager.cpp 2017-12-05 18:47:14.601264000 +0300
|
||||
@@ -135,7 +135,7 @@ void ConfigManager::init ()
|
||||
iniFile = string(iniPathEnv) + "/" + iniFile;
|
||||
}
|
||||
|
||||
- ifstream DllV3Ini(iniFile.c_str());
|
||||
+ std::ifstream DllV3Ini(iniFile.c_str());
|
||||
|
||||
while (DllV3Ini && !DllV3Ini.eof())
|
||||
{
|
||||
@@ -259,9 +259,9 @@ bool ConfigManager::jtagErase(uint16_t e
|
||||
return false;
|
||||
}
|
||||
#if defined(_WIN32) || defined(_WIN64) || defined(__APPLE__)
|
||||
- this_thread::sleep_for(chrono::milliseconds(100));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(100));
|
||||
#else
|
||||
- this_thread::sleep_for(chrono::milliseconds(500));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(500));
|
||||
#endif
|
||||
return true;
|
||||
}
|
||||
@@ -561,7 +561,7 @@ bool ConfigManager::reset(bool vcc, bool
|
||||
return false;
|
||||
}
|
||||
// keep voltage 0 for minmum 5 seconds
|
||||
- this_thread::sleep_for(chrono::seconds(5));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(5));
|
||||
|
||||
if (!this->setDeviceVcc(voltage))
|
||||
{
|
||||
@@ -622,7 +622,7 @@ bool ConfigManager::reset(bool vcc, bool
|
||||
return false;
|
||||
}
|
||||
// keep voltate 0 for minmum 5 seconds
|
||||
- this_thread::sleep_for(chrono::seconds(5));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(5));
|
||||
if (!this->setDeviceVcc(voltage))
|
||||
{
|
||||
return false;
|
||||
@@ -718,10 +718,10 @@ bool ConfigManager::setVccEzFet(uint16_t
|
||||
#if defined(_WIN32) || defined(_WIN64) || defined(__APPLE__)
|
||||
if (vcc)
|
||||
{
|
||||
- this_thread::sleep_for(chrono::milliseconds(500));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(500));
|
||||
}
|
||||
#else
|
||||
- this_thread::sleep_for(chrono::milliseconds(1000));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(1000));
|
||||
#endif
|
||||
|
||||
}
|
||||
@@ -789,9 +789,9 @@ bool ConfigManager::setVccMspFET(uint16_
|
||||
}
|
||||
|
||||
#if defined(_WIN32) || defined(_WIN64) || defined(__APPLE__)
|
||||
- this_thread::sleep_for(chrono::milliseconds(100));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(100));
|
||||
#else
|
||||
- this_thread::sleep_for(chrono::milliseconds(700));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(700));
|
||||
#endif
|
||||
|
||||
// now run calibration to support Energy Trace
|
||||
@@ -822,9 +822,9 @@ bool ConfigManager::setVccMspFET(uint16_
|
||||
return false;
|
||||
}
|
||||
#if defined(_WIN32) || defined(_WIN64) || defined(__APPLE__)
|
||||
- this_thread::sleep_for(chrono::milliseconds(100));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(100));
|
||||
#else
|
||||
- this_thread::sleep_for(chrono::milliseconds(700));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(700));
|
||||
#endif
|
||||
|
||||
// Send power down command to Sub mcu Firmware
|
||||
@@ -858,10 +858,10 @@ bool ConfigManager::setVccMspFetUif(uint
|
||||
#if defined(_WIN32) || defined(_WIN64) || defined(__APPLE__)
|
||||
if (vcc)
|
||||
{
|
||||
- this_thread::sleep_for(chrono::milliseconds(1000));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(1000));
|
||||
}
|
||||
#else
|
||||
- this_thread::sleep_for(chrono::milliseconds(2500));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(2500));
|
||||
#endif
|
||||
return true;
|
||||
}
|
|
@ -0,0 +1,47 @@
|
|||
--- DLL430_v3/src/TI/DLL430/UpdateManagerFet.cpp.orig 2017-12-05 18:47:14.471473000 +0300
|
||||
+++ DLL430_v3/src/TI/DLL430/UpdateManagerFet.cpp 2017-12-05 18:47:14.610002000 +0300
|
||||
@@ -128,7 +128,7 @@ bool UpdateManagerFet::updateCore(Memory
|
||||
intCallback(BL_DATA_BLOCK_PROGRAMMED, (uint32_t)( 100-(requiredCoreUpdates)*requiredCoreUpdates), 0);
|
||||
}
|
||||
|
||||
- this_thread::sleep_for(chrono::seconds(4));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(4));
|
||||
|
||||
fetHandle->shutdown();
|
||||
|
||||
@@ -141,7 +141,7 @@ bool UpdateManagerFet::updateCore(Memory
|
||||
uint32_t countedHidDevices = 0, timeout = 50;
|
||||
do
|
||||
{
|
||||
- this_thread::sleep_for(chrono::seconds(1));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(1));
|
||||
countedHidDevices = HidUpdateManager::countHidDevices(currentPid);
|
||||
|
||||
if (intCallback)
|
||||
@@ -635,7 +635,7 @@ bool UpdateManagerFet::updateFpga()
|
||||
// Start the FPGA update
|
||||
this->upInit(3);
|
||||
|
||||
- this_thread::sleep_for(chrono::seconds(1));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(1));
|
||||
|
||||
// Restore the normal HAL module
|
||||
if (returnValue && !updateHal())
|
||||
@@ -956,7 +956,7 @@ bool UpdateManagerFet::firmWareUpdate(co
|
||||
|
||||
UpdateLog.append("\n---------------------Firmware upate end--------------------------\n");
|
||||
|
||||
- ofstream(logfile.c_str(), ios::app | ios::out) << UpdateLog;
|
||||
+ std::ofstream(logfile.c_str(), ios::app | ios::out) << UpdateLog;
|
||||
#endif
|
||||
}
|
||||
return returnValue;
|
||||
@@ -1063,7 +1063,7 @@ bool UpdateManagerFet::updateFirmware(co
|
||||
this->upInit(0);
|
||||
|
||||
// give the firmware time to execute initialisation
|
||||
- this_thread::sleep_for(chrono::seconds(1));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(1));
|
||||
return true;
|
||||
}
|
||||
|
|
@ -0,0 +1,29 @@
|
|||
--- DLL430_v3/src/TI/DLL430/UpdateManagerMSP_FET430.cpp.orig 2017-12-05 18:38:46.041601000 +0300
|
||||
+++ DLL430_v3/src/TI/DLL430/UpdateManagerMSP_FET430.cpp 2017-12-05 18:41:45.548342000 +0300
|
||||
@@ -212,7 +212,7 @@ bool UpdateManagerMSP_FET430::firmWareUp
|
||||
control->sendData(data_55);
|
||||
control->clearResponse();
|
||||
|
||||
- this_thread::sleep_for(chrono::seconds(8));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(8));
|
||||
}
|
||||
|
||||
MemoryContent firmware;
|
||||
@@ -282,7 +282,7 @@ bool UpdateManagerMSP_FET430::firmWareUp
|
||||
const bool initFailed = !this->fetHandle->send(initCmd);
|
||||
|
||||
// give the firmware time to execute initialisation
|
||||
- this_thread::sleep_for(chrono::seconds(1));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(1));
|
||||
|
||||
//Only an error if no user specified file is used (ie. init will fail for a downgrade)
|
||||
if (initFailed && !fname)
|
||||
@@ -300,7 +300,7 @@ bool UpdateManagerMSP_FET430::firmWareUp
|
||||
cmd.elements.emplace_back(el);
|
||||
|
||||
fetHandle->send(cmd);
|
||||
- this_thread::sleep_for(chrono::seconds(2));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(2));
|
||||
|
||||
if (callback)
|
||||
callback(BL_UPDATE_DONE, 0, 0);
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.orig 2016-04-11 14:08:50.000000000 +0200
|
||||
+++ Makefile 2016-05-02 09:51:27.848060000 +0200
|
||||
@@ -16,6 +16,7 @@
|
||||
--- Makefile.orig 2017-06-22 12:44:14.000000000 +0300
|
||||
+++ Makefile 2017-12-05 18:35:24.639422000 +0300
|
||||
@@ -16,6 +16,7 @@ MAKE_PCH += -x c++-header
|
||||
USE_PCH += -include $(PCH_HEADER)
|
||||
|
||||
export BOOST_DIR
|
||||
|
@ -8,7 +8,7 @@
|
|||
export BIT32
|
||||
export STATIC
|
||||
export DEBUG
|
||||
@@ -76,15 +77,15 @@
|
||||
@@ -76,15 +77,15 @@ ifeq ($(PLATFORM),Linux)
|
||||
|
||||
HIDOBJ := $(LIBTHIRD)/hid-libusb.o
|
||||
else
|
||||
|
@ -29,7 +29,7 @@
|
|||
endif
|
||||
|
||||
ifdef BOOST_DIR
|
||||
@@ -92,9 +93,14 @@
|
||||
@@ -92,9 +93,14 @@ else
|
||||
LIBDIRS += -L$(BOOST_DIR)/lib
|
||||
endif
|
||||
|
||||
|
|
|
@ -0,0 +1,20 @@
|
|||
--- ThirdParty/BSL430_DLL/BSL430_DLL/Connections/MSPBSL_Connection5xxUSB.cpp.orig 2017-12-05 18:38:46.035629000 +0300
|
||||
+++ ThirdParty/BSL430_DLL/BSL430_DLL/Connections/MSPBSL_Connection5xxUSB.cpp 2017-12-05 18:39:43.517163000 +0300
|
||||
@@ -70,7 +70,7 @@ void MSPBSL_Connection5xxUSB:: closeBslc
|
||||
{
|
||||
uint8_t usbDisconnct = USB_DISCONNECT_COMMAND;
|
||||
this->thePacketHandler->TX_Packet(&usbDisconnct,1);
|
||||
- this_thread::sleep_for(chrono::seconds(5));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(5));
|
||||
}
|
||||
|
||||
/***************************************************************************//**
|
||||
@@ -134,7 +134,7 @@ uint16_t MSPBSL_Connection5xxUSB::loadRA
|
||||
{
|
||||
return retValue;
|
||||
}
|
||||
- this_thread::sleep_for(chrono::seconds(1));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(1));
|
||||
|
||||
return ACK;
|
||||
}
|
|
@ -0,0 +1,11 @@
|
|||
--- ThirdParty/BSL430_DLL/BSL430_DLL/MSPBSL_Factory.cpp.orig 2017-12-05 18:38:46.036313000 +0300
|
||||
+++ ThirdParty/BSL430_DLL/BSL430_DLL/MSPBSL_Factory.cpp 2017-12-05 18:39:50.453006000 +0300
|
||||
@@ -212,7 +212,7 @@ MSPBSL_Connection* MSPBSL_Factory::getMS
|
||||
bool isOpen = s->physicalInterfaceCommand(ENUMERATE_COMMAND) == 0;
|
||||
while (s && !isOpen && retries-- > 0)
|
||||
{
|
||||
- this_thread::sleep_for(chrono::seconds(2));
|
||||
+ this_thread::sleep_for(std::chrono::seconds(2));
|
||||
isOpen = s->physicalInterfaceCommand(ENUMERATE_COMMAND) == 0;
|
||||
}
|
||||
if (!isOpen)
|
|
@ -0,0 +1,37 @@
|
|||
--- ThirdParty/BSL430_DLL/BSL430_DLL/Physical_Interfaces/MSPBSL_PhysicalInterfaceSerialUART.cpp.orig 2017-12-05 18:38:46.034235000 +0300
|
||||
+++ ThirdParty/BSL430_DLL/BSL430_DLL/Physical_Interfaces/MSPBSL_PhysicalInterfaceSerialUART.cpp 2017-12-05 18:39:30.622349000 +0300
|
||||
@@ -193,27 +193,27 @@ void MSPBSL_PhysicalInterfaceSerialUART:
|
||||
|
||||
port->set_option(RESETControl(LOW_SIGNAL));
|
||||
port->set_option(TESTControl(LOW_SIGNAL));
|
||||
- this_thread::sleep_for(chrono::milliseconds(10));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(10));
|
||||
port->set_option(TESTControl(HIGH_SIGNAL));
|
||||
- this_thread::sleep_for(chrono::milliseconds(10));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(10));
|
||||
port->set_option(TESTControl(LOW_SIGNAL));
|
||||
- this_thread::sleep_for(chrono::milliseconds(10));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(10));
|
||||
port->set_option(TESTControl(HIGH_SIGNAL));
|
||||
- this_thread::sleep_for(chrono::milliseconds(10));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(10));
|
||||
if( method == STANDARD_INVOKE )
|
||||
{
|
||||
port->set_option(RESETControl(HIGH_SIGNAL));
|
||||
- this_thread::sleep_for(chrono::milliseconds(10));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(10));
|
||||
port->set_option(TESTControl(LOW_SIGNAL));
|
||||
}
|
||||
else if ( method == BSL_XXXX_INVOKE )
|
||||
{
|
||||
port->set_option(TESTControl(LOW_SIGNAL));
|
||||
- this_thread::sleep_for(chrono::milliseconds(10));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(10));
|
||||
port->set_option(RESETControl(HIGH_SIGNAL));
|
||||
}
|
||||
|
||||
- this_thread::sleep_for(chrono::milliseconds(250));
|
||||
+ this_thread::sleep_for(std::chrono::milliseconds(250));
|
||||
|
||||
}
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- ThirdParty/BSL430_DLL/BSL430_DLL/Physical_Interfaces/MSPBSL_PhysicalInterfaceUSB.cpp.orig 2017-12-05 15:03:57.734396000 +0300
|
||||
+++ ThirdParty/BSL430_DLL/BSL430_DLL/Physical_Interfaces/MSPBSL_PhysicalInterfaceUSB.cpp 2017-12-05 15:04:17.062811000 +0300
|
||||
@@ -189,7 +189,7 @@
|
||||
--- ThirdParty/BSL430_DLL/BSL430_DLL/Physical_Interfaces/MSPBSL_PhysicalInterfaceUSB.cpp.orig 2017-12-05 18:47:14.538669000 +0300
|
||||
+++ ThirdParty/BSL430_DLL/BSL430_DLL/Physical_Interfaces/MSPBSL_PhysicalInterfaceUSB.cpp 2017-12-05 18:47:14.575461000 +0300
|
||||
@@ -189,7 +189,7 @@ uint16_t MSPBSL_PhysicalInterfaceUSB::RX
|
||||
return ERROR_READING_DATA;
|
||||
}
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- ThirdParty/BSL430_DLL/Makefile.orig 2015-04-22 12:01:02 UTC
|
||||
+++ ThirdParty/BSL430_DLL/Makefile
|
||||
--- ThirdParty/BSL430_DLL/Makefile.orig 2016-02-29 15:26:38.000000000 +0300
|
||||
+++ ThirdParty/BSL430_DLL/Makefile 2017-12-05 18:35:24.642830000 +0300
|
||||
@@ -47,11 +47,15 @@ ifeq ($(PLATFORM),Linux)
|
||||
INCLUDES += -I$(BOOST_DIR)
|
||||
endif
|
||||
|
|
Loading…
Reference in a new issue