Update to version 18.1
This commit is contained in:
parent
2c3ec5d088
commit
f498efe0e4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=95262
10 changed files with 162 additions and 46 deletions
|
@ -6,25 +6,32 @@
|
|||
#
|
||||
|
||||
PORTNAME= portaudio
|
||||
PORTVERSION= 18
|
||||
PORTVERSION= 18.1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.portaudio.com/archives/
|
||||
DISTNAME= ${PORTNAME}_v${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}_v${PORTVERSION:S/./_/}
|
||||
|
||||
MAINTAINER= michaelnottebrock@gmx.net
|
||||
MAINTAINER= lofi@freebsd.org
|
||||
COMMENT= Portable cross-platform Audio API
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_ZIP= yes
|
||||
USE_GMAKE= yes
|
||||
MAKEFILE= Makefile.linux
|
||||
ALL_TARGET= sharedlib
|
||||
PLIST_SUB= SHLIB_VERSION=${SHLIB_VERSION}
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
NO_FILTER_SHLIBS=yes
|
||||
|
||||
SHLIB_VERSION= 0
|
||||
pre-everything::
|
||||
.if !defined(WITH_PATESTS)
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} "You can additionally build portaudio's testsuite by defining WITH_PATESTS."
|
||||
@${ECHO_MSG}
|
||||
PLIST_SUB+= WITH_PATESTS="@comment "
|
||||
.else
|
||||
PLIST_SUB+= WITH_PATESTS=""
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
pre-patch:
|
||||
# replace \r\n with \n
|
||||
# replace <malloc.h> with <stdlib.h>
|
||||
@${FIND} ${WRKSRC} -type f \
|
||||
|
@ -32,20 +39,20 @@ post-patch:
|
|||
${REINPLACE_CMD} -E \
|
||||
-e 's|
||' \
|
||||
-e 's|malloc.h|stdlib.h|' \
|
||||
-e 's|machine\/soundcard.h|sys\/soundcard.h|'
|
||||
-e 's|machine\/soundcard.h|sys\/soundcard.h|' \
|
||||
-e 's|-lpthread|${PTHREAD_LIBS}|'
|
||||
pre-configure:
|
||||
# Make configure executable
|
||||
@${CHMOD} +x ${WRKSRC}/configure
|
||||
|
||||
# C{C,FLAGS} and PREFIX safeness
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's|gcc|${CC} ${CFLAGS}|' \
|
||||
-e 's|^CFLAGS.*$$||' \
|
||||
${BUILD_WRKSRC}/${MAKEFILE}
|
||||
.if !defined(WITH_PATESTS)
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e 's|tests$$||' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
@${INSTALL_DATA} ${WRKSRC}/pa_common/portaudio.h \
|
||||
${PREFIX}/include
|
||||
@${INSTALL_DATA} ${WRKSRC}/pa_unix_oss/libportaudio.so \
|
||||
${PREFIX}/lib
|
||||
@${LN} -sf libportaudio.so \
|
||||
${PREFIX}/lib/libportaudio.so.${SHLIB_VERSION}
|
||||
.if defined(WITH_PATESTS)
|
||||
post-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (portaudio_v18.zip) = 4371cbba9e0aa13d0b605c7bf31da50a
|
||||
MD5 (portaudio_v18_1.zip) = ce66a732d263fde2b5ad2262ef37a691
|
||||
|
|
14
audio/portaudio/files/patch-pa_tests::patest_record.c
Normal file
14
audio/portaudio/files/patch-pa_tests::patest_record.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- pa_tests/patest_record.c.orig Sun Dec 7 14:48:31 2003
|
||||
+++ pa_tests/patest_record.c Sun Dec 7 14:48:53 2003
|
||||
@@ -138,10 +138,10 @@
|
||||
SAMPLE *wptr = (SAMPLE*)outputBuffer;
|
||||
unsigned int i;
|
||||
int finished;
|
||||
+ int framesToPlay, samplesToPlay, samplesPerBuffer;
|
||||
unsigned int framesLeft = data->maxFrameIndex - data->frameIndex;
|
||||
(void) inputBuffer; /* Prevent unused variable warnings. */
|
||||
(void) outTime;
|
||||
- int framesToPlay, samplesToPlay, samplesPerBuffer;
|
||||
|
||||
if( framesLeft < framesPerBuffer )
|
||||
{
|
13
audio/portaudio/files/patch-pa_tests::patest_wire.c
Normal file
13
audio/portaudio/files/patch-pa_tests::patest_wire.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- pa_tests/patest_wire.c.orig Sun Dec 7 14:49:15 2003
|
||||
+++ pa_tests/patest_wire.c Sun Dec 7 14:49:52 2003
|
||||
@@ -74,9 +74,9 @@
|
||||
SAMPLE *out = (SAMPLE*)outputBuffer;
|
||||
SAMPLE *in = (SAMPLE*)inputBuffer;
|
||||
unsigned int i;
|
||||
- (void) outTime;
|
||||
int samplesPerFrame;
|
||||
int numSamples;
|
||||
+ (void) outTime;
|
||||
|
||||
samplesPerFrame = (int) userData;
|
||||
numSamples = framesPerBuffer * samplesPerFrame;
|
|
@ -1,3 +1,27 @@
|
|||
%%WITH_PATESTS%%bin/patest_buffer
|
||||
%%WITH_PATESTS%%bin/patest_clip
|
||||
%%WITH_PATESTS%%bin/patest_dither
|
||||
%%WITH_PATESTS%%bin/patest_hang
|
||||
%%WITH_PATESTS%%bin/patest_latency
|
||||
%%WITH_PATESTS%%bin/patest_leftright
|
||||
%%WITH_PATESTS%%bin/patest_longsine
|
||||
%%WITH_PATESTS%%bin/patest_many
|
||||
%%WITH_PATESTS%%bin/patest_maxsines
|
||||
%%WITH_PATESTS%%bin/patest_multi_sine
|
||||
%%WITH_PATESTS%%bin/patest_pink
|
||||
%%WITH_PATESTS%%bin/patest_record
|
||||
%%WITH_PATESTS%%bin/patest_ringmix
|
||||
%%WITH_PATESTS%%bin/patest_saw
|
||||
%%WITH_PATESTS%%bin/patest_sine
|
||||
%%WITH_PATESTS%%bin/patest_sine8
|
||||
%%WITH_PATESTS%%bin/patest_sine_formats
|
||||
%%WITH_PATESTS%%bin/patest_sine_time
|
||||
%%WITH_PATESTS%%bin/patest_stop
|
||||
%%WITH_PATESTS%%bin/patest_sync
|
||||
%%WITH_PATESTS%%bin/patest_toomanysines
|
||||
%%WITH_PATESTS%%bin/patest_underflow
|
||||
%%WITH_PATESTS%%bin/patest_wire
|
||||
include/portaudio.h
|
||||
lib/libportaudio.a
|
||||
lib/libportaudio.so
|
||||
lib/libportaudio.so.%%SHLIB_VERSION%%
|
||||
lib/libportaudio.so.0.0.18
|
||||
|
|
|
@ -6,25 +6,32 @@
|
|||
#
|
||||
|
||||
PORTNAME= portaudio
|
||||
PORTVERSION= 18
|
||||
PORTVERSION= 18.1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.portaudio.com/archives/
|
||||
DISTNAME= ${PORTNAME}_v${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}_v${PORTVERSION:S/./_/}
|
||||
|
||||
MAINTAINER= michaelnottebrock@gmx.net
|
||||
MAINTAINER= lofi@freebsd.org
|
||||
COMMENT= Portable cross-platform Audio API
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_ZIP= yes
|
||||
USE_GMAKE= yes
|
||||
MAKEFILE= Makefile.linux
|
||||
ALL_TARGET= sharedlib
|
||||
PLIST_SUB= SHLIB_VERSION=${SHLIB_VERSION}
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
NO_FILTER_SHLIBS=yes
|
||||
|
||||
SHLIB_VERSION= 0
|
||||
pre-everything::
|
||||
.if !defined(WITH_PATESTS)
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} "You can additionally build portaudio's testsuite by defining WITH_PATESTS."
|
||||
@${ECHO_MSG}
|
||||
PLIST_SUB+= WITH_PATESTS="@comment "
|
||||
.else
|
||||
PLIST_SUB+= WITH_PATESTS=""
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
pre-patch:
|
||||
# replace \r\n with \n
|
||||
# replace <malloc.h> with <stdlib.h>
|
||||
@${FIND} ${WRKSRC} -type f \
|
||||
|
@ -32,20 +39,20 @@ post-patch:
|
|||
${REINPLACE_CMD} -E \
|
||||
-e 's|
||' \
|
||||
-e 's|malloc.h|stdlib.h|' \
|
||||
-e 's|machine\/soundcard.h|sys\/soundcard.h|'
|
||||
-e 's|machine\/soundcard.h|sys\/soundcard.h|' \
|
||||
-e 's|-lpthread|${PTHREAD_LIBS}|'
|
||||
pre-configure:
|
||||
# Make configure executable
|
||||
@${CHMOD} +x ${WRKSRC}/configure
|
||||
|
||||
# C{C,FLAGS} and PREFIX safeness
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's|gcc|${CC} ${CFLAGS}|' \
|
||||
-e 's|^CFLAGS.*$$||' \
|
||||
${BUILD_WRKSRC}/${MAKEFILE}
|
||||
.if !defined(WITH_PATESTS)
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e 's|tests$$||' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
@${INSTALL_DATA} ${WRKSRC}/pa_common/portaudio.h \
|
||||
${PREFIX}/include
|
||||
@${INSTALL_DATA} ${WRKSRC}/pa_unix_oss/libportaudio.so \
|
||||
${PREFIX}/lib
|
||||
@${LN} -sf libportaudio.so \
|
||||
${PREFIX}/lib/libportaudio.so.${SHLIB_VERSION}
|
||||
.if defined(WITH_PATESTS)
|
||||
post-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (portaudio_v18.zip) = 4371cbba9e0aa13d0b605c7bf31da50a
|
||||
MD5 (portaudio_v18_1.zip) = ce66a732d263fde2b5ad2262ef37a691
|
||||
|
|
14
audio/portaudio2/files/patch-pa_tests::patest_record.c
Normal file
14
audio/portaudio2/files/patch-pa_tests::patest_record.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- pa_tests/patest_record.c.orig Sun Dec 7 14:48:31 2003
|
||||
+++ pa_tests/patest_record.c Sun Dec 7 14:48:53 2003
|
||||
@@ -138,10 +138,10 @@
|
||||
SAMPLE *wptr = (SAMPLE*)outputBuffer;
|
||||
unsigned int i;
|
||||
int finished;
|
||||
+ int framesToPlay, samplesToPlay, samplesPerBuffer;
|
||||
unsigned int framesLeft = data->maxFrameIndex - data->frameIndex;
|
||||
(void) inputBuffer; /* Prevent unused variable warnings. */
|
||||
(void) outTime;
|
||||
- int framesToPlay, samplesToPlay, samplesPerBuffer;
|
||||
|
||||
if( framesLeft < framesPerBuffer )
|
||||
{
|
13
audio/portaudio2/files/patch-pa_tests::patest_wire.c
Normal file
13
audio/portaudio2/files/patch-pa_tests::patest_wire.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- pa_tests/patest_wire.c.orig Sun Dec 7 14:49:15 2003
|
||||
+++ pa_tests/patest_wire.c Sun Dec 7 14:49:52 2003
|
||||
@@ -74,9 +74,9 @@
|
||||
SAMPLE *out = (SAMPLE*)outputBuffer;
|
||||
SAMPLE *in = (SAMPLE*)inputBuffer;
|
||||
unsigned int i;
|
||||
- (void) outTime;
|
||||
int samplesPerFrame;
|
||||
int numSamples;
|
||||
+ (void) outTime;
|
||||
|
||||
samplesPerFrame = (int) userData;
|
||||
numSamples = framesPerBuffer * samplesPerFrame;
|
|
@ -1,3 +1,27 @@
|
|||
%%WITH_PATESTS%%bin/patest_buffer
|
||||
%%WITH_PATESTS%%bin/patest_clip
|
||||
%%WITH_PATESTS%%bin/patest_dither
|
||||
%%WITH_PATESTS%%bin/patest_hang
|
||||
%%WITH_PATESTS%%bin/patest_latency
|
||||
%%WITH_PATESTS%%bin/patest_leftright
|
||||
%%WITH_PATESTS%%bin/patest_longsine
|
||||
%%WITH_PATESTS%%bin/patest_many
|
||||
%%WITH_PATESTS%%bin/patest_maxsines
|
||||
%%WITH_PATESTS%%bin/patest_multi_sine
|
||||
%%WITH_PATESTS%%bin/patest_pink
|
||||
%%WITH_PATESTS%%bin/patest_record
|
||||
%%WITH_PATESTS%%bin/patest_ringmix
|
||||
%%WITH_PATESTS%%bin/patest_saw
|
||||
%%WITH_PATESTS%%bin/patest_sine
|
||||
%%WITH_PATESTS%%bin/patest_sine8
|
||||
%%WITH_PATESTS%%bin/patest_sine_formats
|
||||
%%WITH_PATESTS%%bin/patest_sine_time
|
||||
%%WITH_PATESTS%%bin/patest_stop
|
||||
%%WITH_PATESTS%%bin/patest_sync
|
||||
%%WITH_PATESTS%%bin/patest_toomanysines
|
||||
%%WITH_PATESTS%%bin/patest_underflow
|
||||
%%WITH_PATESTS%%bin/patest_wire
|
||||
include/portaudio.h
|
||||
lib/libportaudio.a
|
||||
lib/libportaudio.so
|
||||
lib/libportaudio.so.%%SHLIB_VERSION%%
|
||||
lib/libportaudio.so.0.0.18
|
||||
|
|
Loading…
Reference in a new issue