- Update to 1.2

PR:		162400
Submitted by:	Andrei Lavreniyuk <andy.lavr@gmail.com> (maintainer)
This commit is contained in:
Martin Wilke 2012-01-27 17:36:58 +00:00
parent 0add8117f1
commit f4c4d96943
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=289887
9 changed files with 62 additions and 84 deletions

View file

@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= torsocks
PORTVERSION= 1.1
PORTREVISION= 1
PORTVERSION= 1.2
CATEGORIES= net security
MASTER_SITES= GOOGLE_CODE \
http://tor.reactor-xg.kiev.ua/files/
@ -30,7 +29,7 @@ SUB_FILES= pkg-message
OPTIONS= SOCKSDNS "Use socks server for DNS lookups" off \
OLDMETHOD "Do not use RTLD_NEXT parameter to dlsym" off \
NODEBUG "Disable output of error messages" off \
HOSTNAMES "Disable DNS lookups of socks server" off
HOSTNAMES "Enable DNS lookups of socks server" off
.include <bsd.port.pre.mk>
@ -50,8 +49,8 @@ CONFIGURE_ARGS+= --disable-debug
CONFIGURE_ARGS+= --enable-hostnames
.endif
.if defined(WITH_SOCKSDNS) && !defined(WITH_HOSTNAMES)
BROKEN= HOSTNAMES option is necessary if SOCKSDNS option is enabled
.if defined(WITH_SOCKSDNS) && defined(WITH_HOSTNAMES)
BROKEN= HOSTNAMES option is not allowed when SOCKSDNS option is enabled
.endif
pre-everything::
@ -87,9 +86,9 @@ pre-everything::
.if !defined(WITH_HOSTNAMES)
@${ECHO_MSG}
@${ECHO_MSG} "You can use the HOSTNAMES option."
@${ECHO_MSG} "This disables DNS lookups on names"
@${ECHO_MSG} "This enables DNS lookups on names"
@${ECHO_MSG} "provided as socks servers in the config"
@${ECHO_MSG} "file. This option is necessary"
@${ECHO_MSG} "file. This option is not allowed"
@${ECHO_MSG} "if socks dns is enabled since torsocks"
@${ECHO_MSG} "can't send a socks dns request to resolve"
@${ECHO_MSG} "the location of the socks server."
@ -99,12 +98,13 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|@prefix@|${PREFIX}|' ${WRKSRC}/src/torsocks.in
@${REINPLACE_CMD} -e 's|MAP_ANONYMOUS|MAP_ANON|' ${WRKSRC}/src/dead_pool.c
@${MV} ${WRKSRC}/src/torsocks.conf ${WRKSRC}/src/torsocks.conf.sample
@${MV} ${WRKSRC}/doc/torsocks.conf ${WRKSRC}/doc/torsocks.conf.sample
post-install:
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/src/*.example ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.sample ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.sample ${PREFIX}/etc
.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}

View file

@ -1,2 +1,2 @@
SHA256 (torsocks-1.1.tar.gz) = 09dac54c2bb4e57cfdc449dc45b97be832910a4d81d5a2931543b469d97fdf01
SIZE (torsocks-1.1.tar.gz) = 674386
SHA256 (torsocks-1.2.tar.gz) = bea57d3624d723724fd1e260f0e6b2a354c0da742c023aa994c7692270d111d4
SIZE (torsocks-1.2.tar.gz) = 456453

View file

@ -1,21 +1,10 @@
--- src/Makefile.am.orig 2009-02-07 11:48:12.000000000 +0100
+++ src/Makefile.am 2009-02-18 17:29:26.000000000 +0100
@@ -1,7 +1,7 @@
--- src/Makefile.am.orig 2011-10-24 22:26:34.000000000 +0300
+++ src/Makefile.am 2011-11-09 12:36:55.697224889 +0200
@@ -1,6 +1,6 @@
# Makefile used by configure to create real Makefile
-LIBS = -ldl -lc -lresolv
-libdir = @prefix@/lib/torsocks
+LIBS = -lc
-libdir = @libdir@/torsocks
+libdir = @prefix@/lib
# Install helper programs
#bin_PROGRAMS = validateconf inspectsocks saveme
@@ -16,7 +16,7 @@
# Install configuration file
usewithtorconfdir = $(CONFDIR)/
-usewithtorconf_DATA = torsocks.conf
+usewithtorconf_DATA = torsocks.conf.sample
# Install invocation scripts
bin_SCRIPTS = torsocks usewithtor

View file

@ -1,17 +1,11 @@
--- src/Makefile.in.orig 2009-11-08 06:39:45.000000000 -0600
+++ src/Makefile.in 2010-10-02 15:56:22.000000000 -0500
@@ -145,3 +145,3 @@
LIBOBJS = @LIBOBJS@
-LIBS = -ldl -lc -lresolv
+LIBS = -lc
LIBTOOL = @LIBTOOL@
@@ -207,3 +207,3 @@
--- src/Makefile.in.orig 2011-10-24 23:23:39.000000000 +0300
+++ src/Makefile.in 2011-11-09 12:41:22.805940562 +0200
@@ -196,7 +196,7 @@
includedir = @includedir@
infodir = @infodir@
install_sh = @install_sh@
-libdir = @prefix@/lib/torsocks
-libdir = @libdir@/torsocks
+libdir = @prefix@/lib
libexecdir = @libexecdir@
@@ -241,3 +241,3 @@
usewithtorconfdir = $(CONFDIR)/
-usewithtorconf_DATA = torsocks.conf
+usewithtorconf_DATA = torsocks.conf.sample
localedir = @localedir@
localstatedir = @localstatedir@

View file

@ -1,17 +0,0 @@
--- configure.in.orig 2009-11-08 14:35:11.000000000 +0200
+++ configure.in 2009-11-13 16:49:06.984178608 +0200
@@ -123,11 +123,9 @@
dnl Checks for libraries.
dnl Replace `main' with a function in -ldl:
-AC_CHECK_LIB(dl, dlsym, [ tempdso="yes" ],tempdso="no")
-if test "$tempdso" = "no"; then
- AC_CHECK_LIB(c, dlsym,,AC_MSG_ERROR("dlsym() not found in libc or libdl." \
- "Check your system for libc.so and/or libdl.so."))
-fi
+dnl Checks for libraries.
+AC_CHECK_LIB(c, dlsym,,AC_MSG_ERROR(""dlsym() not found in libc." \
+ "Check your system for libc.so."))
AC_CHECK_LIB(resolv, res_query, [ tempres="no" ],tempres="yes")
if test "$tempres" = "no"; then

View file

@ -0,0 +1,13 @@
--- doc/Makefile.am.orig 2011-10-26 21:30:26.000000000 +0300
+++ doc/Makefile.am 2011-11-13 09:08:17.999745756 +0200
@@ -2,7 +2,9 @@
# Install configuration file
confdir = $(CONFDIR)/
-dist_conf_DATA = torsocks.conf
+dist_conf_DATA = torsocks.conf.sample
+datarootdir = ${prefix}/share/torsocks
+
# Install man pages
dist_man_MANS = torsocks.1 torsocks.8 usewithtor.1 torsocks.conf.5

View file

@ -0,0 +1,8 @@
--- test/Makefile.am.orig 2011-11-13 09:40:52.593544321 +0200
+++ test/Makefile.am 2011-11-13 09:41:18.074140449 +0200
@@ -5,3 +5,5 @@
CLEANFILES= test_torsocks
dist_data_DATA = run_tests.sh expectedresults.txt
+
+datarootdir = ${prefix}/share/torsocks/test

View file

@ -1,25 +0,0 @@
--- src/tsocks.c.orig 2009-11-08 14:35:11.000000000 +0200
+++ src/tsocks.c 2009-11-13 17:00:10.412574127 +0200
@@ -54,6 +54,13 @@
#define _GNU_SOURCE
#endif
+/* Required by some BSDs */
+#ifndef MAP_ANONYMOUS
+#ifdef MAP_ANON
+#define MAP_ANONYMOUS MAP_ANON
+#endif
+#endif
+
/* Global configuration variables */
const char *progname = "libtorsocks"; /* Name used in err msgs */
@@ -163,7 +169,7 @@
void tsocks_init(void) {
#define LOAD_ERROR(s,l) { \
- char *error; \
+ const char *error; \
error = dlerror(); \
show_msg(l, "The symbol %s() was not found in any shared " \
"library. The error reported was: %s!\n", s, \

View file

@ -5,8 +5,24 @@ lib/libtorsocks.a
lib/libtorsocks.la
lib/libtorsocks.so
lib/libtorsocks.so.1
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tsocks.conf.complex.example
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tsocks.conf.simple.example
share/torsocks/DEBUG
share/torsocks/README
share/torsocks/README.TORDNS
share/torsocks/SOCKS4.protocol
share/torsocks/SOCKS5
share/torsocks/compilewarnings.patch
share/torsocks/conffile.patch
share/torsocks/getaddrbyhost.patch
share/torsocks/getpeername.patch
share/torsocks/infiniteloop.patch
share/torsocks/localaddresses.patch
share/torsocks/socks-extensions.txt
share/torsocks/tordns.patch
share/torsocks/test/expectedresults.txt
share/torsocks/test/run_tests.sh
@dirrm share/torsocks/test
@dirrm share/torsocks
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/torsocks.conf.sample
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%