upgrade to 3.0
This commit is contained in:
parent
bad0638740
commit
f4fcd5d64f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=6035
4 changed files with 50 additions and 125 deletions
|
@ -1,20 +1,20 @@
|
|||
# New ports collection makefile for: xephem
|
||||
# Version required: 2.7.1
|
||||
# Version required: 3.0
|
||||
# Date created: Thu Aug 1 09:10:22 CDT 1996
|
||||
# Whom: erich@FreeBSD.org
|
||||
#
|
||||
# $Id: Makefile,v 1.3 1996/11/15 22:35:07 obrien Exp $
|
||||
# $Id: Makefile,v 1.4 1996/11/18 09:52:05 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xephem_2.7.1
|
||||
PKGNAME= xephem-2.7.1
|
||||
DISTNAME= xephem_3.0
|
||||
PKGNAME= xephem-3.0
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
|
||||
MASTER_SITE_SUBDIR= applications
|
||||
MASTER_SITES= ftp://iraf.noao.edu/contrib/xephem/xephem_3.0/
|
||||
|
||||
MAINTAINER= erich@FreeBSD.org
|
||||
|
||||
REQUIRES_MOTIF= yes
|
||||
|
||||
USE_IMAKE= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (xephem_2.7.1.tar.gz) = 94de963200663ba0a06cf691dcfe00ee
|
||||
MD5 (xephem_3.0.tar.gz) = 9ca5767bf2d754ed248ec13b449d246d
|
||||
|
|
|
@ -1,86 +1,19 @@
|
|||
--- Imakefile~ Mon Aug 21 10:36:30 1995
|
||||
+++ Imakefile Thu Aug 1 11:58:04 1996
|
||||
@@ -24,7 +24,7 @@
|
||||
--- Imakefile~ Thu Mar 27 15:23:53 1997
|
||||
+++ Imakefile Thu Mar 27 16:25:24 1997
|
||||
@@ -15,10 +15,15 @@
|
||||
|
||||
OBJS = $(SRCS:.c=.o)
|
||||
|
||||
DEPXMLIB = $(USRLIBDIR)/libXm.a
|
||||
- XMLIB = -lXm
|
||||
+ XMLIB = ${MOTIFLIB}
|
||||
DEPLIBS = $(DEPXMLIB) $(DEPXTOOLLIB) $(DEPXLIB)
|
||||
LOCAL_LIBRARIES = $(XMLIB) $(XTOOLLIB) $(XLIB)
|
||||
SYS_LIBRARIES = -lm
|
||||
@@ -34,4 +34,9 @@
|
||||
PROGRAMS = xephem
|
||||
|
||||
/* especially worth having this dependency so the displayed version is current.
|
||||
*/
|
||||
ComplexProgramTarget(xephem)
|
||||
+
|
||||
+install::
|
||||
+ mkdir -p ${PREFIX}/lib/X11/xephem
|
||||
+ tar -cf - auxil edb gscdbd tools work |(cd ${PREFIX}/lib/X11/xephem; tar -xf -)
|
||||
+ tar -cf - auxil edb tools work |(cd ${PREFIX}/lib/X11/xephem; tar -xf -)
|
||||
+ cp XEphem.ad ${PREFIX}/lib/X11/app-defaults/XEphem
|
||||
+
|
||||
versionmenu.o: patchlevel.h
|
||||
--- XEphem.ad~ Mon Aug 7 10:23:43 1995
|
||||
+++ XEphem.ad Thu Aug 1 11:54:15 1996
|
||||
@@ -102,39 +102,39 @@
|
||||
XEphem*TZone.UTC.set: False
|
||||
|
||||
! default plot and listing filenames (a leading ~ refers to HOME)
|
||||
-XEphem*Plot*Filename.value: work/ephem.plt
|
||||
-XEphem*List*Filename.value: work/ephem.lst
|
||||
+XEphem*Plot*Filename.value: /usr/X11R6/lib/X11/xephem/work/ephem.plt
|
||||
+XEphem*List*Filename.value: /usr/X11R6/lib/X11/xephem/work/ephem.lst
|
||||
|
||||
! default sky list filename (a leading ~ refers to HOME)
|
||||
-XEphem*SkyList*textString: work/skylist.txt
|
||||
+XEphem*SkyList*textString: /usr/X11R6/lib/X11/xephem/work/skylist.txt
|
||||
|
||||
! default close list filename (a leading ~ refers to HOME)
|
||||
-XEphem*CloseList*textString: work/closelist.txt
|
||||
+XEphem*CloseList*textString: /usr/X11R6/lib/X11/xephem/work/closelist.txt
|
||||
|
||||
! default help file name (a leading ~ refers to HOME)
|
||||
-XEphem.HELPFILE: auxil/xephem.hlp
|
||||
+XEphem.HELPFILE: /usr/X11R6/lib/X11/xephem/auxil/xephem.hlp
|
||||
|
||||
! default Earth menu sites file name
|
||||
-XEphem.SITESFILE: auxil/xephem_sites
|
||||
+XEphem.SITESFILE: /usr/X11R6/lib/X11/xephem/auxil/xephem_sites
|
||||
|
||||
! default initial database directory, file name pattern, and file names.
|
||||
! DBinitialFiles may list db files to read automatically upon startup, each
|
||||
! separated by one blank. These will be searched for in DBdirectory.
|
||||
-XEphem.DBdirectory: edb
|
||||
+XEphem.DBdirectory: /usr/X11R6/lib/X11/xephem/edb
|
||||
XEphem.DBpattern: *.edb
|
||||
XEphem.DBinitialFiles: basic.edb
|
||||
|
||||
! default database fifo name (a leading ~ refers to HOME)
|
||||
-XEphem.DBFIFO: fifos/xephem_db_fifo
|
||||
+XEphem.DBFIFO: ~/.xephem/xephem_db_fifo
|
||||
|
||||
! default Skyview output fifo name (a leading ~ refers to HOME)
|
||||
-XEphem.SKYOUTFIFO: fifos/xephem_out_fifo
|
||||
+XEphem.SKYOUTFIFO: ~/.xephem/xephem_out_fifo
|
||||
|
||||
! default Skyview direction input fifo name (a leading ~ refers to HOME)
|
||||
-XEphem.SKYINFIFO: fifos/xephem_in_fifo
|
||||
+XEphem.SKYINFIFO: ~/.xephem/xephem_in_fifo
|
||||
|
||||
! default Skyview Button2 fifo name (a leading ~ refers to HOME)
|
||||
-XEphem.SKYLOCFIFO: fifos/xephem_loc_fifo
|
||||
+XEphem.SKYLOCFIFO: ~/.xephem/xephem_loc_fifo
|
||||
|
||||
! set Geocentric.set to true for geocentric separations,
|
||||
! or Topocentric.set to true for topocentric separation..
|
||||
--- misc.c~ Thu Aug 3 14:22:44 1995
|
||||
+++ misc.c Thu Aug 1 11:00:17 1996
|
||||
@@ -673,7 +673,9 @@
|
||||
#include <errno.h>
|
||||
#include <perror.h>
|
||||
#else
|
||||
+#if !defined(__FreeBSD__) && !defined(__OpenBSD__) && !defined(__NetBSD__)
|
||||
extern char *sys_errlist[];
|
||||
+#endif
|
||||
extern int errno;
|
||||
#endif
|
||||
return (sys_errlist[errno]);
|
||||
|
|
|
@ -2,57 +2,49 @@ bin/xephem
|
|||
man/man1/xephem.1.gz
|
||||
lib/X11/app-defaults/XEphem
|
||||
lib/X11/xephem/auxil/README
|
||||
lib/X11/xephem/auxil/moon.fts
|
||||
lib/X11/xephem/auxil/gsccache/README
|
||||
lib/X11/xephem/auxil/marsmap.fts
|
||||
lib/X11/xephem/auxil/mars_db
|
||||
lib/X11/xephem/auxil/moon_db
|
||||
lib/X11/xephem/auxil/xephem.hlp
|
||||
lib/X11/xephem/auxil/xephem_sites
|
||||
lib/X11/xephem/edb/README
|
||||
lib/X11/xephem/edb/asteroids.edb
|
||||
lib/X11/xephem/edb/basic.edb
|
||||
lib/X11/xephem/edb/Messier.edb
|
||||
lib/X11/xephem/edb/NGC.edb
|
||||
lib/X11/xephem/edb/SAC.edb
|
||||
lib/X11/xephem/edb/YBS.edb
|
||||
lib/X11/xephem/edb/astorb.edb
|
||||
lib/X11/xephem/edb/comets.edb
|
||||
lib/X11/xephem/edb/comets2.edb
|
||||
lib/X11/xephem/edb/ngc.edb
|
||||
lib/X11/xephem/edb/gps.edb
|
||||
lib/X11/xephem/edb/mir.edb
|
||||
lib/X11/xephem/edb/pulsars.edb
|
||||
lib/X11/xephem/edb/sac.edb
|
||||
lib/X11/xephem/edb/shuttle.edb
|
||||
lib/X11/xephem/edb/spacecraft.edb
|
||||
lib/X11/xephem/edb/vla2.edb
|
||||
lib/X11/xephem/edb/vla20.edb
|
||||
lib/X11/xephem/edb/vla3.7.edb
|
||||
lib/X11/xephem/edb/vla6.edb
|
||||
lib/X11/xephem/edb/vla90.edb
|
||||
lib/X11/xephem/gscdbd/README
|
||||
lib/X11/xephem/gscdbd/Makefile
|
||||
lib/X11/xephem/gscdbd/gscdbd.c
|
||||
lib/X11/xephem/gscdbd/cacheio.c
|
||||
lib/X11/xephem/gscdbd/gscdbd.h
|
||||
lib/X11/xephem/gscdbd/gscio.c
|
||||
lib/X11/xephem/gscdbd/support.c
|
||||
lib/X11/xephem/gscdbd/version.c
|
||||
lib/X11/xephem/gscdbd/cache/README
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6214.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6215.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6228.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6229.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6230.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6325.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6326.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6311.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6324.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6391.ech
|
||||
lib/X11/xephem/gscdbd/cache/s1500/6263.ech
|
||||
lib/X11/xephem/gscdbd/cache/s0000/5250.ech
|
||||
lib/X11/xephem/gscdbd/cache/s0000/5254.ech
|
||||
lib/X11/xephem/gscdbd/cache/s0000/5255.ech
|
||||
lib/X11/xephem/gscdbd/cache/s0000/5257.ech
|
||||
lib/X11/xephem/gscdbd/cache/s0000/5031.ech
|
||||
lib/X11/xephem/gscdbd/cache/s0000/5044.ech
|
||||
lib/X11/xephem/gscdbd/cache/s0730/5611.ech
|
||||
lib/X11/xephem/gscdbd/cache/s0730/5612.ech
|
||||
lib/X11/xephem/gscdbd/cache/s0730/5613.ech
|
||||
lib/X11/xephem/gscdbd/cache/n8230/4661.ech
|
||||
lib/X11/xephem/gscdbd/cache/s8230/9534.ech
|
||||
lib/X11/xephem/edb/vla2cm.edb
|
||||
lib/X11/xephem/edb/vla20cm.edb
|
||||
lib/X11/xephem/edb/vla3.7cm.edb
|
||||
lib/X11/xephem/edb/vla6cm.edb
|
||||
lib/X11/xephem/edb/vla90cm.edb
|
||||
lib/X11/xephem/tools/README
|
||||
lib/X11/xephem/tools/encke2edb.nawk
|
||||
lib/X11/xephem/tools/astorb2edb.pl
|
||||
lib/X11/xephem/tools/encke2edb.pl
|
||||
lib/X11/xephem/tools/extract.awk
|
||||
lib/X11/xephem/tools/gps.awk
|
||||
lib/X11/xephem/tools/gsc/Makefile
|
||||
lib/X11/xephem/tools/gsc/README
|
||||
lib/X11/xephem/tools/gsc/gscd.c
|
||||
lib/X11/xephem/tools/gsc/gscload.c
|
||||
lib/X11/xephem/tools/gsc/gsclogstats.pl
|
||||
lib/X11/xephem/tools/gsc/support.c
|
||||
lib/X11/xephem/tools/jost2edb.nawk
|
||||
lib/X11/xephem/tools/tle2edb.awk
|
||||
lib/X11/xephem/tools/yeomans.pl
|
||||
lib/X11/xephem/work/README
|
||||
lib/X11/xephem/work/ephem.plt
|
||||
@dirrm lib/X11/xephem/auxil/gsccache
|
||||
@dirrm lib/X11/xephem/auxil
|
||||
@dirrm lib/X11/xephem/edb
|
||||
@dirrm lib/X11/xephem/tools/gsc
|
||||
@dirrm lib/X11/xephem/tools
|
||||
@dirrm lib/X11/xephem/work
|
||||
@dirrm lib/X11/xephem
|
||||
|
|
Loading…
Reference in a new issue