Update to 0.94.
This commit is contained in:
parent
ffdf5b9d69
commit
f5295b8b8d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=429920
4 changed files with 12 additions and 44 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cone
|
||||
PORTVERSION= 0.92
|
||||
PORTVERSION= 0.94
|
||||
CATEGORIES= mail
|
||||
# This is for beta versions, leave it in please:
|
||||
#MASTER_SITES= http://www.courier-mta.org/beta/${PORTNAME}/ \
|
||||
|
@ -16,7 +16,7 @@ COMMENT= Console based mail client with POP3/IMAP/SMAP support
|
|||
LICENSE= GPLv3
|
||||
|
||||
LIB_DEPENDS= libaspell.so:textproc/aspell \
|
||||
libcourier-unicode.so:devel/courier-unicode
|
||||
libcourier-unicode.so:devel/courier-unicode
|
||||
BUILD_DEPENDS= gpgv:security/gnupg1
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
|
||||
|
@ -35,12 +35,12 @@ INSTALL_TARGET= install-strip
|
|||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/leaf
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mailtool
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/cone
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/sysconftool ${STAGEDIR}${PREFIX}/sbin/cone-sysconftool
|
||||
${RM} ${STAGEDIR}${PREFIX}/share/cone/rootcerts/.0
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/ChangeLog ${STAGEDIR}${DOCSDIR}
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/leaf
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mailtool
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/cone
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/sysconftool ${STAGEDIR}${PREFIX}/sbin/cone-sysconftool
|
||||
${RM} ${STAGEDIR}${PREFIX}/share/cone/rootcerts/.0
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/ChangeLog ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (cone-0.92.tar.bz2) = bfc1170565d931ac9b8a674410f44cb2472c7b755b5bb97e9915d37fdfe9d631
|
||||
SIZE (cone-0.92.tar.bz2) = 3774451
|
||||
TIMESTAMP = 1483020625
|
||||
SHA256 (cone-0.94.tar.bz2) = c52be25ca3547baf1d7ed6fdfdb2aaec3224ea6183b8fc8eeb53f3e615694f49
|
||||
SIZE (cone-0.94.tar.bz2) = 3749999
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
--- cone/cursesmessage.C.orig 2014-01-06 19:51:56 UTC
|
||||
+++ cone/cursesmessage.C
|
||||
@@ -3761,10 +3761,10 @@ bool CursesMessage::decrypt(std::string
|
||||
gi.passphrase_fd=passphrase_fd.c_str();
|
||||
}
|
||||
|
||||
- gi.input_func= &tempSaveText.input_func;
|
||||
+ gi.input_func= &CursesMessage::DecryptSaveText::input_func;
|
||||
gi.input_func_arg= &tempSaveText;
|
||||
|
||||
- gi.output_func= &tempSaveText.output_func;
|
||||
+ gi.output_func= &CursesMessage::DecryptSaveText::output_func;
|
||||
gi.output_func_arg= &tempSaveText;
|
||||
|
||||
gi.errhandler_func= &tempSaveText.err_func;
|
|
@ -1,18 +0,0 @@
|
|||
--- libs/tcpd/libcouriertls.c.orig 2014-10-22 08:00:04 UTC
|
||||
+++ libs/tcpd/libcouriertls.c
|
||||
@@ -74,7 +74,15 @@ struct proto_ops op_list[] =
|
||||
{ "TLSv1", &TLSv1_method, SSL_OP_ALL },
|
||||
{ "TLS1", &TLSv1_method, SSL_OP_ALL },
|
||||
{ "SSL3+", &SSLv23_method, SSL_OP_ALL|SSL_OP_NO_SSLv2 },
|
||||
+#ifndef OPENSSL_NO_SSL3
|
||||
{ "SSL3", &SSLv3_method, SSL_OP_ALL },
|
||||
+#else
|
||||
+ { "SSL3", &SSLv23_method, SSL_OP_ALL|SSL_OP_NO_SSLv2|SSL_OP_NO_TLSv1
|
||||
+#ifdef HAVE_TLSV1_1_METHOD
|
||||
+ |SSL_OP_NO_TLSv1_1|SSL_OP_NO_TLSv1_2
|
||||
+#endif /* SSL_OP_NO_TLSv1 */
|
||||
+ },
|
||||
+#endif /* OPENSSL_NO_SSL3 */
|
||||
{ "SSL23", &SSLv23_method, SSL_OP_ALL },
|
||||
{ "", &SSLv23_method, SSL_OP_ALL|SSL_OP_NO_SSLv2|SSL_OP_NO_SSLv3 },
|
||||
{ NULL, &SSLv23_method, SSL_OP_ALL|SSL_OP_NO_SSLv2|SSL_OP_NO_SSLv3 },
|
Loading…
Reference in a new issue