Upgrade x265 from 2.6 to 2.8 and:
. Explicitly disable use of AVX with clang (see patch for links) . Put non-SSL sources back on the list of MASTER_SITES Bump PORTREVISION in the depending ports as appropriate.
This commit is contained in:
parent
cf320394fc
commit
f52aa6f55d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=474814
8 changed files with 29 additions and 23 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= libbpg
|
||||
PORTVERSION= 0.9.7
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://bellard.org/bpg/
|
||||
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
PORTNAME= ccextractor
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.85
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= multimedia
|
||||
|
||||
MAINTAINER= oz@nixil.net
|
||||
|
|
|
@ -3,6 +3,7 @@
|
|||
|
||||
PORTNAME= ffmpeg
|
||||
PORTVERSION= 4.0.1
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= multimedia audio ipv6 net
|
||||
MASTER_SITES= https://ffmpeg.org/releases/
|
||||
|
|
|
@ -2,18 +2,19 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= x265
|
||||
PORTVERSION= 2.6
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.8
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= https://downloads.videolan.org/pub/videolan/${PORTNAME}/ \
|
||||
https://mirror.leaseweb.com/videolan/x265/
|
||||
MASTER_SITES= https://downloads.videolan.org/pub/videolan/x265/ \
|
||||
https://mirror.leaseweb.com/videolan/x265/ \
|
||||
http://downloads.videolan.org/pub/videolan/x265/ \
|
||||
http://mirror.leaseweb.com/videolan/x265/
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}
|
||||
|
||||
MAINTAINER= mi@aldan.algebra.com
|
||||
COMMENT= H.265/High Efficiency Video Coding (HEVC) format
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/../COPYING
|
||||
LICENSE_FILE= ${WRKSRC:H}/COPYING
|
||||
|
||||
BUILD_DEPENDS= yasm:devel/yasm
|
||||
|
||||
|
@ -28,7 +29,7 @@ DEBUG_VARS_OFF= CFLAGS+=-DNDEBUG CPPFLAGS+=-DNDEBUG
|
|||
HI10P_CMAKE_BOOL= HIGH_BIT_DEPTH
|
||||
HI12P_CMAKE_BOOL= MAIN12
|
||||
HI12P_IMPLIES= HI10P
|
||||
OPTIMIZED_FLAGS_VARS= CFLAGS+=-O3 CPPFLAGS+=-O3
|
||||
OPTIMIZED_FLAGS_VARS= CFLAGS+=-O3 CXXFLAGS+=-O3
|
||||
|
||||
DEBUG_DESC= Enable debugging
|
||||
HI10P_DESC= Enable HI10P Support (64-bit only)
|
||||
|
@ -39,8 +40,8 @@ USE_LDCONFIG= yes
|
|||
CMAKE_ARGS= -DENABLE_PIC=on -DPLATFORM_LIBS=md -DENABLE_TESTS=on
|
||||
CFLAGS_mips= -DNO_ATOMICS # cannot use lang/gcc
|
||||
CFLAGS_mips64= -DNO_ATOMICS # cannot use lang/gcc
|
||||
EXTRACT_AFTER_ARGS+= --exclude "md5*"
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION}/source
|
||||
EXTRACT_AFTER_ARGS+= --exclude "md5*" --exclude compat
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}/source
|
||||
|
||||
do-test:
|
||||
${WRKSRC}/test/TestBench
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1516798519
|
||||
SHA256 (x265_2.6.tar.gz) = 1bf0036415996af841884802161065b9e6be74f5f6808ac04831363e2549cdbf
|
||||
SIZE (x265_2.6.tar.gz) = 1271976
|
||||
TIMESTAMP = 1531665864
|
||||
SHA256 (x265_2.8.tar.gz) = 6e59f9afc0c2b87a46f98e33b5159d56ffb3558a49d8e3d79cb7fdc6b7aaa863
|
||||
SIZE (x265_2.8.tar.gz) = 1379551
|
||||
|
|
13
multimedia/x265/files/patch-disable-avx-for-clang
Normal file
13
multimedia/x265/files/patch-disable-avx-for-clang
Normal file
|
@ -0,0 +1,13 @@
|
|||
See:
|
||||
|
||||
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=229788
|
||||
https://bitbucket.org/multicoreware/x265/issues/422/when-using-clang-with-avx-enabled
|
||||
|
||||
--- CMakeLists.txt 2018-05-21 04:33:10.000000000 -0400
|
||||
+++ CMakeLists.txt 2018-07-17 12:51:05.820330000 -0400
|
||||
@@ -133,4 +133,5 @@
|
||||
if(${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
|
||||
set(CLANG 1)
|
||||
+ add_definitions("-mno-avx")
|
||||
endif()
|
||||
if(${CMAKE_CXX_COMPILER_ID} STREQUAL "Intel")
|
|
@ -1,9 +0,0 @@
|
|||
--- test/testharness.h 2016-12-23 00:57:39.000000000 -0500
|
||||
+++ test/testharness.h 2017-01-17 15:46:38.623298000 -0500
|
||||
@@ -69,5 +69,5 @@
|
||||
#elif HAVE_RDTSC
|
||||
#include <intrin.h>
|
||||
-#elif defined(__GNUC__)
|
||||
+#elif defined(__GNUC__) && (!defined(__clang__) || __clang_major__ < 4)
|
||||
/* fallback for older GCC/MinGW */
|
||||
static inline uint32_t __rdtsc(void)
|
|
@ -3,5 +3,5 @@ include/x265.h
|
|||
include/x265_config.h
|
||||
lib/libx265.a
|
||||
lib/libx265.so
|
||||
lib/libx265.so.146
|
||||
lib/libx265.so.160
|
||||
libdata/pkgconfig/x265.pc
|
||||
|
|
Loading…
Reference in a new issue