Update to 0.0.5, based on spandsp-devel5, that will be removed

This commit is contained in:
Renato Botelho 2010-08-31 17:26:07 +00:00
parent 4d6ef4096a
commit f54e9047e7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=260293
10 changed files with 20 additions and 105 deletions

View file

@ -6,30 +6,29 @@
#
PORTNAME= spandsp
DISTVERSION= 0.0.3
PORTREVISION= 2
PORTVERSION= 0.0.5
CATEGORIES= comms
MASTER_SITES= http://www.soft-switch.org/downloads/spandsp/ \
http://www.soft-switch.org/downloads/spandsp/old/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Fax DSP library for Asterisk
COMMENT= A DSP library and software FAX machine
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/pre.*$//}
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
post-patch:
@${FIND} ${WRKSRC} -name *.c | ${XARGS} ${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|'
CONFLICTS= spandsp-devel-[0-9]*
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (spandsp-0.0.3.tgz) = 6ea33941985fbf94b5f79dc3255ad925
SHA256 (spandsp-0.0.3.tgz) = 368467b757736aef99e19f68e4ed50012b555ef18445b4ad7e47da8c1c353118
SIZE (spandsp-0.0.3.tgz) = 1667197
MD5 (spandsp-0.0.5.tgz) = fe83ed37a7831f0dd38e7ef4e7e6fd9e
SHA256 (spandsp-0.0.5.tgz) = 07f42a237c77b08fa765c3a148c83cdfa267bf24c0ab681d80b90d30dd0b3dbf
SIZE (spandsp-0.0.5.tgz) = 2506742

View file

@ -1,14 +0,0 @@
--- src/Makefile.in.orig Sat Mar 31 08:39:20 2007
+++ src/Makefile.in Fri Jul 20 11:50:18 2007
@@ -213,9 +213,9 @@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-AM_CFLAGS = $(COMP_VENDOR_CFLAGS)
+#AM_CFLAGS = $(COMP_VENDOR_CFLAGS)
MAINTAINERCLEANFILES = Makefile.in
-INCLUDES = -I$(top_builddir)
+#INCLUDES = -I$(top_builddir)
lib_LTLIBRARIES = libspandsp.la
libspandsp_la_SOURCES = adsi.c \
async.c \

View file

@ -1,10 +0,0 @@
--- src/playout.c~ Fri Feb 4 14:19:30 2005
+++ src/playout.c Thu Jun 23 15:35:06 2005
@@ -37,6 +37,7 @@
#include <stdlib.h>
#include <string.h>
#include <limits.h>
+#include <sys/types.h>
#include "spandsp/telephony.h"
#include "spandsp/playout.h"

View file

@ -1,17 +0,0 @@
$FreeBSD$
--- src/spandsp/dc_restore.h.orig
+++ src/spandsp/dc_restore.h
@@ -53,6 +53,11 @@
clean_sample = sample - (dc_bias >> 15);
*/
+#ifndef INT16_MAX
+#define INT16_MAX 0x7fff
+#define INT16_MIN (-0x7fff-1)
+#endif
+
/*!
Zero DC restoration descriptor. This defines the working state for a single
instance of DC content filter.

View file

@ -1,15 +0,0 @@
--- src/awgn.c.orig Sun Nov 19 09:07:24 2006
+++ src/awgn.c Fri Jul 20 11:59:50 2007
@@ -48,12 +48,8 @@
#include <stdlib.h>
#include <inttypes.h>
-#if defined(HAVE_TGMATH_H)
#include <tgmath.h>
-#endif
-#if defined(HAVE_MATH_H)
#include <math.h>
-#endif
#include "spandsp/telephony.h"
#include "spandsp/dc_restore.h"

View file

@ -1,15 +0,0 @@
--- src/tone_generate.c.orig Sat Mar 3 05:40:33 2007
+++ src/tone_generate.c Fri Jul 20 12:03:07 2007
@@ -37,12 +37,8 @@
#include <stdio.h>
#include <time.h>
#include <fcntl.h>
-#if defined(HAVE_TGMATH_H)
#include <tgmath.h>
-#endif
-#if defined(HAVE_MATH_H)
#include <math.h>
-#endif
#include "spandsp/telephony.h"
#include "spandsp/dc_restore.h"

View file

@ -1,15 +0,0 @@
--- src/v17tx.c.orig Sun Mar 18 05:43:50 2007
+++ src/v17tx.c Fri Jul 20 12:05:16 2007
@@ -35,12 +35,8 @@
#include <inttypes.h>
#include <stdlib.h>
#include <string.h>
-#if defined(HAVE_TGMATH_H)
#include <tgmath.h>
-#endif
-#if defined(HAVE_MATH_H)
#include <math.h>
-#endif
#include "spandsp/telephony.h"
#include "spandsp/logging.h"

View file

@ -1,4 +1,5 @@
Spandsp is a DSP library to support fax functions in the Asterisk PBX.
Basically it implements a software fax machine to fax out or in.
Spandsp is a DSP library for telephony and fax functions. It
basically, also implements a complete software fax machine to
send and, or receive messages.
WWW: http://www.soft-switch.org/

View file

@ -12,6 +12,7 @@ include/spandsp/bitstream.h
include/spandsp/complex.h
include/spandsp/complex_filters.h
include/spandsp/complex_vector_float.h
include/spandsp/crc.h
include/spandsp/dc_restore.h
include/spandsp/dds.h
include/spandsp/dtmf.h
@ -41,6 +42,8 @@ include/spandsp/sig_tone.h
include/spandsp/silence_gen.h
include/spandsp/super_tone_rx.h
include/spandsp/super_tone_tx.h
include/spandsp/t30_api.h
include/spandsp/t30_logging.h
include/spandsp/t30.h
include/spandsp/t30_fcf.h
include/spandsp/t31.h
@ -66,11 +69,9 @@ include/spandsp/v42bis.h
include/spandsp/v8.h
include/spandsp/vector_float.h
include/spandsp/vector_int.h
include/spandsp/version.h
lib/libspandsp.a
lib/libspandsp.la
lib/libspandsp.so
lib/libspandsp.so.0
%%DATADIR%%/global-tones.xml
%%DATADIR%%/tones.dtd
@dirrm %%DATADIR%%
lib/libspandsp.so.1
@dirrm include/spandsp