Update otter-browser to beta 5

Additional to the changes made by otter's upstream development, this
commit also addresses otter being incompletely installed by the
current port/package.

Approved by:	rakuco (mentor)
Differential:	https://reviews.freebsd.org/D2361
This commit is contained in:
Alonso Schaich 2015-05-08 16:30:29 +00:00
parent 5061ae835b
commit f59db108d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=385795
4 changed files with 76 additions and 25 deletions

View file

@ -1,30 +1,24 @@
# $FreeBSD$
PORTNAME= otter
PORTVERSION= 0.9.03
DISTVERSIONPREFIX= v
PORTVERSION= 0.9.05
CATEGORIES= www
# Avoid pkgname conflict with misc/otter
PKGNAMESUFFIX= -browser
DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Browser based on Qt 5
USE_QT5= concurrent core gui network printsupport qmake_build script \
sql webkit widgets buildtools_build
USE_QT5= concurrent core gui multimedia network printsupport \
script sql webkit widgets \
buildtools_build qmake_build
USES= cmake:outsource desktop-file-utils
USE_GITHUB= yes
GH_ACCOUNT= Emdek
GH_ACCOUNT= OtterBrowser
GH_PROJECT= otter-browser
PLIST_FILES= bin/otter-browser \
share/applications/otter-browser.desktop
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/otter-browser \
${STAGEDIR}/${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/otter-browser.desktop \
${STAGEDIR}/${DESKTOPDIR}
GH_TAGNAME= v${PORTVERSION}
GH_COMMIT= c1819f1
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (Emdek-otter-browser-v0.9.03_GH0.tar.gz) = a08327e916e7fe93f2fca2f162522b8b591b11149d8b530f7a82f89210531109
SIZE (Emdek-otter-browser-v0.9.03_GH0.tar.gz) = 1497199
SHA256 (otter-v0.9.05.tar.gz) = 7ac825d061a0c55eb7b9c398e037da98521c62a2b2627ecca382ad239bc9bbed
SIZE (otter-v0.9.05.tar.gz) = 2302456

View file

@ -1,10 +1,21 @@
--- CMakeLists.txt.orig 2014-11-01 22:44:51.000000000 +0100
+++ CMakeLists.txt 2014-11-17 16:36:54.938559771 +0100
@@ -54,6 +54,7 @@
set(CMAKE_AUTOMOC ON)
--- CMakeLists.txt.orig 2015-04-01 19:43:12 UTC
+++ CMakeLists.txt
@@ -71,9 +71,9 @@ endif (MSVC)
option(EnableQtwebengine "Enable QtWebEngine backend (requires Qt 5.4)" OFF)
find_package(Qt5Core REQUIRED)
+find_package(Qt5Concurrent REQUIRED)
find_package(Qt5Network REQUIRED)
find_package(Qt5PrintSupport REQUIRED)
find_package(Qt5Script REQUIRED)
if (${EnableQtwebengine})
- find_package(Qt5 5.4.0 REQUIRED COMPONENTS Core Gui Multimedia Network PrintSupport Script Sql WebEngine WebEngineWidgets WebKit WebKitWidgets Widgets)
+ find_package(Qt5 5.4.0 REQUIRED COMPONENTS Concurrent Core Gui Multimedia Network PrintSupport Script Sql WebEngine WebEngineWidgets WebKit WebKitWidgets Widgets)
else (${EnableQtwebengine})
- find_package(Qt5 5.2.0 REQUIRED COMPONENTS Core Gui Multimedia Network PrintSupport Script Sql WebKit WebKitWidgets Widgets)
+ find_package(Qt5 5.2.0 REQUIRED COMPONENTS Concurrent Core Gui Multimedia Network PrintSupport Script Sql WebKit WebKitWidgets Widgets)
endif (${EnableQtwebengine})
set(otter_src
@@ -311,5 +311,5 @@ install(FILES resources/icons/otter-brow
install(FILES resources/icons/otter-browser-128.png DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/128x128/apps/ RENAME otter-browser.png)
install(FILES resources/icons/otter-browser-256.png DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/256x256/apps/ RENAME otter-browser.png)
install(FILES otter-browser.desktop DESTINATION ${XDG_APPS_INSTALL_DIR})
-install(FILES man/otter-browser.1 DESTINATION share/man/man1/)
+install(FILES man/otter-browser.1 DESTINATION man/man1/)
install(TARGETS otter-browser DESTINATION bin/)

View file

@ -0,0 +1,46 @@
bin/otter-browser
man/man1/otter-browser.1.gz
share/applications/otter-browser.desktop
share/icons/hicolor/128x128/apps/otter-browser.png
share/icons/hicolor/16x16/apps/otter-browser.png
share/icons/hicolor/256x256/apps/otter-browser.png
share/icons/hicolor/32x32/apps/otter-browser.png
share/icons/hicolor/48x48/apps/otter-browser.png
share/icons/hicolor/64x64/apps/otter-browser.png
share/otter-browser/locale/otter-browser_ca_ES.qm
share/otter-browser/locale/otter-browser_cs_CZ.qm
share/otter-browser/locale/otter-browser_da.qm
share/otter-browser/locale/otter-browser_de_DE.qm
share/otter-browser/locale/otter-browser_el.qm
share/otter-browser/locale/otter-browser_en_CA.qm
share/otter-browser/locale/otter-browser_en_GB.qm
share/otter-browser/locale/otter-browser_en_US.qm
share/otter-browser/locale/otter-browser_es_ES.qm
share/otter-browser/locale/otter-browser_es_MX.qm
share/otter-browser/locale/otter-browser_et.qm
share/otter-browser/locale/otter-browser_fi.qm
share/otter-browser/locale/otter-browser_fr_CA.qm
share/otter-browser/locale/otter-browser_fr_FR.qm
share/otter-browser/locale/otter-browser_hu.qm
share/otter-browser/locale/otter-browser_id_ID.qm
share/otter-browser/locale/otter-browser_it_IT.qm
share/otter-browser/locale/otter-browser_ja_JP.qm
share/otter-browser/locale/otter-browser_ka_GE.qm
share/otter-browser/locale/otter-browser_lt.qm
share/otter-browser/locale/otter-browser_nb_NO.qm
share/otter-browser/locale/otter-browser_nl.qm
share/otter-browser/locale/otter-browser_pl_PL.qm
share/otter-browser/locale/otter-browser_pt_BR.qm
share/otter-browser/locale/otter-browser_pt_PT.qm
share/otter-browser/locale/otter-browser_ro.qm
share/otter-browser/locale/otter-browser_ru_RU.qm
share/otter-browser/locale/otter-browser_sk.qm
share/otter-browser/locale/otter-browser_sl_SI.qm
share/otter-browser/locale/otter-browser_sr.qm
share/otter-browser/locale/otter-browser_sr@Ijekavian.qm
share/otter-browser/locale/otter-browser_sr@ijekavianlatin.qm
share/otter-browser/locale/otter-browser_sr@latin.qm
share/otter-browser/locale/otter-browser_tr_TR.qm
share/otter-browser/locale/otter-browser_uk_UA.qm
share/otter-browser/locale/otter-browser_zh_CN.qm
share/otter-browser/locale/otter-browser_zh_TW.qm