Update to 2.11.0 release:
- switch to binary distribution - general cleanup of port Makefile - take maintainership [1] Approved by: maintainer [1]
This commit is contained in:
parent
5d63115c09
commit
f5c1ec3abf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=266334
4 changed files with 21 additions and 136 deletions
|
@ -6,99 +6,46 @@
|
|||
#
|
||||
|
||||
PORTNAME= xerces-j
|
||||
PORTVERSION= 2.9.1
|
||||
PORTVERSION= 2.11.0
|
||||
CATEGORIES= textproc java
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE}
|
||||
MASTER_SITE_SUBDIR= xerces/j
|
||||
DISTFILES= Xerces-J-src.${PORTVERSION}${EXTRACT_SUFX} Xerces-J-tools.${PORTVERSION}${EXTRACT_SUFX}
|
||||
DISTNAME= Xerces-J-bin.${PORTVERSION}
|
||||
|
||||
MAINTAINER= hq@FreeBSD.org
|
||||
MAINTAINER= ale@FreeBSD.org
|
||||
COMMENT= XML parser for Java
|
||||
|
||||
CONFLICTS= xml4j-4.*
|
||||
|
||||
USE_JAVA= yes
|
||||
JAVA_VERSION= 1.3+
|
||||
USE_ANT= yes
|
||||
USE_JIKES= no
|
||||
NO_BUILD= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/xerces-${PORTVERSION:S/./_/g}
|
||||
|
||||
OPTIONS= DEPRECATED_JARS "build/install the deprecated JARs" on \
|
||||
SAMPLES "build/install the samples" on
|
||||
|
||||
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
ALL_TARGET= jars
|
||||
.if !defined(NOPORTDOCS)
|
||||
ALL_TARGET+= javadocs
|
||||
.if ${JAVA_PORT_VERSION:C/[0-9]\.([0-9])\.[0-9]/\1/} == "5"
|
||||
ALL_TARGET+= docs
|
||||
.endif
|
||||
PORTDOCS= *
|
||||
.endif
|
||||
PORTEXAMPLES= *
|
||||
|
||||
JARFILES+= xercesImpl.jar xml-apis.jar
|
||||
.if !defined(WITHOUT_DEPRECATED_JARS)
|
||||
ALL_TARGET+= deprecatedjars
|
||||
DEPRECATED_JARFILES= xerces.jar xercesSamples.jar
|
||||
PLIST_FILES+= ${DEPRECATED_JARFILES:S,^,%%DATADIR%%/deprecated/,}
|
||||
PLIST_DIRS+= %%DATADIR%%/deprecated %%DATADIR%%
|
||||
.endif
|
||||
JARFILES= xercesImpl.jar xml-apis.jar
|
||||
|
||||
PLIST_FILES+= ${JARFILES:S,^,%%JAVAJARDIR%%/,}
|
||||
|
||||
TOOLS_JARFILES= resolver.jar stylebook-1.0-b2.jar bin/xjavac.jar
|
||||
CLASSPATH!= ${ECHO_CMD} ${TOOLS_JARFILES:S,^,tools/,} | ${TR} " " ":"
|
||||
MAKE_ENV= CLASSPATH=${CLASSPATH}
|
||||
|
||||
JAVA_PORT_API= ${LOCALBASE}/share/doc/jdk${JAVA_PORT_VERSION:C/([0-9]\.[0-9])\.[0-9]/\1/}/api
|
||||
.if exists(${JAVA_PORT_API})
|
||||
MAKE_ARGS+= -Djdk.api="${JAVA_PORT_API}"
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
@cd ${WRKSRC} && ${MV} ../tools .
|
||||
PLIST_FILES= ${JARFILES:S,^,%%JAVAJARDIR%%/,}
|
||||
|
||||
do-install:
|
||||
@${ECHO_MSG} -n ">> Installing JAR files in ${JAVAJARDIR}..."
|
||||
.for JARFILE in ${JARFILES}
|
||||
@cd ${WRKSRC}/build && ${INSTALL_DATA} ${JARFILE} ${JAVAJARDIR}/${JARFILE}
|
||||
@cd ${WRKSRC} && ${INSTALL_DATA} ${JARFILE} ${JAVAJARDIR}/${JARFILE}
|
||||
@${ECHO_MSG} -n " ${JARFILE}"
|
||||
.endfor
|
||||
@${ECHO_MSG} " [ DONE ]"
|
||||
.if !defined(WITHOUT_DEPRECATED_JARS)
|
||||
@${ECHO_MSG} -n ">> Installing deprecated JAR files in ${DATADIR}/deprecated/..."
|
||||
@${MKDIR} ${DATADIR}/deprecated
|
||||
.for JARFILE in ${DEPRECATED_JARFILES}
|
||||
@cd ${WRKSRC}/build && ${INSTALL_DATA} ${JARFILE} ${DATADIR}/deprecated/${JARFILE}
|
||||
@${ECHO_MSG} -n " ${JARFILE}"
|
||||
.endfor
|
||||
@${ECHO_MSG} " [ DONE ]"
|
||||
.endif
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
|
||||
@cd ${WRKSRC}/build/docs/ && \
|
||||
${FIND} . -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
|
||||
${FIND} . -not -type d -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} \* ${DOCSDIR})
|
||||
@${ECHO_MSG} " [ DONE ]"
|
||||
.endif
|
||||
.if !defined(WITHOUT_SAMPLES)
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
@${ECHO_MSG} -n ">> Installing samples in ${EXAMPLESDIR}..."
|
||||
@cd ${WRKSRC}/samples && \
|
||||
${FIND} . -type d -exec ${MKDIR} "${EXAMPLESDIR}/{}" \; && \
|
||||
${FIND} . -not -type d -exec ${INSTALL_DATA} "{}" "${EXAMPLESDIR}/{}" \;
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "data samples" ${EXAMPLESDIR})
|
||||
@${ECHO_MSG} " [ DONE ]"
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_SAMPLES)
|
||||
post-install:
|
||||
@${FIND} -s ${WRKSRC}/samples -not -type d | \
|
||||
${SED} -ne 's,^${WRKSRC}/samples,${EXAMPLESDIR:S,${PREFIX}/,,},p' >> ${TMPPLIST}
|
||||
@${FIND} -s -d ${WRKSRC}/samples -type d | \
|
||||
${SED} -ne 's,^${WRKSRC}/samples,@dirrm ${EXAMPLESDIR:S,${PREFIX}/,,},p' >> ${TMPPLIST}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,2 @@
|
|||
MD5 (Xerces-J-src.2.9.1.tar.gz) = e340cba4a2abf4f0f833488380821153
|
||||
SHA256 (Xerces-J-src.2.9.1.tar.gz) = 13af0062a72a4a0d541ca5336391eafa4d580258cacf4a5e062ea584ca950592
|
||||
SIZE (Xerces-J-src.2.9.1.tar.gz) = 1711507
|
||||
MD5 (Xerces-J-tools.2.9.1.tar.gz) = 6b50c65f2c31d66bb258aa5be79b0e21
|
||||
SHA256 (Xerces-J-tools.2.9.1.tar.gz) = 4cf1382d630e59925a1d290510532543b5b9d2e149732d38dac3012f63c2ebff
|
||||
SIZE (Xerces-J-tools.2.9.1.tar.gz) = 4379682
|
||||
SHA256 (Xerces-J-bin.2.11.0.tar.gz) = 69cfcf1a4fa3562417152b0a5c5800d7d2b7dbb6b59fb2d3ce353dac592a443b
|
||||
SIZE (Xerces-J-bin.2.11.0.tar.gz) = 5195434
|
||||
|
|
|
@ -1,61 +0,0 @@
|
|||
Allows to enforce a packagelistLoc for JDK API documentation
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- build.xml.orig Thu Nov 24 16:57:51 2005
|
||||
+++ build.xml Thu Nov 24 17:19:25 2005
|
||||
@@ -402,7 +402,9 @@
|
||||
windowtitle='XML Standard API' doctitle='XML Standard API'
|
||||
bottom='${copyright}'
|
||||
additionalparam='${additional.param}'
|
||||
- />
|
||||
+ >
|
||||
+ <link offline="true" packagelistLoc="${jdk.api}" href="${jdk.api}"/>
|
||||
+ </javadoc>
|
||||
<mkdir dir='${build.dir}/docs/javadocs/xni'/>
|
||||
<javadoc packagenames='org.apache.xerces.xni.*'
|
||||
locale='en_US'
|
||||
@@ -412,7 +414,9 @@
|
||||
doctitle='Xerces Native Interface'
|
||||
bottom='${copyright}'
|
||||
additionalparam='${additional.param}'
|
||||
- />
|
||||
+ >
|
||||
+ <link offline="true" packagelistLoc="${jdk.api}" href="${jdk.api}"/>
|
||||
+ </javadoc>
|
||||
<mkdir dir='${build.dir}/docs/javadocs/xs'/>
|
||||
<javadoc packagenames='org.apache.xerces.xs, org.apache.xerces.xs.datatypes'
|
||||
locale='en_US'
|
||||
@@ -422,7 +426,9 @@
|
||||
doctitle='XML Schema API'
|
||||
bottom='${copyright}'
|
||||
additionalparam='${additional.param}'
|
||||
- />
|
||||
+ >
|
||||
+ <link offline="true" packagelistLoc="${jdk.api}" href="${jdk.api}"/>
|
||||
+ </javadoc>
|
||||
|
||||
<mkdir dir='${build.dir}/docs/javadocs/xerces2'/>
|
||||
<javadoc packagenames='org.apache.xerces.dom.*,
|
||||
@@ -440,7 +446,9 @@
|
||||
doctitle='Xerces2 Implementation'
|
||||
bottom='${copyright}'
|
||||
additionalparam='${additional.param}'
|
||||
- />
|
||||
+ >
|
||||
+ <link offline="true" packagelistLoc="${jdk.api}" href="${jdk.api}"/>
|
||||
+ </javadoc>
|
||||
<mkdir dir='${build.dir}/docs/javadocs/other'/>
|
||||
<javadoc packagenames='org.apache.html.*,
|
||||
org.apache.wml.*,
|
||||
@@ -451,7 +459,9 @@
|
||||
windowtitle='Other Classes' doctitle='Other Classes'
|
||||
bottom='${copyright}'
|
||||
additionalparam='${additional.param}'
|
||||
- />
|
||||
+ >
|
||||
+ <link offline="true" packagelistLoc="${jdk.api}" href="${jdk.api}"/>
|
||||
+ </javadoc>
|
||||
</target>
|
||||
|
||||
<!-- =================================================================== -->
|
|
@ -1,5 +1,5 @@
|
|||
The Xerces Java Parser is a complete implementation of the parser related
|
||||
portions of JAXP 1.3 and also brings Xerces into compliance with SAX 2.0.2, the
|
||||
portions of JAXP 1.4 and also brings Xerces into compliance with SAX 2.0.2, the
|
||||
DOM Level 3 Core and Load/Save W3C Recommendations, the XML Inclusions
|
||||
(XInclude) Version 1.0 W3C Recommendation and the XML Schema 1.0 Structures and
|
||||
Datatypes Second Edition W3C Recommendations.
|
||||
|
@ -13,4 +13,7 @@ The Apache Xerces2 parser is the reference implementation of XNI but other
|
|||
parser components, configurations, and parsers can be written using the Xerces
|
||||
Native Interface.
|
||||
|
||||
WWW: http://xml.apache.org/xerces2-j/
|
||||
WWW: http://xerces.apache.org/xerces2-j/
|
||||
|
||||
- Alex Dupre
|
||||
ale@FreeBSD.org
|
||||
|
|
Loading…
Reference in a new issue