For ARMv6, declare FPSETMASK 0 and FEDISABLEEXCEPT 1. This allows mysql server to
build on ARMv6. No need to bump portrevision for everyone else here as this only affects ARM users. PR: 195750 Submitted by: mikael.urankar@gmail.com Approved by: mentor (implicit)
This commit is contained in:
parent
3c576aed66
commit
f5f737f97e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=376033
4 changed files with 38 additions and 2 deletions
|
@ -85,4 +85,10 @@ CMAKE_ARGS+= -DWITH_EMBEDDED_SERVER="ON"
|
|||
post-patch:
|
||||
@${REINPLACE_CMD} 's/*.1/${MMAN1}/' ${WRKSRC}/man/CMakeLists.txt
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "armv6"
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config.h.cmake
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
12
databases/mysql55-server/files/extra-patch-config.h.cmake
Normal file
12
databases/mysql55-server/files/extra-patch-config.h.cmake
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- config.h.cmake.orig 2014-12-05 16:24:02 UTC
|
||||
+++ config.h.cmake
|
||||
@@ -151,7 +151,8 @@
|
||||
#cmakedefine HAVE_FESETROUND 1
|
||||
#cmakedefine HAVE_FINITE 1
|
||||
#cmakedefine HAVE_FP_EXCEPT 1
|
||||
-#cmakedefine HAVE_FPSETMASK 1
|
||||
+#cmakedefine HAVE_FPSETMASK 0
|
||||
+#cmakedefine HAVE_FEDISABLEEXCEPT 1
|
||||
#cmakedefine HAVE_FSEEKO 1
|
||||
#cmakedefine HAVE_FSYNC 1
|
||||
#cmakedefine HAVE_FTIME 1
|
|
@ -71,4 +71,10 @@ USES+= readline
|
|||
post-patch:
|
||||
@${REINPLACE_CMD} 's/*.1/${MMAN1}/' ${WRKSRC}/man/CMakeLists.txt
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "armv6"
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config.h.cmake
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
12
databases/mysql56-server/files/extra-patch-config.h.cmake
Normal file
12
databases/mysql56-server/files/extra-patch-config.h.cmake
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- config.h.cmake.orig 2014-12-05 16:24:02 UTC
|
||||
+++ config.h.cmake
|
||||
@@ -151,7 +151,8 @@
|
||||
#cmakedefine HAVE_FESETROUND 1
|
||||
#cmakedefine HAVE_FINITE 1
|
||||
#cmakedefine HAVE_FP_EXCEPT 1
|
||||
-#cmakedefine HAVE_FPSETMASK 1
|
||||
+#cmakedefine HAVE_FPSETMASK 0
|
||||
+#cmakedefine HAVE_FEDISABLEEXCEPT 1
|
||||
#cmakedefine HAVE_FSEEKO 1
|
||||
#cmakedefine HAVE_FSYNC 1
|
||||
#cmakedefine HAVE_FTIME 1
|
Loading…
Reference in a new issue