upgrade to v 1.2

Submitted by: Philippe Charnier <charnier@xp11.frmug.org>,
              with minor mods by me
This commit is contained in:
Eric L. Hernes 1996-12-09 15:37:29 +00:00
parent 6f6ac99c4b
commit f617349ad3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=4910
10 changed files with 64 additions and 38 deletions

View file

@ -1,15 +1,15 @@
# New ports collection makefile for: mpeg2codec
# Version required: 1.1a
# Date created: June 21, 1996
# Version required: 1.2
# Date created: November 25, 1996
# Whom: "Philippe Charnier" <charnier@lirmm.fr>
#
# $Id: Makefile,v 1.1.1.1 1996/07/10 05:32:53 asami Exp $
# $Id: Makefile,v 1.2 1996/11/18 11:28:25 asami Exp $
#
DISTNAME= mpeg2codec-1.1a
DISTNAME= mpeg2codec-1.2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.netcom.com/pub/cf/cfogg/mpeg2/
DISTFILES= mpeg2codec_v1.1a.tar.gz
MASTER_SITES= ftp://ftp.mpeg.org/pub/mpeg/mssg/
DISTFILES= mpeg2vidcodec_v12.tar.gz
MAINTAINER= charnier@lirmm.fr
@ -21,5 +21,8 @@ do-install:
${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
${WRKSRC}/src/mpeg2${i}/mpeg2${i}ode ${PREFIX}/bin
.endfor
${MKDIR} -p ${PREFIX}/share/mpeg2
${CP} ${WRKSRC}/doc/mpeg2enc.doc ${PREFIX}/share/mpeg2
${CP} ${WRKSRC}/par/* ${PREFIX}/share/mpeg2
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (mpeg2codec_v1.1a.tar.gz) = 83eda281bac437f52e38977d4df065b6
MD5 (mpeg2vidcodec_v12.tar.gz) = 4a66565979be0818bd8a41d948943451

View file

@ -1,13 +1,12 @@
--- Makefile 1996/06/18 18:44:04 1.1
+++ Makefile 1996/06/18 19:46:05
@@ -30,23 +30,23 @@
--- Makefile 1996/11/25 19:40:19 1.1
+++ Makefile 1996/11/25 21:33:39
@@ -30,31 +30,31 @@
# uncomment the following two lines if you want to include X11 support
# (mpeg2decode)
-#USE_DISP = -DDISPLAY
-#LIBS = -lX11
+USE_DISP = -DDISPLAY
+LIBS = -lX11
#LIBS = -lX11
# uncomment the following two lines if you want to use shared memory
# (faster display if server and client run on the same machine)
@ -30,12 +29,13 @@
# select one of the following CC CFLAGS settings
@@ -54,7 +54,7 @@
#
# GNU gcc
#
CC = gcc
-CC = gcc
-CFLAGS = -O2
+CC = cc
+CFLAGS = -O2 -m486
#
# SPARCworks acc
all: mpeg2decode mpeg2encode

View file

@ -1,5 +1,5 @@
--- src/mpeg2enc/mpeg2enc.c 1996/06/20 19:58:58 1.1
+++ src/mpeg2enc/mpeg2enc.c 1996/06/20 19:36:25
--- ./src/mpeg2enc/mpeg2enc.c 1996/11/25 21:18:23 1.1
+++ ./src/mpeg2enc/mpeg2enc.c 1996/11/25 21:22:40
@@ -29,6 +29,7 @@
#include <stdio.h>
@ -8,11 +8,15 @@
#define GLOBAL /* used by global.h */
#include "config.h"
@@ -50,6 +51,8 @@
@@ -50,6 +51,12 @@
printf("Usage: mpeg2encode in.par out.m2v\n");
exit(0);
}
+
+ /*
+ * this prevents a floating point exception in calcSNR (stats.c) when
+ * working on black and white images (charnier@lirmm.fr)
+ */
+ fpsetmask(0);
/* read parameter file */

View file

@ -1,2 +1,8 @@
bin/mpeg2encode
bin/mpeg2decode
share/mpeg2/mpeg2enc.doc
share/mpeg2/MPEG-1.par
share/mpeg2/NTSC.par
share/mpeg2/PAL.par
share/mpeg2/inter.mat
share/mpeg2/intra.mat

View file

@ -1,15 +1,15 @@
# New ports collection makefile for: mpeg2codec
# Version required: 1.1a
# Date created: June 21, 1996
# Version required: 1.2
# Date created: November 25, 1996
# Whom: "Philippe Charnier" <charnier@lirmm.fr>
#
# $Id: Makefile,v 1.1.1.1 1996/07/10 05:32:53 asami Exp $
# $Id: Makefile,v 1.2 1996/11/18 11:28:25 asami Exp $
#
DISTNAME= mpeg2codec-1.1a
DISTNAME= mpeg2codec-1.2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.netcom.com/pub/cf/cfogg/mpeg2/
DISTFILES= mpeg2codec_v1.1a.tar.gz
MASTER_SITES= ftp://ftp.mpeg.org/pub/mpeg/mssg/
DISTFILES= mpeg2vidcodec_v12.tar.gz
MAINTAINER= charnier@lirmm.fr
@ -21,5 +21,8 @@ do-install:
${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
${WRKSRC}/src/mpeg2${i}/mpeg2${i}ode ${PREFIX}/bin
.endfor
${MKDIR} -p ${PREFIX}/share/mpeg2
${CP} ${WRKSRC}/doc/mpeg2enc.doc ${PREFIX}/share/mpeg2
${CP} ${WRKSRC}/par/* ${PREFIX}/share/mpeg2
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (mpeg2codec_v1.1a.tar.gz) = 83eda281bac437f52e38977d4df065b6
MD5 (mpeg2vidcodec_v12.tar.gz) = 4a66565979be0818bd8a41d948943451

View file

@ -1,13 +1,12 @@
--- Makefile 1996/06/18 18:44:04 1.1
+++ Makefile 1996/06/18 19:46:05
@@ -30,23 +30,23 @@
--- Makefile 1996/11/25 19:40:19 1.1
+++ Makefile 1996/11/25 21:33:39
@@ -30,31 +30,31 @@
# uncomment the following two lines if you want to include X11 support
# (mpeg2decode)
-#USE_DISP = -DDISPLAY
-#LIBS = -lX11
+USE_DISP = -DDISPLAY
+LIBS = -lX11
#LIBS = -lX11
# uncomment the following two lines if you want to use shared memory
# (faster display if server and client run on the same machine)
@ -30,12 +29,13 @@
# select one of the following CC CFLAGS settings
@@ -54,7 +54,7 @@
#
# GNU gcc
#
CC = gcc
-CC = gcc
-CFLAGS = -O2
+CC = cc
+CFLAGS = -O2 -m486
#
# SPARCworks acc
all: mpeg2decode mpeg2encode

View file

@ -1,5 +1,5 @@
--- src/mpeg2enc/mpeg2enc.c 1996/06/20 19:58:58 1.1
+++ src/mpeg2enc/mpeg2enc.c 1996/06/20 19:36:25
--- ./src/mpeg2enc/mpeg2enc.c 1996/11/25 21:18:23 1.1
+++ ./src/mpeg2enc/mpeg2enc.c 1996/11/25 21:22:40
@@ -29,6 +29,7 @@
#include <stdio.h>
@ -8,11 +8,15 @@
#define GLOBAL /* used by global.h */
#include "config.h"
@@ -50,6 +51,8 @@
@@ -50,6 +51,12 @@
printf("Usage: mpeg2encode in.par out.m2v\n");
exit(0);
}
+
+ /*
+ * this prevents a floating point exception in calcSNR (stats.c) when
+ * working on black and white images (charnier@lirmm.fr)
+ */
+ fpsetmask(0);
/* read parameter file */

View file

@ -1,2 +1,8 @@
bin/mpeg2encode
bin/mpeg2decode
share/mpeg2/mpeg2enc.doc
share/mpeg2/MPEG-1.par
share/mpeg2/NTSC.par
share/mpeg2/PAL.par
share/mpeg2/inter.mat
share/mpeg2/intra.mat