Use ports libtool instead of the included one. This should fix building

on 7.0-CURRENT.

Notified by:	kris (pointyhat)
This commit is contained in:
Christian Weisgerber 2007-03-27 23:47:50 +00:00
parent 0c7b5c2581
commit f630b1a36e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188603
3 changed files with 12 additions and 11 deletions

View file

@ -20,7 +20,7 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
FLAC.7:${PORTSDIR}/audio/flac
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}" \
--with-xmms-prefix="${X11BASE}"
@ -33,6 +33,6 @@ post-configure:
# XXX
post-install:
@${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la
${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la
.include <bsd.port.mk>

View file

@ -3,15 +3,7 @@ $FreeBSD$
--- configure.orig
+++ configure
@@ -7976,6 +7976,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -10541,9 +10542,9 @@
@@ -10541,9 +10541,9 @@
if test x$debug = xtrue; then
OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -g -O0 -DDEBUG"
else

View file

@ -13,6 +13,15 @@ $FreeBSD$
am__objects_1 = charset.lo configure.lo fileinfo.lo http.lo plugin.lo \
tag.lo
am_libxmms_flac_la_OBJECTS = $(am__objects_1)
@@ -189,7 +188,7 @@
LIBS = @LIBS@
# Don't build a static library
-LIBTOOL = $(top_builddir)/libtool-disable-static
+LIBTOOL = @LIBTOOL@ --tag=disable-static
LN_S = @LN_S@
LTLIBICONV = @LTLIBICONV@
LTLIBOBJS = @LTLIBOBJS@
@@ -296,8 +295,7 @@
$(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
$(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \