- Upgrade to 1.2.3.

- Use external libtiff.
- Unmark FORBIDDEN.
- Unmark BROKEN since it seems to work on FreeBSD 6.X+ and !i386 now
  (at least the platforms I could test).

Initial upgrade work by:	fenner
This commit is contained in:
Simon L. B. Nielsen 2006-04-14 17:38:45 +00:00
parent 213b16a3dc
commit f663d9082e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159499
32 changed files with 456 additions and 120 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= ivtools
PORTVERSION= 1.2.1
PORTREVISION= 1
PORTVERSION= 1.2.3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -16,26 +15,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Drawing editors derived from idraw
FORBIDDEN= http://vuxml.FreeBSD.org/pkg-ivtools.html
BUILD_DEPENDS= imake:${X_IMAKE_PORT}
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
USE_XLIB= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:259
CONFIGURE_ARGS= --with-tiff=${PREFIX}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
INSTALLS_SHLIB= yes
USE_GNAKE= yes
MAKE_ARGS= ARCH=FREEBSD
MANCOMPRESSED= no
MAN1= idraw.1 iclass.1 drawtool.1 comterp.1 comdraw.1 flipbook.1 graphdraw.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
.if ${ARCH} != "i386"
BROKEN= "fails to configure on ${ARCH}"
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (ivtools-1.2.1.tgz) = 42235814450be55f489843f203383c0c
SHA256 (ivtools-1.2.1.tgz) = d699c7bba5a85b2bfb32895ad3a6df533ad94148843a98f6e4bfbd42a9279494
SIZE (ivtools-1.2.1.tgz) = 2135750
MD5 (ivtools-1.2.3.tgz) = aa35433e5e30f0215d6a563ff2edffbc
SHA256 (ivtools-1.2.3.tgz) = 2e201fd499646012611f15f220b15a7306bd013c830a9d6230cf9d7e6fa29fb1
SIZE (ivtools-1.2.3.tgz) = 2137349

View file

@ -1,76 +0,0 @@
--- config/rules.def.orig Thu Jul 15 17:05:32 2004
+++ config/rules.def Thu Jul 15 17:10:44 2004
@@ -1055,71 +1055,15 @@
*/
#ifndef InstallIncludes
-#if InstallRelative
-#define InstallIncludes(dir) @@\
-install:: @@\
- -@if [ -h $(TOP)/include ]; then exit 0; else \ @@\
- (cd $(TOP) && $(LN) src/include include); fi
-#else
-#define InstallIncludes(dir) @@\
-install:: @@\
- MakeDir($(INCDIR)/dir) @@\
- $(INSTALL) -c $(INSTINCFLAGS) *.h $(INCDIR)/dir @@\
- @@\
-uninstall:: @@\
- (cd $(INCDIR)/dir;$(RM) *.h)
-#endif
+#define InstallIncludes(dir) /**/
#endif
#ifndef InstallInclude
-#if InstallRelative
-#define InstallInclude(dir, file) @@\
-install:: @@\
- -@if [ -h $(TOP)/include ]; then exit 0; else \ @@\
- (cd $(TOP) && $(LN) src/include include); fi
-#else
-#define InstallInclude(dir, file) @@\
-install:: @@\
- MakeDir($(INCDIR)/dir) @@\
- $(INSTALL) -c $(INSTINCFLAGS) file $(INCDIR)/dir @@\
- @@\
-uninstall:: @@\
- $(RM) $(INCDIR)/dir/file
-#endif
+#define InstallInclude(dir, file) /**/
#endif
#ifndef InstallSymLink
-#if InstallRelative
#define InstallSymLink(dir, file) /**/
-#else
-#if !defined(SVR4)
-#if defined(DARWIN)
-#define InstallSymLink(dir, file) @@\
-install:: @@\
- MakeDir(dir) @@\
- cp -f file dir @@\
- @@\
-uninstall:: @@\
- $(RM) dir/file
-#else
-#define InstallSymLink(dir, file) @@\
-install:: @@\
- MakeDir(dir) @@\
- cp -fd file dir @@\
- @@\
-uninstall:: @@\
- $(RM) dir/file
-#endif
-#else
-#define InstallSymLink(dir, file) @@\
-install:: @@\
- MakeDir(dir) @@\
- tar cf - file | (cd dir; tar xfp -) @@\
- @@\
-uninstall:: @@\
- $(RM) dir/file
-#endif
-#endif
#endif
/*

View file

@ -1,9 +1,13 @@
--- config/Imakefile.orig Mon Jul 16 10:10:06 2001
+++ config/Imakefile Wed Mar 27 12:18:06 2002
@@ -9,12 +9,3 @@
$FreeBSD$
--- config/Imakefile.orig
+++ config/Imakefile
@@ -8,13 +8,3 @@
SUBDIRS = InterViews
MakeInSubdirs($(SUBDIRS))
-
-#if !InstallRelative
-install::
- MakeDir($(CONFIGDIR))

View file

@ -0,0 +1,32 @@
$FreeBSD$
--- config/params.def.orig
+++ config/params.def
@@ -975,7 +975,7 @@
-lSpatialObjectDEX \
-lStat \
-lSurfaceTest \
--lTIFF \
+-ltiff \
-lTargetDetection-CSU \
-lTopology \
-lTraits \
@@ -1023,7 +1023,7 @@
-lIUE-IF-Region \
-lDexTestIUE \
-lIUE-Unit \
--lTIFF
+-ltiff
#endif
#else
#define IueCCLdLibs /**/
@@ -1056,7 +1056,7 @@
#ifndef TiffCCLdLibs
#ifdef TiffLibDir
-#define TiffCCLdLibs -L$(TIFFLIBDIR) -lTIFF
+#define TiffCCLdLibs -L$(TIFFLIBDIR) -ltiff
#else
#define TiffCCLdLibs /**/
#endif

View file

@ -0,0 +1,24 @@
$FreeBSD$
--- config/rules.def.orig
+++ config/rules.def
@@ -1054,6 +1054,9 @@
* Install header files on Linux.
*/
+#define InstallIncludes(dir) @@\
+install::
+
#ifndef InstallIncludes
#if InstallRelative
#define InstallIncludes(dir) @@\
@@ -1071,6 +1074,8 @@
#endif
#endif
+#define InstallInclude(dir, file) @@\
+install::
#ifndef InstallInclude
#if InstallRelative
#define InstallInclude(dir, file) @@\

View file

@ -1,6 +1,9 @@
--- src/ComTerp/comterp.c~ Tue May 25 15:07:38 2004
+++ src/ComTerp/comterp.c Mon Nov 22 11:27:09 2004
@@ -63,6 +63,7 @@
$FreeBSD$
--- src/ComTerp/comterp.c.orig
+++ src/ComTerp/comterp.c
@@ -74,6 +74,7 @@
#if __GNUC__>=3
#include <fstream.h>
#endif
@ -8,3 +11,12 @@
#define TITLE "ComTerp"
#define STREAM_MECH
@@ -896,7 +897,7 @@
fbuf.attach(fd);
} else
fbuf.attach(fileno(stdout));
-#elif (__GNUC__==3 && __GNUC_MINOR__<1) || __GNUC__>3
+#elif (__GNUC__==3 && __GNUC_MINOR__<1) || __GNUC__>3 || defined(__FreeBSD__)
fileptr_filebuf fbuf(handler() && handler()->wrfptr()
? handler()->wrfptr() : stdout,
ios_base::out);

View file

@ -0,0 +1,49 @@
$FreeBSD$
--- src/ComTerp/comterpserv.c.orig
+++ src/ComTerp/comterpserv.c
@@ -152,7 +152,7 @@
fbuf.attach(fd);
istream in (&fbuf);
in.gets(&instr);
-#elif (__GNUC__==3 && __GNUC_MINOR__<1) || __GNUC__>3
+#elif (__GNUC__==3 && __GNUC_MINOR__<1) || __GNUC__>3 || defined(__FreeBSD__)
char instr[BUFSIZ];
FILE* ifptr = fdopen(fd, "r");
fileptr_filebuf fbuf(ifptr, ios_base::in);
@@ -160,6 +160,7 @@
in.get(instr, BUFSIZ, '\n'); // needs to be generalized with <vector.h>
#else
char instr[BUFSIZ];
+ fileptr_filebuf fbuf(ifptr, ios_base::in);
fileptr_filebuf fbuf(fd, ios_base::in, false, static_cast<size_t>(BUFSIZ));
istream in (&fbuf);
in.get(instr, BUFSIZ, '\n'); // needs to be generalized with <vector.h>
@@ -202,7 +203,7 @@
#if __GNUC__<3
filebuf fbuf;
fbuf.attach(fd);
-#elif (__GNUC__==3 && __GNUC_MINOR__<1) || __GNUC__>3
+#elif (__GNUC__==3 && __GNUC_MINOR__<1) || __GNUC__>3 || defined(__FreeBSD__)
FILE* ofptr = fdopen(fd, "w");
fileptr_filebuf fbuf(ofptr, ios_base::out);
#else
@@ -320,7 +321,7 @@
err_print( stderr, "comterp" );
#if __GNUC__<3
filebuf obuf(handler() ? handler()->get_handle() : 1);
-#elif __GNUC__==3 && __GNUC_MINOR__<1 || __GNUC__>3
+#elif __GNUC__==3 && __GNUC_MINOR__<1 || __GNUC__>3 || defined(__FreeBSD__)
FILE* ofptr = fdopen(handler() ? handler()->get_handle() : 1, "w");
fileptr_filebuf obuf(ofptr, ios_base::out);
#else
@@ -345,7 +346,7 @@
err_print( stderr, "comterp" );
#if __GNUC__<3
filebuf obuf(handler() ? handler()->get_handle() : 1);
-#elif __GNUC__==3 && __GNUC_MINOR__<1 || __GNUC__>3
+#elif __GNUC__==3 && __GNUC_MINOR__<1 || __GNUC__>3 || defined(__FreeBSD__)
FILE* ofptr = fdopen(handler() ? handler()->get_handle() : 1, "w");
fileptr_filebuf obuf(ofptr, ios_base::out);
#else

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/Imakefile.orig
+++ src/Imakefile
@@ -75,7 +75,6 @@
DrawServ \
drawserv_ \
\
- include \
scripts \
utils \
tests \

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- src/Makefile.orig
+++ src/Makefile
@@ -298,7 +298,7 @@
ACEDISPATCH =
-SUBDIRS = IV-common Unidraw-common ComUtil Attribute TopoFace ComTerp comtest comterp_ IV InterViews IV-2_6 IV-X11 OS TIFF Dispatch dclock iclass idemo Time IVGlyph ivtext glyphs AttrGlyph ComGlyph glyphterp Unidraw UniIdraw idraw OverlayUnidraw $(ACEDISPATCH) drawtool $(IUEDIRS) ComUnidraw comdraw FrameUnidraw flipbook GraphUnidraw graphdraw DrawServ drawserv_ include scripts utils tests man html
+SUBDIRS = IV-common Unidraw-common ComUtil Attribute TopoFace ComTerp comtest comterp_ IV InterViews IV-2_6 IV-X11 OS TIFF Dispatch dclock iclass idemo Time IVGlyph ivtext glyphs AttrGlyph ComGlyph glyphterp Unidraw UniIdraw idraw OverlayUnidraw $(ACEDISPATCH) drawtool $(IUEDIRS) ComUnidraw comdraw FrameUnidraw flipbook GraphUnidraw graphdraw DrawServ drawserv_ scripts utils tests man html
Makefiles::
-@for i in $(SUBDIRS); \

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/box1/Imakefile.orig
+++ src/glyphs/examples3.1/box1/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/box2/Imakefile.orig
+++ src/glyphs/examples3.1/box2/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/box3/Imakefile.orig
+++ src/glyphs/examples3.1/box3/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/box4/Imakefile.orig
+++ src/glyphs/examples3.1/box4/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/box5/Imakefile.orig
+++ src/glyphs/examples3.1/box5/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/button1/Imakefile.orig
+++ src/glyphs/examples3.1/button1/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/button2/Imakefile.orig
+++ src/glyphs/examples3.1/button2/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/button3/Imakefile.orig
+++ src/glyphs/examples3.1/button3/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/bvalue/Imakefile.orig
+++ src/glyphs/examples3.1/bvalue/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/circle/Imakefile.orig
+++ src/glyphs/examples3.1/circle/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/drag/Imakefile.orig
+++ src/glyphs/examples3.1/drag/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/fonts/Imakefile.orig
+++ src/glyphs/examples3.1/fonts/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/himom/Imakefile.orig
+++ src/glyphs/examples3.1/himom/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/image/Imakefile.orig
+++ src/glyphs/examples3.1/image/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/ips/Imakefile.orig
+++ src/glyphs/examples3.1/ips/Imakefile
@@ -6,6 +6,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(ips)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/menu/Imakefile.orig
+++ src/glyphs/examples3.1/menu/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/patch/Imakefile.orig
+++ src/glyphs/examples3.1/patch/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/preview/Imakefile.orig
+++ src/glyphs/examples3.1/preview/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/print/Imakefile.orig
+++ src/glyphs/examples3.1/print/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/rubband/Imakefile.orig
+++ src/glyphs/examples3.1/rubband/Imakefile
@@ -4,6 +4,7 @@
OBJS = main.o
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(a.out)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/glyphs/examples3.1/zoomer/Imakefile.orig
+++ src/glyphs/examples3.1/zoomer/Imakefile
@@ -2,6 +2,7 @@
#ifdef InObjectCodeDir
+OTHER_CCLDLIBS = $(TIFF_CCLDLIBS)
Use_libInterViews()
ComplexProgramTargetNoInstall(test)

View file

@ -6,7 +6,6 @@ bin/flipbook
bin/graphdraw
bin/iclass
bin/idraw
bin/ivdl
bin/ivgetjpg
bin/ivtext
bin/ivtiftopnm
@ -16,39 +15,39 @@ bin/stdcmapppm
lib/ivtools/InterViews
lib/ivtools/comterp.err
lib/libAttrGlyph.so
lib/libAttrGlyph.so.1.2.1
lib/libAttrGlyph.so.1.2.3
lib/libAttribute.so
lib/libAttribute.so.1.2.1
lib/libAttribute.so.1.2.3
lib/libComGlyph.so
lib/libComGlyph.so.1.2.1
lib/libComGlyph.so.1.2.3
lib/libComTerp.so
lib/libComTerp.so.1.2.1
lib/libComTerp.so.1.2.3
lib/libComUnidraw.so
lib/libComUnidraw.so.1.2.1
lib/libComUnidraw.so.1.2.3
lib/libComUtil.so
lib/libComUtil.so.1.2.1
lib/libComUtil.so.1.2.3
lib/libDrawServ.so
lib/libDrawServ.so.1.2.1
lib/libDrawServ.so.1.2.3
lib/libFrameUnidraw.so
lib/libFrameUnidraw.so.1.2.1
lib/libFrameUnidraw.so.1.2.3
lib/libGraphUnidraw.so
lib/libGraphUnidraw.so.1.2.1
lib/libGraphUnidraw.so.1.2.3
lib/libIV-common.so
lib/libIV-common.so.1.2.1
lib/libIV-common.so.1.2.3
lib/libIV.so
lib/libIV.so.1.2.1
lib/libIV.so.1.2.3
lib/libIVGlyph.so
lib/libIVGlyph.so.1.2.1
lib/libIVGlyph.so.1.2.3
lib/libOverlayUnidraw.so
lib/libOverlayUnidraw.so.1.2.1
lib/libOverlayUnidraw.so.1.2.3
lib/libTime.so
lib/libTime.so.1.2.1
lib/libTime.so.1.2.3
lib/libTopoFace.so
lib/libTopoFace.so.1.2.1
lib/libTopoFace.so.1.2.3
lib/libUniIdraw.so
lib/libUniIdraw.so.1.2.1
lib/libUniIdraw.so.1.2.3
lib/libUnidraw-common.so
lib/libUnidraw-common.so.1.2.1
lib/libUnidraw-common.so.1.2.3
lib/libUnidraw.so
lib/libUnidraw.so.1.2.1
lib/libUnidraw.so.1.2.3
@dirrm lib/ivtools