Bugfix to set RANLIB correctly. Also set VERSION in port Makefile.

Closes PR ports/2937.

Submitted by:	Taguchi Takeshi <taguchi@tohoku.iij.ad.jp>
This commit is contained in:
Satoshi Asami 1997-03-11 11:02:41 +00:00
parent 21aaf2b306
commit f68e96f599
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=5935
5 changed files with 21 additions and 13 deletions

View file

@ -1,9 +1,9 @@
# New ports collection makefile for: tcl7.6jp
# Version required: 7.6p2jp
# Date created:
# Date created: 11 March 1997
# Whom: taguchi@tohoku.iij.ad.jp
#
# $Id: Makefile,v 1.1.1.1 1997/03/02 13:01:24 asami Exp $
# $Id: Makefile,v 1.2 1997/03/05 23:13:23 asami Exp $
#
DISTNAME= tcl7.6p2
@ -21,6 +21,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
VERSION= 7.6jp
.if defined(PATCH_DEBUG)
PATCH_DIST_ARGS= -d ${WRKDIR}/${DISTNAME} -E ${PATCH_DIST_STRIP}
.else
@ -35,11 +37,11 @@ post-configure:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}
pre-build:
cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} && rm *.o
cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} && rm *.o
pre-install:
${MKDIR} ${PREFIX}/lib/tcl7.6jp
cd ${WRKSRC} && ${MAKE} -f Makefile.lib install PREFIX=${PREFIX}
${MKDIR} ${PREFIX}/lib/tcl${VERSION}
cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} install
post-install:
${LDCONFIG} -m ${PREFIX}/lib

View file

@ -1,6 +1,4 @@
NOPROFILE= yes
VERSION= 7.6jp
LIB= tcl${VERSION}
TCL_LIBRARY= ${PREFIX}/lib/tcl${VERSION}
CFLAGS+= -I. -I./../generic \

View file

@ -1,5 +1,5 @@
--- tclConfig.sh.in.ORIG Mon Feb 10 13:22:37 1997
+++ tclConfig.sh.in Mon Feb 10 13:23:28 1997
--- ./tclConfig.sh.in.orig Fri Jan 31 09:17:04 1997
+++ ./tclConfig.sh.in Tue Mar 4 13:13:25 1997
@@ -20,7 +20,7 @@
TCL_CC='@CC@'
@ -9,3 +9,12 @@
# The name of the Tcl library (may be either a .a file or a shared library):
TCL_LIB_FILE=@TCL_LIB_FILE@
@@ -69,7 +69,7 @@
TCL_COMPAT_OBJS='@LIBOBJS@'
# Name of the ranlib program to use.
-TCL_RANLIB='@RANLIB@'
+TCL_RANLIB=ranlib
# String to pass to linker to pick up the Tcl library from its
# build directory.

View file

@ -3,7 +3,7 @@
# Date created:
# Whom: taguchi@tohoku.iij.ad.jp
#
# $Id$
# $Id: Makefile,v 1.1.1.1 1997/03/02 13:02:06 asami Exp $
#
DISTNAME= tk4.2p2
@ -41,13 +41,13 @@ post-configure:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}
pre-build:
cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} && rm -f *.o
cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} && rm -f *.o
pre-install:
${MKDIR} ${PREFIX}/lib/tk${VERSION}
post-install:
cd ${WRKSRC} && ${MAKE} -f Makefile.lib install PREFIX=${PREFIX}
cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} install
${LDCONFIG} -m ${PREFIX}/lib
@echo "**********"
@echo "IMPORTANT:"

View file

@ -1,4 +1,3 @@
VERSION= 4.2jp
NOPROFILE= yes
LIB= tk${VERSION}
TK_LIBRARY= ${PREFIX}/lib/tk${VERSION}