Update to 0.13.
This commit is contained in:
parent
cc991b216b
commit
f6bb40bbfb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35294
6 changed files with 36 additions and 42 deletions
|
@ -6,15 +6,15 @@
|
|||
#
|
||||
|
||||
PORTNAME= pango
|
||||
PORTVERSION= 0.12
|
||||
PORTVERSION= 0.13
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= http://people.redhat.com/otaylor/pango-mirror/download/
|
||||
MASTER_SITES= ftp://ftp.gtk.org/pub/gtk/v1.3/ \
|
||||
ftp://ftp.cs.umn.edu/pub/gimp/gtk/v1.3/ \
|
||||
http://www.ameth.org/gimp/gtk/v1.3/
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= glib-1.3.1:${PORTSDIR}/devel/glib13 \
|
||||
giconv.2:${PORTSDIR}/converters/libiconv \
|
||||
fribidi.0:${PORTSDIR}/textproc/fribidi
|
||||
LIB_DEPENDS= glib-1.3.2:${PORTSDIR}/devel/glib13
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
@ -23,8 +23,4 @@ CONFIGURE_ARGS= --with-qt=no
|
|||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
|
||||
pre-patch:
|
||||
@find ${WRKSRC} -type f | xargs ${GREP} -l iconv.h | \
|
||||
xargs ${PERL} -pi -e "s|iconv\.h|giconv.h|g"
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (pango-0.12.tar.gz) = 1a99cf704d089cfe15678da1c80ecfca
|
||||
MD5 (pango-0.13.tar.gz) = 524bb245043d8b5b72feb3e8594968f5
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
--- configure.orig Tue Jul 18 10:46:00 2000
|
||||
+++ configure Tue Jul 18 10:46:24 2000
|
||||
@@ -2290,14 +2290,14 @@
|
||||
#
|
||||
# Check for libiconv
|
||||
#
|
||||
- echo $ac_n "checking for libiconv_open in -liconv""... $ac_c" 1>&6
|
||||
-echo "configure:2295: checking for libiconv_open in -liconv" >&5
|
||||
+ echo $ac_n "checking for libiconv_open in -lgiconv""... $ac_c" 1>&6
|
||||
+echo "configure:2295: checking for libiconv_open in -lgiconv" >&5
|
||||
ac_lib_var=`echo iconv'_'libiconv_open | sed 'y%./+-%__p_%'`
|
||||
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-liconv $LIBS"
|
||||
+LIBS="-lgiconv $LIBS"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 2303 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -2339,7 +2339,7 @@
|
||||
UNICODE_CFLAGS=
|
||||
UNICODE_LIBS=
|
||||
if test "x$with_libiconv" = "xyes" ; then
|
||||
- UNICODE_LIBS="-liconv"
|
||||
+ UNICODE_LIBS="-lgiconv"
|
||||
fi
|
||||
|
||||
|
|
@ -1,11 +1,12 @@
|
|||
--- pango/Makefile.in.orig Tue Jul 18 11:21:36 2000
|
||||
+++ pango/Makefile.in Tue Jul 18 11:21:41 2000
|
||||
@@ -100,9 +100,9 @@
|
||||
--- pango/Makefile.in.orig Fri Nov 17 23:44:42 2000
|
||||
+++ pango/Makefile.in Mon Nov 20 12:43:20 2000
|
||||
@@ -106,10 +106,10 @@
|
||||
# down at which point we'll either use the GTK+ versioning
|
||||
# scheme or the standard libtool scheme.
|
||||
#
|
||||
-libpango_la_LDFLAGS = -release $(VERSION) $(GLIB_LIBS)
|
||||
+libpango_la_LDFLAGS = -version-info $(VERSION:S/./:/) $(GLIB_LIBS)
|
||||
@HAVE_FRIBIDI_FALSE@libpango_la_LIBADD = mini-fribidi/libmini-fribidi.la
|
||||
|
||||
-libpangox_la_LDFLAGS = -release $(VERSION)
|
||||
+libpangox_la_LDFLAGS = -version-info $(VERSION:S/./:/)
|
||||
|
|
20
x11-toolkits/pango/files/patch-ac
Normal file
20
x11-toolkits/pango/files/patch-ac
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- Makefile.in.orig Fri Nov 17 23:44:38 2000
|
||||
+++ Makefile.in Mon Nov 20 12:55:05 2000
|
||||
@@ -88,7 +88,7 @@
|
||||
VERSION = @VERSION@
|
||||
X_LIBS = @X_LIBS@
|
||||
|
||||
-SUBDIRS = modules pango examples docs tools fonts
|
||||
+SUBDIRS = modules pango examples tools fonts
|
||||
|
||||
bin_SCRIPTS = pango-config
|
||||
|
||||
@@ -369,7 +369,7 @@
|
||||
install-exec-am: install-binSCRIPTS
|
||||
install-exec: install-exec-recursive
|
||||
|
||||
-install-data-am: install-pkgconfigDATA
|
||||
+install-data-am:
|
||||
install-data: install-data-recursive
|
||||
|
||||
install-am: all-am
|
|
@ -9,9 +9,11 @@ include/pango/pango-engine.h
|
|||
include/pango/pango-font.h
|
||||
include/pango/pango-fontmap.h
|
||||
include/pango/pango-glyph.h
|
||||
include/pango/pango-indic.h
|
||||
include/pango/pango-item.h
|
||||
include/pango/pango-layout.h
|
||||
include/pango/pango-modules.h
|
||||
include/pango/pango-tabs.h
|
||||
include/pango/pango-types.h
|
||||
include/pango/pango-utils.h
|
||||
include/pango/pango.h
|
||||
|
@ -24,8 +26,12 @@ lib/libpangox.so
|
|||
lib/libpangox.so.0
|
||||
lib/pango/modules/pango-arabic.so
|
||||
lib/pango/modules/pango-basic.so
|
||||
lib/pango/modules/pango-bengali.so
|
||||
lib/pango/modules/pango-devanagari.so
|
||||
lib/pango/modules/pango-gujarati.so
|
||||
lib/pango/modules/pango-gurmukhi.so
|
||||
lib/pango/modules/pango-hangul.so
|
||||
lib/pango/modules/pango-myanmar.so
|
||||
lib/pango/modules/pango-tamil.so
|
||||
lib/pango/modules/pango-thai.so
|
||||
@dirrm lib/pango/modules
|
||||
|
|
Loading…
Reference in a new issue