- Fix build

- Fix pathname in desktop entry file

PR:		187055
This commit is contained in:
Martin Wilke 2014-02-27 09:24:15 +00:00
parent 8369f3b7e6
commit f6daf54c01
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=346300
4 changed files with 56 additions and 49 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= viruskiller
PORTVERSION= 1.03
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= FRUGALWARE/games-extra/${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION}-1
@ -13,40 +13,29 @@ COMMENT= Arcade game that relies on quick reflexes
LICENSE= GPLv2
OPTIONS_DEFINE= DOCS
USE_SDL= mixer image ttf net
USES= gmake
BROKEN= Does not build
DEPRECATED= Broken for more then 6 month
EXPIRATION_DATE= 2014-02-27
INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= gmake
USE_SDL= mixer image ttf net
MAKEFILE= makefile
INSTALLS_ICONS= yes
NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == "amd64"
BROKEN= Does not build with new libz
.endif
OPTIONS_DEFINE= DOCS
post-patch:
# Remove non-free restricted files:
${RM} -f ${WRKSRC}/music/* ${WRKSRC}/sound/*
.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e "s|^.*install.*DOCS.*||g" \
-e "s|^.*mkdir.*DOCDIR.*||g" \
${WRKSRC}/makefile
.endif
@${REINPLACE_CMD} -e "s|^PREFIX.*|PREFIX=${PREFIX}|g" \
-e "s|^BINDIR.*|BINDIR=${PREFIX}/bin/|g" \
-e "s|^DATADIR.*|DATADIR=${DATADIR}/|g" \
-e "s|^DOCDIR.*|DOCDIR=${DOCSDIR}|g" ${WRKSRC}/makefile
@${REINPLACE_CMD} -e \
'/^DOCS/s|=.*|= doc/README doc/*.*| ; \
/^PREFIX/s|=.*|= ${PREFIX}| ; \
/^BINDIR/s|=.*|= $$(DESTDIR)$$(PREFIX)/bin/| ; \
/^DATADIR/s|=.*|= $$(DESTDIR)$$(PREFIX)/${DATADIR_REL}/| ; \
/^DOCDIR/s|=.*|= $$(DESTDIR)$$(PREFIX)/${DOCSDIR_REL}/| ; \
/^ICONDIR/s|=.*|= $$(DESTDIR)$$(PREFIX)/share/icons/hicolor/| ; \
/^DESKTOPDIR/s|=.*|= $$(DESTDIR)$$(PREFIX)/share/applications/| ; \
s|install .* 755|$${BSD_INSTALL_PROGRAM}| ; \
s|install .* 644|$${BSD_INSTALL_DATA}| ; \
/ICONS/s|cp|$${BSD_INSTALL_DATA}|' ${WRKSRC}/makefile
@${REINPLACE_CMD} -e \
's|.png|| ; \
s|/usr/games/||' ${WRKSRC}/icons/viruskiller.desktop
.include <bsd.port.mk>

View file

@ -0,0 +1,27 @@
--- src/pak.cpp.orig
+++ src/pak.cpp
@@ -124,7 +124,7 @@
{
printf("Couldn't open %s for reading!\n", filename);
closedir(dirp);
- gzclose(pak);
+ gzclose((gzFile)pak);
exit(1);
}
@@ -156,13 +156,13 @@
{
printf("Couldn't open %s for reading!\n", filename);
closedir(dirp);
- gzclose(pak);
+ gzclose((gzFile)pak);
exit(1);
}
else
{
fSize = gzread(fp, buffer, filesize);
- gzclose(fp);
+ gzclose((gzFile)fp);
cSize = (uLongf)((fSize * 1.01) + 12);
compress2(output, &cSize, buffer, fSize, 9);

View file

@ -1,9 +1,9 @@
Your computer has been invaded! Dozens of little viruses are pouring in via
security holes in Microsoft Internet Explorer, Microsoft Outlook, Microsoft MSN
Messenger and Microsoft Recycle Bin!! Using your trusty mouse you must shoot the
buggers before they can destroy your files! Some will steal them from their home
directories and take them back to their security hole. Others will just eat them
right there on the spot! See how long you and your computer can survive the
onslaught!
Your computer has been invaded! Dozens of little viruses are pouring in
via security holes in Microsoft Internet Explorer, Microsoft Outlook,
Microsoft MSN Messenger and Microsoft Recycle Bin!! Using your trusty
mouse you must shoot the buggers before they can destroy your files!
Some will steal them from their home directories and take them back to
their security hole. Others will just eat them right there on the spot!
See how long you and your computer can survive the onslaught!
WWW: http://www.parallelrealities.co.uk/projects/virusKiller.php

View file

@ -1,6 +1,5 @@
bin/viruskiller
%%DATADIR%%/viruskiller.pak
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
share/applications/viruskiller.desktop
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/battery.png
%%PORTDOCS%%%%DOCSDIR%%/bomb.png
@ -13,14 +12,6 @@ bin/viruskiller
share/icons/hicolor/16x16/apps/viruskiller.png
share/icons/hicolor/32x32/apps/viruskiller.png
share/icons/hicolor/64x64/apps/viruskiller.png
share/applications/viruskiller.desktop
%%DATADIR%%/viruskiller.pak
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry %%DATADIR%%
@dirrmtry share/icons/hicolor/64x64/apps
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor/16x16/apps
@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor
@dirrmtry share/icons