Add devel/erlang-mustache, a Mustache template engine for Erlang.

This commit is contained in:
Jimmy Olgeni 2015-05-12 14:02:17 +00:00
parent 5798ebb36d
commit f6e004e94b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=386151
7 changed files with 74 additions and 0 deletions

View file

@ -410,6 +410,7 @@
SUBDIR += eric6
SUBDIR += eris
SUBDIR += erlang-msgpack
SUBDIR += erlang-mustache
SUBDIR += erlang-protobuffs
SUBDIR += esdl
SUBDIR += etcd

View file

@ -0,0 +1,41 @@
# $FreeBSD$
PORTNAME= mustache
PORTVERSION= 0.3.0
DISTVERSIONPREFIX=v
CATEGORIES= devel
PKGNAMEPREFIX= erlang-
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Mustache template engine for Erlang
LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/bin/erl:${PORTSDIR}/lang/erlang
RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= VERSION="${PORTVERSION}"
USE_GITHUB= yes
GH_ACCOUNT= soranoba
ALL_TARGET= compile
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e "s/%%PORTVERSION%%/${PORTVERSION}/" ${WRKSRC}/src/mustache.app.src
@${RM} ${WRKSRC}/src/*.bak ${WRKSRC}/src/*.orig
do-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
.endif
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
${INSTALL_DATA} ${WRKSRC}/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (soranoba-mustache-v0.3.0_GH0.tar.gz) = 829153de008de92702ae8fc9f9d3986fcdee16a2578e98c6495ba86ad15ba665
SIZE (soranoba-mustache-v0.3.0_GH0.tar.gz) = 187846

View file

@ -0,0 +1,11 @@
--- rebar.config.orig 2015-05-08 16:05:56 UTC
+++ rebar.config
@@ -36,8 +36,4 @@
{deps,
[
- {meck, ".*", {git, "git://github.com/eproxus/meck.git", {tag, "0.8.2"}}},
- {reloader, ".*", {git, "git://github.com/sile/reloader.git", {branch, "master"}}},
- {edown, ".*", {git, "git://github.com/dwango/edown.git", {branch, "master"}}},
- {eunit_formatters, ".*", {git, "git://github.com/seancribbs/eunit_formatters", {branch, "master"}}}
]}.

View file

@ -0,0 +1,11 @@
--- src/mustache.app.src.orig 2015-05-12 13:41:59 UTC
+++ src/mustache.app.src
@@ -2,7 +2,7 @@
{application, mustache,
[
{description, "Mustache template engine for Erlang/OTP"},
- {vsn, git},
+ {vsn, "%%PORTVERSION%%"},
{registered, []},
{applications, [
kernel,

View file

@ -0,0 +1,3 @@
Mustache template engine for Erlang/OTP.
WWW: https://github.com/soranoba/mustache

View file

@ -0,0 +1,5 @@
lib/erlang/lib/mustache-%%VERSION%%/ebin/mustache.app
lib/erlang/lib/mustache-%%VERSION%%/ebin/mustache.beam
lib/erlang/lib/mustache-%%VERSION%%/src/mustache.app.src
lib/erlang/lib/mustache-%%VERSION%%/src/mustache.erl
%%PORTDOCS%%%%DOCSDIR%%/README.md