RTP Quality Monitor from UCL. Similar to rtpmon.
This commit is contained in:
parent
000ab664d5
commit
f6e116765c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25361
12 changed files with 156 additions and 0 deletions
32
mbone/rqm/Makefile
Normal file
32
mbone/rqm/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# New ports collection makefile for: rqm
|
||||
# Version required: 1.0.0
|
||||
# Date created: 30 January 2000
|
||||
# Whom: fenner
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= rqm-1.0.0
|
||||
CATEGORIES= mbone
|
||||
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rqm/1.0.0/
|
||||
|
||||
MAINTAINER= fenner@FreeBSD.Org
|
||||
|
||||
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libuclmmbase.a:${PORTSDIR}/devel/uclmmbase
|
||||
|
||||
WRKSRC= ${WRKDIR}/rqm/
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PREFIX=${PREFIX} X11BASE=${X11BASE}
|
||||
|
||||
ALL_TARGET= rqm
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/rqm ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/rqm
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/rqm
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
mbone/rqm/distinfo
Normal file
1
mbone/rqm/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (rqm-1.0.0.tar.gz) = 406a9bfe4a3e9ad9f1a981701072f54a
|
35
mbone/rqm/files/patch-aa
Normal file
35
mbone/rqm/files/patch-aa
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- configure.orig Sun Oct 3 08:47:46 1999
|
||||
+++ configure Sun Jan 30 16:05:14 2000
|
||||
@@ -53,9 +53,9 @@
|
||||
|
||||
echo "Configuring rqm v$VERSION for $OSTYPE"
|
||||
|
||||
-GCCWFLAGS="-W -Wall -Wbad-function-cast -Wmissing-prototypes -Wno-implicit-int -Werror"
|
||||
-TCL_LIBS="../tk-8.0/unix/libtk8.0.a ../tcl-8.0/unix/libtcl8.0.a"
|
||||
-TCL_INCL="-I../tk-8.0/generic -I../tcl-8.0/generic"
|
||||
+GCCWFLAGS="-W -Wall -Wbad-function-cast -Wmissing-prototypes -Wno-implicit-int"
|
||||
+TCL_LIBS="-L${PREFIX}/lib -ltk82 -ltcl82"
|
||||
+TCL_INCL="-I${PREFIX}/include/tk8.2/generic -I${PREFIX}/include/tcl8.2/generic"
|
||||
DEFS=""
|
||||
|
||||
AR="ar"
|
||||
@@ -103,7 +103,7 @@
|
||||
;;
|
||||
FreeBSD ) CC="gcc"
|
||||
WFLAGS=$GCCWFLAGS
|
||||
- INCLUDE="-I/usr/local/include"
|
||||
+ INCLUDE="-I${PREFIX}/include -I${X11BASE}/include"
|
||||
LDLIBS="-lm"
|
||||
DEBUG="-g"
|
||||
CHAR="-fsigned-char"
|
||||
@@ -172,8 +172,8 @@
|
||||
s@__AR__@$AR@
|
||||
s@__RANLIB__@$RANLIB@
|
||||
s@__WFLAGS__@$WFLAGS@
|
||||
-s@__INCLUDE__@$TCL_INCL $INCLUDE -I../common@g
|
||||
-s@__LDLIBS__@$TCL_LIBS -L../common -lcommon $LDLIBS@g
|
||||
+s@__INCLUDE__@$TCL_INCL $INCLUDE -I${PREFIX}/include/uclmmbase@g
|
||||
+s@__LDLIBS__@$TCL_LIBS -L${PREFIX}/lib -luclmmbase $LDLIBS@g
|
||||
s@__CHAR__@$CHAR@
|
||||
s@__DEBUG__@$DEBUG2@
|
||||
s@__OPTIMIZE__@$OPTIMIZE2@
|
1
mbone/rqm/pkg-comment
Normal file
1
mbone/rqm/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A graphical RTP quality monitor
|
7
mbone/rqm/pkg-descr
Normal file
7
mbone/rqm/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
The Real-time Transport Protocol, RTP [1], provides quality of service
|
||||
feedback with reception reports sent alongside the media stream. If the
|
||||
media is sent via IP multicast it is possible for a third party to snoop
|
||||
on these reception reports, displaying reception quality for all members
|
||||
of a group. The RQM application performs such snooping.
|
||||
|
||||
WWW: http://www-mice.cs.ucl.ac.uk/multimedia/software/rqm/
|
2
mbone/rqm/pkg-plist
Normal file
2
mbone/rqm/pkg-plist
Normal file
|
@ -0,0 +1,2 @@
|
|||
bin/rqm
|
||||
share/doc/rqm/README
|
32
net/rqm/Makefile
Normal file
32
net/rqm/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# New ports collection makefile for: rqm
|
||||
# Version required: 1.0.0
|
||||
# Date created: 30 January 2000
|
||||
# Whom: fenner
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= rqm-1.0.0
|
||||
CATEGORIES= mbone
|
||||
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rqm/1.0.0/
|
||||
|
||||
MAINTAINER= fenner@FreeBSD.Org
|
||||
|
||||
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libuclmmbase.a:${PORTSDIR}/devel/uclmmbase
|
||||
|
||||
WRKSRC= ${WRKDIR}/rqm/
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PREFIX=${PREFIX} X11BASE=${X11BASE}
|
||||
|
||||
ALL_TARGET= rqm
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/rqm ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/rqm
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/rqm
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/rqm/distinfo
Normal file
1
net/rqm/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (rqm-1.0.0.tar.gz) = 406a9bfe4a3e9ad9f1a981701072f54a
|
35
net/rqm/files/patch-aa
Normal file
35
net/rqm/files/patch-aa
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- configure.orig Sun Oct 3 08:47:46 1999
|
||||
+++ configure Sun Jan 30 16:05:14 2000
|
||||
@@ -53,9 +53,9 @@
|
||||
|
||||
echo "Configuring rqm v$VERSION for $OSTYPE"
|
||||
|
||||
-GCCWFLAGS="-W -Wall -Wbad-function-cast -Wmissing-prototypes -Wno-implicit-int -Werror"
|
||||
-TCL_LIBS="../tk-8.0/unix/libtk8.0.a ../tcl-8.0/unix/libtcl8.0.a"
|
||||
-TCL_INCL="-I../tk-8.0/generic -I../tcl-8.0/generic"
|
||||
+GCCWFLAGS="-W -Wall -Wbad-function-cast -Wmissing-prototypes -Wno-implicit-int"
|
||||
+TCL_LIBS="-L${PREFIX}/lib -ltk82 -ltcl82"
|
||||
+TCL_INCL="-I${PREFIX}/include/tk8.2/generic -I${PREFIX}/include/tcl8.2/generic"
|
||||
DEFS=""
|
||||
|
||||
AR="ar"
|
||||
@@ -103,7 +103,7 @@
|
||||
;;
|
||||
FreeBSD ) CC="gcc"
|
||||
WFLAGS=$GCCWFLAGS
|
||||
- INCLUDE="-I/usr/local/include"
|
||||
+ INCLUDE="-I${PREFIX}/include -I${X11BASE}/include"
|
||||
LDLIBS="-lm"
|
||||
DEBUG="-g"
|
||||
CHAR="-fsigned-char"
|
||||
@@ -172,8 +172,8 @@
|
||||
s@__AR__@$AR@
|
||||
s@__RANLIB__@$RANLIB@
|
||||
s@__WFLAGS__@$WFLAGS@
|
||||
-s@__INCLUDE__@$TCL_INCL $INCLUDE -I../common@g
|
||||
-s@__LDLIBS__@$TCL_LIBS -L../common -lcommon $LDLIBS@g
|
||||
+s@__INCLUDE__@$TCL_INCL $INCLUDE -I${PREFIX}/include/uclmmbase@g
|
||||
+s@__LDLIBS__@$TCL_LIBS -L${PREFIX}/lib -luclmmbase $LDLIBS@g
|
||||
s@__CHAR__@$CHAR@
|
||||
s@__DEBUG__@$DEBUG2@
|
||||
s@__OPTIMIZE__@$OPTIMIZE2@
|
1
net/rqm/pkg-comment
Normal file
1
net/rqm/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A graphical RTP quality monitor
|
7
net/rqm/pkg-descr
Normal file
7
net/rqm/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
The Real-time Transport Protocol, RTP [1], provides quality of service
|
||||
feedback with reception reports sent alongside the media stream. If the
|
||||
media is sent via IP multicast it is possible for a third party to snoop
|
||||
on these reception reports, displaying reception quality for all members
|
||||
of a group. The RQM application performs such snooping.
|
||||
|
||||
WWW: http://www-mice.cs.ucl.ac.uk/multimedia/software/rqm/
|
2
net/rqm/pkg-plist
Normal file
2
net/rqm/pkg-plist
Normal file
|
@ -0,0 +1,2 @@
|
|||
bin/rqm
|
||||
share/doc/rqm/README
|
Loading…
Reference in a new issue