Update net-im/nheko and support libraries to latest upstream
- adds presence support Release notes are at https://github.com/Nheko-Reborn/mtxclient/releases/tag/v0.3.1 https://github.com/Nheko-Reborn/nheko/releases/tag/v0.7.2
This commit is contained in:
parent
a3db6d8797
commit
f75dd037d9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=538873
10 changed files with 22 additions and 69 deletions
|
@ -2,8 +2,7 @@
|
|||
|
||||
PORTNAME= mtxclient
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.3.0
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 0.3.1
|
||||
CATEGORIES= net-im
|
||||
|
||||
MAINTAINER= adridg@FreeBSD.org
|
||||
|
@ -13,7 +12,6 @@ LICENSE= MIT
|
|||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json \
|
||||
spdlog>=1.3:devel/spdlog \
|
||||
googletest>0:devel/googletest
|
||||
LIB_DEPENDS= libsodium.so:security/libsodium \
|
||||
libboost_date_time.so:devel/boost-libs \
|
||||
|
@ -22,7 +20,8 @@ LIB_DEPENDS= libsodium.so:security/libsodium \
|
|||
libboost_regex.so:devel/boost-libs \
|
||||
libboost_system.so:devel/boost-libs \
|
||||
libboost_thread.so:devel/boost-libs \
|
||||
libolm.so:security/olm
|
||||
libolm.so:security/olm \
|
||||
libspdlog.so:devel/spdlog
|
||||
|
||||
USES= cmake compiler:c++17-lang pkgconfig ssl \
|
||||
tar:xz
|
||||
|
@ -30,11 +29,4 @@ USES= cmake compiler:c++17-lang pkgconfig ssl \
|
|||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Nheko-Reborn
|
||||
|
||||
# 71 files use #include <json.hpp>, which needs to be
|
||||
# elsewhere; an alternative would be to bung in -I${LOCALBASE}/include/nlohmann
|
||||
post-patch:
|
||||
${FIND} ${WRKSRC} -type f -print0 | \
|
||||
${XARGS} -0 ${REINPLACE_CMD} \
|
||||
's+include <json.hpp>+include <nlohmann/json.hpp>+'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1587418243
|
||||
SHA256 (Nheko-Reborn-mtxclient-v0.3.0_GH0.tar.gz) = 0c2930b5861d93bab9a6515adca74ebaa78984119705d9b4372a9deb275dd30c
|
||||
SIZE (Nheko-Reborn-mtxclient-v0.3.0_GH0.tar.gz) = 507299
|
||||
TIMESTAMP = 1592215303
|
||||
SHA256 (Nheko-Reborn-mtxclient-v0.3.1_GH0.tar.gz) = e4899cc4ce87397de2aef865e94ea2cdb8d9cb86253727e7d90532b925ecc770
|
||||
SIZE (Nheko-Reborn-mtxclient-v0.3.1_GH0.tar.gz) = 511985
|
||||
|
|
|
@ -24,6 +24,8 @@ include/mtx/events/messages/video.hpp
|
|||
include/mtx/events/name.hpp
|
||||
include/mtx/events/pinned_events.hpp
|
||||
include/mtx/events/power_levels.hpp
|
||||
include/mtx/events/presence.hpp
|
||||
include/mtx/events/reaction.hpp
|
||||
include/mtx/events/redaction.hpp
|
||||
include/mtx/events/tag.hpp
|
||||
include/mtx/events/tombstone.hpp
|
||||
|
@ -61,4 +63,4 @@ lib/cmake/MatrixClient/MatrixClientConfigVersion.cmake
|
|||
lib/cmake/MatrixClient/MatrixClientTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/MatrixClient/MatrixClientTargets.cmake
|
||||
lib/libmatrix_client.so
|
||||
lib/libmatrix_client.so.0.3.0
|
||||
lib/libmatrix_client.so.0.3.1
|
||||
|
|
|
@ -2,8 +2,7 @@
|
|||
|
||||
PORTNAME= nheko
|
||||
DISTVERSIONPREFIX=v
|
||||
DISTVERSION= 0.7.1
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 0.7.2
|
||||
CATEGORIES= net-im
|
||||
|
||||
MAINTAINER= adridg@FreeBSD.org
|
||||
|
@ -55,12 +54,4 @@ GH_TUPLE= drycpp:lmdbxx:0b43ca87d8cfabba392dfe884eb1edb83874de02:lmdb/deps/lmdb
|
|||
post-extract:
|
||||
cd ${WRKSRC}/deps/tweeny && ${LN} -s include tweeny
|
||||
|
||||
# Includes <json.hpp> without referencing where it's installed,
|
||||
# so hackishly correct all the broken paths.
|
||||
post-patch:
|
||||
${FIND} ${WRKSRC} -type f -print0 | \
|
||||
${XARGS} -0 ${REINPLACE_CMD} \
|
||||
-e 's+include <json.hpp>+include <nlohmann/json.hpp>+' \
|
||||
-e 's+include "json.hpp"+include <nlohmann/json.hpp>+'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
TIMESTAMP = 1588506704
|
||||
SHA256 (Nheko-Reborn-nheko-v0.7.1_GH0.tar.gz) = ce7ddacbf54707c7e76a816ffca51d73bb6360a38a96807666e3ddeeab8fccf4
|
||||
SIZE (Nheko-Reborn-nheko-v0.7.1_GH0.tar.gz) = 781856
|
||||
TIMESTAMP = 1592215601
|
||||
SHA256 (Nheko-Reborn-nheko-v0.7.2_GH0.tar.gz) = 412908fcec0e66a0557db5359556b65e85dd22b8644a6a2ed569a90dea4bde3c
|
||||
SIZE (Nheko-Reborn-nheko-v0.7.2_GH0.tar.gz) = 899562
|
||||
SHA256 (drycpp-lmdbxx-0b43ca87d8cfabba392dfe884eb1edb83874de02_GH0.tar.gz) = 93721132bbf5045d38ad62de2997655e9984c48ea5c9886746d42128f4b26fbd
|
||||
SIZE (drycpp-lmdbxx-0b43ca87d8cfabba392dfe884eb1edb83874de02_GH0.tar.gz) = 47524
|
||||
SHA256 (mobius3-tweeny-6a5033372fe53c4c731c66c8a2d56261746cd85c_GH0.tar.gz) = c9fcabcdbeb89e4236bbb773ddacf6293ca2a8618f2b1a67e689e3edb704ecd3
|
||||
|
|
|
@ -1,8 +0,0 @@
|
|||
--- src/ui/Avatar.cpp.orig 2020-05-21 11:23:51 UTC
|
||||
+++ src/ui/Avatar.cpp
|
||||
@@ -1,4 +1,5 @@
|
||||
#include <QPainter>
|
||||
+#include <QPainterPath>
|
||||
#include <QSettings>
|
||||
|
||||
#include "AvatarProvider.h"
|
|
@ -1,10 +0,0 @@
|
|||
--- src/ui/InfoMessage.cpp.orig 2020-05-21 11:28:08 UTC
|
||||
+++ src/ui/InfoMessage.cpp
|
||||
@@ -4,6 +4,7 @@
|
||||
#include <QDateTime>
|
||||
#include <QLocale>
|
||||
#include <QPainter>
|
||||
+#include <QPainterPath>
|
||||
#include <QPen>
|
||||
#include <QtGlobal>
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- src/ui/Painter.h.orig 2020-05-21 11:21:08 UTC
|
||||
+++ src/ui/Painter.h
|
||||
@@ -3,6 +3,7 @@
|
||||
#include <QFontMetrics>
|
||||
#include <QPaintDevice>
|
||||
#include <QPainter>
|
||||
+#include <QPainterPath>
|
||||
#include <QtGlobal>
|
||||
|
||||
class Painter : public QPainter
|
|
@ -1,8 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= spectral
|
||||
PORTVERSION= 603
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 817
|
||||
CATEGORIES= net-im
|
||||
|
||||
MAINTAINER= adridg@FreeBSD.org
|
||||
|
@ -13,20 +12,17 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
|
||||
BUILD_DEPENDS= libqmatrixclient>=0.5.3.2:net-im/libqmatrixclient
|
||||
|
||||
USES= compiler:c++17-lang gl pkgconfig qmake qt:5 tar:bz2
|
||||
USES= cmake compiler:c++17-lang gl pkgconfig qt:5 tar:bz2
|
||||
USE_GL= gl
|
||||
USE_QT= core dbus declarative graphicaleffects gui imageformats \
|
||||
multimedia network quickcontrols quickcontrols2 svg widgets \
|
||||
buildtools_build linguist_build qmake_build
|
||||
|
||||
USE_GITLAB= yes
|
||||
GL_ACCOUNT= b0
|
||||
GL_ACCOUNT= spectral-im
|
||||
GL_PROJECT= spectral \
|
||||
SortFilterProxyModel:sfpm
|
||||
GL_COMMIT= 4ef8e1efd95cd8de3f5c215d2ed27754d8e8c11a \
|
||||
GL_COMMIT= 8d6e69d5529b932b85a2f5e6774de27a267a2ace \
|
||||
c61f2bdb0da48804a596a9a3a9382eebdba764dc:sfpm
|
||||
GL_SUBDIR= include/SortFilterProxyModel:sfpm
|
||||
|
||||
QMAKE_ARGS+= USE_SYSTEM_QMATRIXCLIENT=true
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
TIMESTAMP = 1559832001
|
||||
SHA256 (b0-spectral-4ef8e1efd95cd8de3f5c215d2ed27754d8e8c11a_GL0.tar.gz) = 21a042072c1e04e4129d1786f2e5143cb35f408cd692065867f67dc4085615cb
|
||||
SIZE (b0-spectral-4ef8e1efd95cd8de3f5c215d2ed27754d8e8c11a_GL0.tar.gz) = 868460
|
||||
SHA256 (b0-SortFilterProxyModel-c61f2bdb0da48804a596a9a3a9382eebdba764dc_GL0.tar.gz) = 1c2ba6d6926192e0c5e20aa9270d77accce4649a780f957a0b95f5c9d375050b
|
||||
SIZE (b0-SortFilterProxyModel-c61f2bdb0da48804a596a9a3a9382eebdba764dc_GL0.tar.gz) = 32084
|
||||
TIMESTAMP = 1588512516
|
||||
SHA256 (spectral-im-spectral-8d6e69d5529b932b85a2f5e6774de27a267a2ace_GL0.tar.gz) = cc6ed91feb4af8078f0185fd64570c43d5c877030c255a011c7bfe9522e2505b
|
||||
SIZE (spectral-im-spectral-8d6e69d5529b932b85a2f5e6774de27a267a2ace_GL0.tar.gz) = 845196
|
||||
SHA256 (spectral-im-SortFilterProxyModel-c61f2bdb0da48804a596a9a3a9382eebdba764dc_GL0.tar.gz) = 2403a578fc5b3e46ad1c3b14e71590ca4aaa00c521958020cd925e05fadc32c1
|
||||
SIZE (spectral-im-SortFilterProxyModel-c61f2bdb0da48804a596a9a3a9382eebdba764dc_GL0.tar.gz) = 18483
|
||||
|
|
Loading…
Reference in a new issue