security/denyhosts: Convert to USE_PYTHON=pep517

- Bump PORTREVISION for package change
This commit is contained in:
Po-Chuan Hsieh 2024-03-23 22:18:59 +08:00
parent 307bccbbf8
commit f76cd2c801
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
2 changed files with 14 additions and 3 deletions

View File

@ -1,5 +1,6 @@
PORTNAME= denyhosts
PORTVERSION= 3.1.2
PORTREVISION= 1
CATEGORIES= security
PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
MASTER_SITES= https://github.com/denyhosts/denyhosts/releases/download/v${PORTVERSION:R}/
@ -12,11 +13,12 @@ WWW= https://github.com/denyhosts/denyhosts
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${RUN_DEPENDS}
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipaddr>=0:devel/py-ipaddr@${PY_FLAVOR}
USES= cpe python shebangfix
USE_PYTHON= autoplist concurrent distutils
USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
USE_RC_SUBR= denyhosts

View File

@ -1,6 +1,6 @@
--- setup.py.orig 2020-05-08 14:20:42 UTC
+++ setup.py
@@ -13,8 +13,8 @@ from DenyHosts.util import normalize_whitespace
@@ -13,8 +13,8 @@ etcpath = "/etc"
from DenyHosts.version import VERSION
etcpath = "/etc"
@ -11,6 +11,15 @@
scriptspath = ospj("scripts", libpath)
pluginspath = ospj("plugins", libpath)
denyhostsman = 'denyhosts.8'
@@ -40,7 +40,7 @@ setup(
)
setup(
- name="DenyHosts",
+ name="denyhosts",
version=VERSION,
description="DenyHost is a utility to help sys admins thwart ssh hackers",
author="Jesse Smith",
@@ -50,10 +50,6 @@ setup(
package_dir={'DenyHosts': 'DenyHosts'},
packages=["DenyHosts"],