Update to 2.6.8.
This commit is contained in:
parent
e884039b93
commit
f7cdb2aaaa
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=175608
4 changed files with 11 additions and 33 deletions
|
@ -3,11 +3,10 @@
|
|||
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/irc/xchat/Makefile,v 1.5 2006/10/10 20:51:46 mezz Exp $
|
||||
# $MCom: ports-stable/irc/xchat/Makefile,v 1.1 2006/10/26 08:33:06 marcus Exp $
|
||||
|
||||
PORTNAME= xchat
|
||||
PORTVERSION= 2.6.6
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 2.6.8
|
||||
CATEGORIES= irc gnome ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://xchat.org/files/source/2.6/
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (xchat-2.6.6.tar.bz2) = 43c187582beb31e744c4c5a833a022b5
|
||||
SHA256 (xchat-2.6.6.tar.bz2) = c4b38d29e6a9872c8ffde27c8866d8c3b9f1fe6e227cef5fed39bc79f983d44c
|
||||
SIZE (xchat-2.6.6.tar.bz2) = 1098934
|
||||
MD5 (xchat-2.6.8.tar.bz2) = 940fd8560a4e4e5d905e53207c6cbb87
|
||||
SHA256 (xchat-2.6.8.tar.bz2) = 7e239a43c5e293da57a0ee8dc1e383d243ec44b00e682558db93be3d2752611f
|
||||
SIZE (xchat-2.6.8.tar.bz2) = 1184287
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
# Fixes two tab-nick-completion bugs:
|
||||
# 1. Crash when you type space-tab
|
||||
# 2. Critical glib warning when completion in a dialog-tab.
|
||||
--- src/fe-gtk/fkeys.c.orig Thu Aug 5 07:49:06 2004
|
||||
+++ src/fe-gtk/fkeys.c Mon Aug 16 22:54:58 2004
|
||||
@@ -1427,7 +1427,7 @@
|
||||
skip_len++;
|
||||
}
|
||||
else
|
||||
- cursor_pos = g_utf8_pointer_to_offset(text, g_utf8_offset_to_pointer(ch, 1));
|
||||
+ return 2;
|
||||
}
|
||||
|
||||
comp = skip_len;
|
||||
@@ -1608,7 +1608,8 @@
|
||||
list = list->next;
|
||||
}
|
||||
PrintText (sess, buf);
|
||||
- g_completion_free(gcomp);
|
||||
+ if (gcomp)
|
||||
+ g_completion_free(gcomp);
|
||||
return 2;
|
||||
}
|
||||
/* Only one matching entry */
|
|
@ -1,7 +1,4 @@
|
|||
bin/xchat
|
||||
%%DBUS%%bin/xchat-remote
|
||||
%%DBUS%%lib/xchat/plugins/dbus.la
|
||||
%%DBUS%%lib/xchat/plugins/dbus.so
|
||||
%%PERL%%lib/xchat/plugins/perl.la
|
||||
%%PERL%%lib/xchat/plugins/perl.so
|
||||
%%PYTHON%%lib/xchat/plugins/python.la
|
||||
|
@ -9,6 +6,8 @@ bin/xchat
|
|||
%%TCL%%lib/xchat/plugins/tcl.la
|
||||
%%TCL%%lib/xchat/plugins/tcl.so
|
||||
share/applications/xchat.desktop
|
||||
%%DBUS%%share/dbus-1/services/org.xchat.service.service
|
||||
share/locale/be/LC_MESSAGES/xchat.mo
|
||||
share/locale/de/LC_MESSAGES/xchat.mo
|
||||
share/locale/el/LC_MESSAGES/xchat.mo
|
||||
share/locale/es/LC_MESSAGES/xchat.mo
|
||||
|
@ -16,10 +15,14 @@ share/locale/fi/LC_MESSAGES/xchat.mo
|
|||
share/locale/fr/LC_MESSAGES/xchat.mo
|
||||
share/locale/gl/LC_MESSAGES/xchat.mo
|
||||
share/locale/hu/LC_MESSAGES/xchat.mo
|
||||
share/locale/it/LC_MESSAGES/xchat.mo
|
||||
share/locale/ja/LC_MESSAGES/xchat.mo
|
||||
share/locale/ko/LC_MESSAGES/xchat.mo
|
||||
share/locale/lt/LC_MESSAGES/xchat.mo
|
||||
share/locale/nl/LC_MESSAGES/xchat.mo
|
||||
share/locale/pa/LC_MESSAGES/xchat.mo
|
||||
share/locale/pt/LC_MESSAGES/xchat.mo
|
||||
share/locale/ru/LC_MESSAGES/xchat.mo
|
||||
share/locale/sq/LC_MESSAGES/xchat.mo
|
||||
share/locale/sr/LC_MESSAGES/xchat.mo
|
||||
share/locale/sv/LC_MESSAGES/xchat.mo
|
||||
|
|
Loading…
Reference in a new issue