finance/frontaccounting24: Update version 2.4.11=>2.4.12

The port has hard coded DEFAULT_VERSIONS= php=8.0 which is very much
unlikely to be. So for now update to the next version to add support for
php 8.1 and later.
This is required for the removal of php80

Approved by:	portmgr (blanket)
This commit is contained in:
Muhammad Moinur Rahman 2023-12-30 10:10:02 +01:00
parent 746aa3ee36
commit f7fbe95c36
4 changed files with 16 additions and 41 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= frontaccounting24
PORTVERSION= 2.4.11
PORTVERSION= 2.4.12
DISTVERSIONSUFFIX= ${PORTVERSION}
CATEGORIES= finance www
MASTER_SITES= SF/${DIST_SUBDIR}/FrontAccounting%202.4/${PORTVERSION}
@ -16,32 +16,31 @@ LICENSE_FILE= ${WRKSRC}/doc/license.txt
USES= cpe
USE_PHP+= mysqli session ctype zlib
WRKSRC= ${WRKDIR}/${DIST_SUBDIR}
NO_BUILD= yes
SUB_FILES= pkg-deinstall pkg-message
PORTDOCSARGS=
DEFAULT_VERSIONS+= php=8.0
WRKSRC= ${WRKDIR}/${DIST_SUBDIR}
OPTIONS_DEFINE= APACHE LIGHTTPD NGINX NLS DOCS
OPTIONS_DEFAULT= APACHE MYSQL_SERVER
OPTIONS_RADIO= RG1
OPTIONS_RADIO_RG1= MARIADB_CLIENT MYSQL_CLIENT MYSQL_SERVER
RG1_DESC= Database Connectivity
MARIADB_CLIENT_DESC= MariaDB client connector support
MYSQL_CLIENT_DESC= MySQL client connector support
MYSQL_SERVER_DESC= MySQL server support
NGINX_DESC= NGINX web server
RG1_DESC= Database Connectivity
APACHE_USES= apache:run php:web
DOCS_VARS_OFF= PORTDOCSARGS='-not -path "./doc*"'
LIGHTTPD_RUN_DEPENDS= lighttpd:www/lighttpd
LIGHTTPD_USES= php:web
MARIADB_CLIENT_USES= mysql:106m
MYSQL_CLIENT_USES= mysql:client
MYSQL_SERVER_USES= mysql:server
NGINX_RUN_DEPENDS= nginx:www/nginx
NGINX_USES= php:web
MYSQL_SERVER_USES= mysql:server
MYSQL_CLIENT_USES= mysql:client
MARIADB_CLIENT_USES= mysql:106m
NLS_USES= gettext
.include <bsd.port.options.mk>
@ -54,13 +53,9 @@ USES+= php:cgi php:cli
USE_PHP+= mysqli
.endif
.if !${PORT_OPTIONS:MDOCS}
PORTDOCSARGS= '-not -path "./doc*"'
.endif
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} . \
${STAGEDIR}${WWWDIR} ${PORTDOCSARGS})
@${MKDIR} ${STAGEDIR}${WWWDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} . \
${STAGEDIR}${WWWDIR} ${PORTDOCSARGS})
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1648556109
SHA256 (frontaccounting/frontaccounting-2.4.11.tar.gz) = 5ee17c063d68c1e84eeadf8b2a14b3bb2ca46db597fd508403c50644717addd9
SIZE (frontaccounting/frontaccounting-2.4.11.tar.gz) = 1874152
TIMESTAMP = 1703926379
SHA256 (frontaccounting/frontaccounting-2.4.12.tar.gz) = 6e4a0eaf388550655dcb696668bac977a2cb2f5f3e78ee14b7d61879b7c3e808
SIZE (frontaccounting/frontaccounting-2.4.12.tar.gz) = 1876122

View File

@ -1,15 +1,6 @@
--- includes/session.inc.orig 2021-12-04 13:45:21 UTC
--- includes/session.inc.orig 2022-07-13 06:00:09 UTC
+++ includes/session.inc
@@ -397,7 +397,7 @@ foreach ($installed_extensions as $ext)
ini_set('session.gc_maxlifetime', 36000); // moved from below.
$Session_manager = new SessionManager();
-$Session_manager->sessionStart('FA'.md5(dirname(__FILE__)), 0, '/', null, True);
+$Session_manager->sessionStart('FA'.md5(dirname(__FILE__)));
$_SESSION['SysPrefs'] = new sys_prefs();
@@ -431,9 +431,8 @@ if ($SysPrefs->error_logfile != '') {
@@ -432,9 +432,8 @@ if ($SysPrefs->error_logfile != '') {
to avoid unexpeced session timeouts.
Make sure this directory exists and is writable!
*/

View File

@ -1,11 +0,0 @@
--- includes/session.inc.orig 2021-12-04 13:45:21 UTC
+++ includes/session.inc
@@ -397,7 +397,7 @@ foreach ($installed_extensions as $ext)
ini_set('session.gc_maxlifetime', 36000); // moved from below.
$Session_manager = new SessionManager();
-$Session_manager->sessionStart('FA'.md5(dirname(__FILE__)), 0, '/', null, True);
+$Session_manager->sessionStart('FA'.md5(dirname(__FILE__)));
$_SESSION['SysPrefs'] = new sys_prefs();