- Update to 2.1.0
- Fix LICENSE - Fix RUN_DEPENDS - Fix configure handling - Fix desktop file categories - Simplify stripping - Switch to options helpers PR: 248149 Submitted by: amdmi3 Approved by: lme (maintainer)
This commit is contained in:
parent
6103f38236
commit
f80d69606f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=545817
4 changed files with 43 additions and 36 deletions
|
@ -2,21 +2,20 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= scummvm-tools
|
||||
PORTVERSION= 2.0.0
|
||||
PORTREVISION= 6
|
||||
PORTVERSION= 2.1.0
|
||||
CATEGORIES= games emulators
|
||||
MASTER_SITES= http://www.scummvm.org/frs/${PORTNAME}/${PORTVERSION}/
|
||||
|
||||
MAINTAINER= lme@FreeBSD.org
|
||||
COMMENT= Tools for use with the SCUMMVM game emulator
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
BUILD_DEPENDS= lame:audio/lame \
|
||||
flac:audio/flac \
|
||||
oggenc:audio/vorbis-tools
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
|
||||
libpng.so:graphics/png \
|
||||
libmad.so:audio/libmad \
|
||||
|
@ -25,50 +24,36 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
|
|||
libfreetype.so:print/freetype2
|
||||
|
||||
USES= compiler:c++11-lang gmake iconv tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
HAS_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ARGS+= --enable-verbose-build
|
||||
CONFIGURE_TARGET=
|
||||
|
||||
STRIP_FILES= construct_mohawk create_sjisfnt decine decompile degob \
|
||||
dekyra deriven descumm desword2 extract_mohawk gob_loadcalc \
|
||||
scummvm-tools-cli
|
||||
CONFIGURE_ARGS= --prefix="${PREFIX}" --enable-verbose-build
|
||||
|
||||
DESKTOP_ENTRIES="ScummVM Tools" \
|
||||
"" \
|
||||
"${DATADIR}/scummvmtools_128.png" \
|
||||
"${PORTNAME}" \
|
||||
"Games;" \
|
||||
"Utility;Compression;" \
|
||||
false
|
||||
|
||||
PORTDOCS= COPYRIGHT NEWS README TODO
|
||||
|
||||
OPTIONS_DEFINE= WXGTK DOCS
|
||||
OPTIONS_DEFAULT= WXGTK
|
||||
OPTIONS_DEFINE= WXGTK DOCS
|
||||
OPTIONS_DEFAULT=WXGTK
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MWXGTK}
|
||||
USE_WX= 2.8
|
||||
WX_COMP= wx:lib:build
|
||||
WX_CONFIG_ARGS= absolute
|
||||
GUI_BIN= tools_gui
|
||||
PLIST_SUB+= WX=""
|
||||
STRIP_FILES+= scummvm-tools
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-wxwidgets
|
||||
PLIST_SUB+= WX="@comment "
|
||||
.endif
|
||||
WXGTK_USE= WX=2.8
|
||||
WXGTK_VARS= WX_COMP=wx:lib:build WX_CONFIG_ARGS=absolute
|
||||
WXGTK_CONFIGURE_ENABLE= wxwidgets
|
||||
|
||||
pre-patch:
|
||||
@${REINPLACE_CMD} -e 's|wxgtk2-2.8-config|${WX_CONFIG:C/.*\///}|' \
|
||||
@${REINPLACE_CMD} -e 's|^\(_wxconfig=\).*|\1${WX_CONFIG:C/.*\///}|' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
pre-install:
|
||||
${STRIP_CMD} ${STRIP_FILES:S|^|${WRKSRC}/|}
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1528670348
|
||||
SHA256 (scummvm-tools-2.0.0.tar.bz2) = 79a6fc0be81c1ed8938ec996c05f67b67f40b1de514ff1a20efa919a70fc6c22
|
||||
SIZE (scummvm-tools-2.0.0.tar.bz2) = 969421
|
||||
TIMESTAMP = 1575995430
|
||||
SHA256 (scummvm-tools-2.1.0.tar.bz2) = 76a74b8f47d4ac3bd9a6126816ab42a927662c98f7b0e70ea64814459bcd31a4
|
||||
SIZE (scummvm-tools-2.1.0.tar.bz2) = 842819
|
||||
|
|
22
games/scummvm-tools/files/patch-configure
Normal file
22
games/scummvm-tools/files/patch-configure
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- configure.orig 2020-07-13 19:08:26 UTC
|
||||
+++ configure
|
||||
@@ -1672,16 +1672,12 @@ if test "$_wxwidgets" = auto ; then
|
||||
fi
|
||||
|
||||
if test "$_wxwidgets" = yes ; then
|
||||
- _wxincludes="`$_wxconfig --prefix="$_wxpath" --cflags`"
|
||||
- _wxlibs="`$_wxconfig --prefix="$_wxpath" --libs`"
|
||||
- _wxstaticlibs="`$_wxconfig --prefix="$_wxpath" --static --libs 2> /dev/null`"
|
||||
+ _wxincludes="`$_wxconfig --cflags`"
|
||||
+ _wxlibs="`$_wxconfig --libs`"
|
||||
+ _wxstaticlibs="`$_wxconfig --static --libs 2> /dev/null`"
|
||||
_wxstaticlibs=`echo $_wxstaticlibs | sed 's|-lpng||' | sed 's|-lz||'`
|
||||
# _wxstaticlibs may contain non-static libraries that we also have in _wxstaticlibs.
|
||||
# remove those to avoid dependency on non-static libraries
|
||||
-
|
||||
- # Use the compiler specified by wx-config. This is needed on some systems to get a working executable.
|
||||
- CXX="`$_wxconfig --cxx`"
|
||||
- LD=$CXX
|
||||
|
||||
echo_n "Checking for wxwidgets gui dev component... "
|
||||
has_wx_gui_dev=no
|
|
@ -4,12 +4,12 @@ bin/decine
|
|||
bin/decompile
|
||||
bin/degob
|
||||
bin/dekyra
|
||||
bin/deriven
|
||||
bin/deprince
|
||||
bin/descumm
|
||||
bin/desword2
|
||||
bin/extract_mohawk
|
||||
bin/gob_loadcalc
|
||||
%%WX%%bin/scummvm-tools
|
||||
%%WXGTK%%bin/scummvm-tools
|
||||
bin/scummvm-tools-cli
|
||||
%%DATADIR%%/detaillogo.jpg
|
||||
%%DATADIR%%/logo.jpg
|
||||
|
|
Loading…
Reference in a new issue