- Fix problem with new version of pyrex. It is not necessary as a dependency.
- Remove BROKEN state - Bump PORTREVISION Approved by: portmgr
This commit is contained in:
parent
8f54c06a08
commit
f811ef3fed
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202569
2 changed files with 26 additions and 7 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= soya3d
|
||||
PORTVERSION= 0.13.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://download.gna.org/soya/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -19,8 +20,7 @@ COMMENT= Very high level 3D engine for Python
|
|||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode \
|
||||
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging \
|
||||
${PYTHON_SITELIBDIR}/pysdl_mixer/sdl_mixer.so:${PORTSDIR}/audio/py-sdl_mixer \
|
||||
pyrexc:${PORTSDIR}/devel/pyrex
|
||||
${PYTHON_SITELIBDIR}/pysdl_mixer/sdl_mixer.so:${PORTSDIR}/audio/py-sdl_mixer
|
||||
LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
|
||||
GLEW.1:${PORTSDIR}/graphics/glew \
|
||||
openal.0:${PORTSDIR}/audio/openal \
|
||||
|
@ -50,8 +50,6 @@ DISTFILES+= SoyaTutorial-${SOYATUTVER}${EXTRACT_SUFX}
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
BROKEN= broken with current version of devel/pyrex
|
||||
|
||||
.if ${ARCH} == "amd64"
|
||||
CFLAGS += -fPIC
|
||||
.endif
|
||||
|
|
|
@ -1,6 +1,27 @@
|
|||
--- setup.py.orig Sun May 13 10:54:49 2007
|
||||
+++ setup.py Fri Aug 17 16:32:16 2007
|
||||
@@ -129,6 +129,7 @@
|
||||
--- setup.py.orig 2007-11-05 20:44:27.000000000 -0500
|
||||
+++ setup.py 2007-11-05 20:47:14.000000000 -0500
|
||||
@@ -22,6 +22,7 @@
|
||||
|
||||
# Modify the following if needed :
|
||||
USE_OPENAL = 1 # use OpenAL
|
||||
+HAVE_PYREX = 0
|
||||
#USE_OPENAL = 0
|
||||
|
||||
# Modify the following if needed :
|
||||
@@ -76,12 +77,6 @@
|
||||
SDISTING = ("sdist" in sys.argv[1:]) and not ("--help" in sys.argv[1:])
|
||||
|
||||
|
||||
-try:
|
||||
- from Pyrex.Distutils import build_ext
|
||||
- HAVE_PYREX = 1
|
||||
-except:
|
||||
- HAVE_PYREX = 0
|
||||
-
|
||||
HERE = os.path.dirname(sys.argv[0])
|
||||
#ODE_DIR = os.path.join(HERE, "ode-0.5")
|
||||
DEFINES = []
|
||||
@@ -129,6 +124,7 @@
|
||||
DEFINES.append(('SOYA_MACOSX',1))
|
||||
else:
|
||||
LIBS.append("openal")
|
||||
|
|
Loading…
Reference in a new issue