MFH: r458235 r458238
Fix after empty FLAVOR as make argument was forbidden Remove the use of submake, and use the parent's port shared library instead. While there, remove an obsolete sed line that does not match anything.
This commit is contained in:
parent
13221b9561
commit
f81b065f70
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q1/; revision=458243
2 changed files with 12 additions and 8 deletions
10
net/miniupnpc/files/patch-setup.py
Normal file
10
net/miniupnpc/files/patch-setup.py
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- setup.py.orig 2018-01-06 09:33:40 UTC
|
||||||
|
+++ setup.py
|
||||||
|
@@ -23,6 +23,6 @@ setup(name="miniupnpc",
|
||||||
|
description='miniUPnP client',
|
||||||
|
ext_modules=[
|
||||||
|
Extension(name="miniupnpc", sources=["miniupnpcmodule.c"],
|
||||||
|
- extra_objects=["libminiupnpc.a"])
|
||||||
|
+ libraries=["miniupnpc"])
|
||||||
|
])
|
||||||
|
|
|
@ -1,11 +1,12 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
CATEGORIES= net python
|
CATEGORIES= net python
|
||||||
|
PORTREVISION= 1
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
|
||||||
COMMENT= Python module for miniupnpc
|
COMMENT= Python module for miniupnpc
|
||||||
|
|
||||||
BUILD_DEPENDS= ${NONEXISTENT}:net/miniupnpc:build
|
LIB_DEPENDS= libminiupnpc.so:net/miniupnpc
|
||||||
|
|
||||||
MASTERDIR= ${.CURDIR}/../miniupnpc
|
MASTERDIR= ${.CURDIR}/../miniupnpc
|
||||||
|
|
||||||
|
@ -14,13 +15,6 @@ USE_PYTHON= autoplist distutils
|
||||||
|
|
||||||
PLIST= ${.CURDIR}/pkg-plist
|
PLIST= ${.CURDIR}/pkg-plist
|
||||||
|
|
||||||
post-patch:
|
|
||||||
${REINPLACE_CMD} 's/\(version\)="[^"]*"/\1="${PORTVERSION}"/' \
|
|
||||||
${WRKSRC}/setup.py
|
|
||||||
|
|
||||||
pre-build:
|
|
||||||
${CP} $$(make FLAVOR= -C ${MASTERDIR} -V WRKSRC)/libminiupnpc.a ${WRKSRC}
|
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/miniupnpc.so
|
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/miniupnpc.so
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue